Page 2 of 3

Re: Problem getting custom map to run on my map server [was:

Posted: 22 Dec 2010, 01:13
by nmaligec
From your reply above, it seems like you missed step 6.

There is a 2nd _import.txt file that you need to look at. It is inside the npc folder itself: /npc/_import.txt
Open this up and on a new line add:

import: npc/004-3/_import.txt


Note: I assume the folder you put _import _warps and _mobs is /npc/004-3/

Without that entry none of the commands you added will run, ie map:004-3.gat will not be called and the map server skips adding it to the list.

I hope this is the problem, if not I don't know what else could be wrong.

Re: Problem getting custom map to run on my map server [was:

Posted: 22 Dec 2010, 02:35
by shannonbrimer
that was the problem now i got a new problem lol the map-server reads the new map then shuts off this is what i saw in map-server


loading maps [11/63]: data\004-3.gat
16188 28024

Re: Problem getting custom map to run on my map server [was:

Posted: 22 Dec 2010, 04:30
by Freeyorp101
You need to export to wlk; simply changing the extension from tmx to wlk on a file in tmx format will not work.


---Freeyorp

Re: Problem getting custom map to run on my map server [was:

Posted: 22 Dec 2010, 05:23
by shannonbrimer
it shows WLK files in propertys. this is out outlock of the WLK files when i open it.

<?xml version="1.0" encoding="UTF-8"?>
<map version="1.0" orientation="orthogonal" width="200" height="100" tilewidth="32" tileheight="32">
<tileset firstgid="1" name="desert1" tilewidth="32" tileheight="32">
<image source="Documents and Settings/Owner/Desktop/New Folder/graphics/tiles/desert1.png"/>
</tileset>
<tileset firstgid="257" name="desert2" tilewidth="32" tileheight="32">
<image source="Documents and Settings/Owner/Desktop/New Folder/graphics/tiles/desert2.png"/>
</tileset>
<tileset firstgid="513" name="mountain" tilewidth="32" tileheight="32">
<image source="Documents and Settings/Owner/Desktop/New Folder/graphics/tiles/mountain.png"/>
</tileset>
<tileset firstgid="695" name="collision" tilewidth="32" tileheight="32">
<image source="Documents and Settings/Owner/Desktop/New Folder/graphics/tiles/collision.png"/>
</tileset>
<tileset firstgid="697" name="desert_x5" tilewidth="32" tileheight="32">
<image source="Documents and Settings/Owner/Desktop/New Folder/graphics/tiles/desert_x5.png"/>
</tileset>
<layer name="ground" width="200" height="100">
<data encoding="base64" compression="gzip">
H4sIAAAAAAAAC+3cQW6CQACG0RnPqEZdW923tWfr8c

[rest of file redacted by Crush]

Re: Problem getting custom map to run on my map server [was:

Posted: 22 Dec 2010, 07:33
by Crush
What you posted is a TMX file. You've just renamed the TMX to WLK. This will not work. You can't convert a file to a different format just by renaming it. The file type Windows shows in "properties" isn't reliable because it is only determined by the filename extension without actually looking at the content of the file.

To create a real .wlk file open the tmx in Tiled and export it to .wlk using the export plugin.

By the way, you can use the attachment feature of the forum to post large files. This keeps the forum readable.

question about tools/tmwcon

Posted: 22 Dec 2010, 07:39
by nmaligec
Since this is about maps, I got a quick question.

I can't get the map converter in the tools folder to work. Instead I just add mobs and warps with a text editor. Would it be necessary to add the objects in Tiled to the map if I do mobs/warps manually?

Also I heard a few people mention that the converter doesn't work properly. Is this true? Is there a preference for manual or for using the converter?

Re: Problem getting custom map to run on my map server [was:

Posted: 22 Dec 2010, 09:01
by shannonbrimer
i went to tile opened the map and went to export as and typed in 004-3.wlk and all i get is the giving filename doesnt have any known file extension

Re: Problem getting custom map to run on my map server [was:

Posted: 22 Dec 2010, 10:07
by nmaligec
Ok, that is weird. I can export no problem. I am using Tiled Qt 0.5, and when exporting it has .wlk as the default file type. Are you sure you are going to File and Export As? Just doing a Save As will NOT let you convert to a walk file.
Export as wlk.png
Export as wlk.png (12.79 KiB) Viewed 1782 times
If you are using Export, maybe check the version of Tiled you are using. At least I know for sure Qt 0.5 version will work. I downloaded it straight from
http://www.mapeditor.org/

Re: Problem getting custom map to run on my map server [was:

Posted: 22 Dec 2010, 22:07
by shannonbrimer
well i guess you found my problem im using 0.5.1 of the tiled

Re: Problem getting custom map to run on my map server [was:

Posted: 22 Dec 2010, 22:35
by shannonbrimer
ok the map loaded but its grey with the error: could not load map

error while loading maps/004-3.tmx.gz

Re: Problem getting custom map to run on my map server [was:

Posted: 22 Dec 2010, 22:38
by Crush
It seems to work server-sided. But now you have to add the map file to the client, too.

There are several ways to do that.

-Customdata zip file in user directory (Quick and dirty fix for you and potential other players on your server)
-Unpacked data files (Most convenient for yourself when you want to develop content)
-Custom update server (You need some webspace to set this up, but when you want others to play on your server, you will have to do this sooner or later anyway)

Choose your poison. Please also tell us your operating system, because two of the three steps above are operating-system dependent.

Re: Problem getting custom map to run on my map server [was:

Posted: 22 Dec 2010, 23:03
by shannonbrimer
webspace is my poison so others caqn enjoy the map too lol and i use windows xp for now hoping to transfer all my data to my laptop later which is ubuntu but laptop being worked on right now

Re: Problem getting custom map to run on my map server [was:

Posted: 23 Dec 2010, 07:41
by Crush
I was afraid of that, because I've never done this myself. Maybe someone else can help you better in this regard. But what you have to do to my knowledge is:

-Put all game data used by your server (graphics, maps, sounds etc.) in zip files
-use a tool to calcutate the adler32 checksums of the zip files
-create a resource2.txt (or is this an xml by now?) which lists all the updates with their checksums
-upload the zip files and the resource file to your website
-change some conf settings of the server to point the clients to your website

You can open http://updates.themanaworld.org with a common webbrowser for an example.

Re: Problem getting custom map to run on my map server [was:

Posted: 23 Dec 2010, 08:18
by shannonbrimer
well what about dirty fix can people still join my server if i do dirty fix and can they be able to go to the map if i do the dirty fix one

Re: Problem getting custom map to run on my map server [was:

Posted: 23 Dec 2010, 10:00
by Crush
They can when you give them a file and they put it into the correct directory.

1. create a new zip file
2. create a directory "maps" in it
3. put your map into the directory
4. Put the zip file into the customdata directory of the client machine. The path should be something along the line of C:\Documents and Settings\username\applicationData\Roaming\mana\customdata. Unfortunately I can't tell for sure right now. I am at work right now and the WinXP machine I have access to is in an active directory domain and thus the whole user directory here looks totally different from a usual home machine. The customdata directory very likely doesn't exist yet, but there should also be an update directory in the same place.