Page 2 of 3

Posted: 02 Jan 2006, 18:13
by Moonray
Manual compile (with --prefix=/home/me/tmw/) didn't solve the problem either. Help!

Posted: 02 Jan 2006, 18:39
by Platyna
You are gunzipped it without error?

Regards.

Posted: 02 Jan 2006, 19:29
by Moonray
Yep, no errors while gunzipping. But, even though there were no files to unzip, I still got the decompression error. Very weird.

Cheers.

Posted: 02 Jan 2006, 19:36
by flamma
I managed to gunzip all the maps (those in .tmw/updates/maps and /usr/share/games/tmw/data/maps). But nothing changes.

Removing .tmw directory don't fix anything. As don't fix creating a new character or registering a new account.

:?

Posted: 02 Jan 2006, 19:58
by Bjørn
Does portage allow for compiling olders versions of TMW, or could somebody try manually if not? Like 0.0.17? Then we would know whether this problem is caused by a change between the versions or by some external factor.

Posted: 02 Jan 2006, 20:50
by flamma
There isn't a ebuild older than the 0.0.18 one. I have this problem for a long time, so the version should be really old.

Is possible to connect to the server with such an old client?

Posted: 02 Jan 2006, 21:01
by Platyna
flamma wrote:I managed to gunzip all the maps (those in .tmw/updates/maps and /usr/share/games/tmw/data/maps). But nothing changes.

Removing .tmw directory don't fix anything. As don't fix creating a new character or registering a new account.

:?
Well, I just wanted to check it this is not zlib issue.

Regards.

Posted: 02 Jan 2006, 21:07
by ElvenProgrammer
flamma wrote:Is possible to connect to the server with such an old client?
At least with 0.0.17 should be possible.

Posted: 03 Jan 2006, 17:57
by Pajarico
flamma wrote:There isn't a ebuild older than the 0.0.18 one. I have this problem for a long time, so the version should be really old.

Is possible to connect to the server with such an old client?
I doubt that's truth :wink: This is in my system:

Code: Select all

lxuser@hal2000 ~ $ ls -l /usr/portage/games-rpg/tmw/
total 28
-rw-r--r--  1 root root 1851 Dec 26 22:05 ChangeLog
-rw-r--r--  1 root root  559 Dec 26 22:05 Manifest
drwxr-xr-x  2 root root 4096 Dec 26 22:05 files
-rw-r--r--  1 root root  158 May  5  2005 metadata.xml
-rw-r--r--  1 root root 1415 Oct  2 10:29 tmw-0.0.16-r1.ebuild
-rw-r--r--  1 root root 1435 Oct 13 21:05 tmw-0.0.17.ebuild
-rw-r--r--  1 root root 1430 Dec 26 21:38 tmw-0.0.18.ebuild
The thing is that if you wish to install older versions you have to explicitly tell 'emerge' the version number, like this:

Code: Select all

ACCEPT_KEYWORDS="~amd64" emerge -avl =tmw-0.0.1
Remember the =(equal sign)!!

Posted: 03 Jan 2006, 20:41
by flamma
I don't know why, but if you look at my system:

Code: Select all

mymachine ~ # ls -l /usr/portage/games-rpg/tmw/
total 24
-rw-r--r--  1 root root 1966 ene  2 02:07 ChangeLog
drwxr-xr-x  2 root root 4096 ene  2 02:07 files
-rw-r--r--  1 root root  668 ene  2 02:07 Manifest
-rw-r--r--  1 root root  158 may  5  2005 metadata.xml
-rw-r--r--  1 root root 1429 ene  2 02:05 tmw-0.0.18.1.ebuild
-rw-r--r--  1 root root 1430 dic 26 21:38 tmw-0.0.18.ebuild
mymachine ~ #
That's why I said what I said.

Posted: 04 Jan 2006, 07:23
by zbyte64
i did the same stuff as moonray did as well, no go. I tried versions 0.0.17 - 0.0.18.1 using the CVS as well as ebuilds....

Posted: 04 Jan 2006, 14:05
by Platyna
As far as I know there is an issue with gentoo ebuild...it some what provides old source. Try to download and compile the source from our download site and see if the same problem occurs. Also make sure you have physfs 1.0.x and guichan 4.0.x. What I would do at you place would be compiling these things manually, without ebuilds and diff sources on ebuild.

Regards.

Posted: 04 Jan 2006, 17:24
by Moonray
Platyna, as stated in a previous post, I downloaded the source provided by you, and compiled from scratch (after having removed all traces of tmw), and I still got the map error.

Posted: 04 Jan 2006, 19:11
by Pajarico
flamma, just checked that now the oldest ebuild is 0.18.1 :(. It got banished in the last sync (~20 hours ago). You can still get it at bugs.gentoo.org, thought, and put in the portage overlay.
But as platyna said, the best is to fetch the source directly from the downloads page.
As far as I know there is an issue with gentoo ebuild...it some what provides old source.
I don't understand what you mean...

Posted: 04 Jan 2006, 19:19
by Platyna
I mean exactly what I wrote. I have diffed source given me by a Gentoo user with TMW's 0.0.18.1 tarball - it is not the same.

Regards.