Page 1 of 1

Movement Glitch.

Posted: 16 Aug 2006, 10:21
by Pauan
Murrr... I FINALLY got it installed and the server running. I create my character, everything runs good so far... then the game starts. I click somewhere on the screen to move, and my character obediently does so. However, about 3 steps into the movement, he suddenly stops, turns around, and goes back to the upper-left corner. He then stays there, and even frantic mouse presses won't get him to move from the spot. I tried the calibration... but immediately afterwards, he now moves into the upper-RIGHT corner. In addition to this, the keyboard controls do not work at all.

I am using a moderately decent computer running Ubuntu, and am also using a USB tablet and a USB keyboard. Might this have something to do with the problem?

EDIT: Here are some screenshots... they are in chronological order. After dieing or starting the game, I end up in the upper-right corner, as shown in screenshot 1. I then click rapidly many times in a second, allowing me to move to the lower-left a little ways, as shown in screenshot 2. But if I stop frantically clicking, I immediately return back to the upper-right corner, as shown in screenshot 3. This is very hard, seeing as how I am unable to actually attack anything without returning back to the starting point...

Image

Image

Image

Posted: 16 Aug 2006, 10:49
by ElvenProgrammer
Have you got a joystick? Try to unplug it.

Posted: 16 Aug 2006, 11:14
by Pauan
ElvenProgrammer wrote:Have you got a joystick? Try to unplug it.
No I do not have a joystick plugged in. The only devices connected to my computer are the tablet, keyboard, ethernet cord, sound, monitor, etc. etc. No joystick, however.

EDIT: I tried unplugging and replugging in my keyboard... now it works. The only problem is that now the cursor disappears whenever I stop clicking, and of course the collision-detection is off. I understand that the team is working on improving the collision-detection however.

Posted: 16 Aug 2006, 15:33
by Modanung
Collision-detection off? :?
Are you using your own server or something?

Posted: 16 Aug 2006, 18:44
by Rapier
I've actually run into the same problem a time or two.

I will be auto-attacking (ctrl-shift) and all the sudden I run in a direction. I have to close the program and re-open it to move out of a corner.

Posted: 16 Aug 2006, 23:48
by Bjørn
Even though you may not have a joystick, I would suggest you still try clicking that calibration button. At least it solved quite the same problem for this guy:

http://forums.themanaworld.org/viewtopic.php?p=16517

Posted: 17 Aug 2006, 00:51
by Pauan
@ Modanung: I wouldn't even know how. I am using the usual Mana Server that I'm guessing everybody else is using, since there were some other people around. When I say collision-detection is off, what I mean is that I can click on a monster from several feet away, and still attack it. Yet if I'm standing right in front of it, it takes several clicks to get me to attack it. I get much the same problem with the keyboard. Also, one other thing is what when I DO attack the monster, if it was facing up, it will attack upwards, even if I'm below it. Same for me: if I'm facing to the left, with the monster to my right, I will attack to the left and yet the monster still gets hit. I am not sure if this is something that is still being worked on, or if it's a problem with me only....

Also... I just logged in, here's the server I'm connecting to:
217.172.177.27
Mana World (9)

I'm guessing the 9 is showing how many people are playing at the moment, seeing as how it changes each time I log-in.

@ Rapier: That has not happened to me yet, but I will keep an eye out for it! For me, the problem happened the instant I started the game, which meant I had no chance to even attack a monster.

@ Bjørn: As I said, after clicking on it, my character went to the upper-RIGHT corner rather than the upper-left. However, it seems to be solved now... I had to unplug and replugin my keyboard.

Posted: 17 Aug 2006, 01:03
by Crush
Pauan wrote:When I say collision-detection is off, what I mean is that I can click on a monster from several feet away, and still attack it. Yet if I'm standing right in front of it, it takes several clicks to get me to attack it. I get much the same problem with the keyboard. Also, one other thing is what when I DO attack the monster, if it was facing up, it will attack upwards, even if I'm below it. Same for me: if I'm facing to the left, with the monster to my right, I will attack to the left and yet the monster still gets hit. I am not sure if this is something that is still being worked on, or if it's a problem with me only....
all that attacking stuff will have to be rewritten anyway with V. 0.1

Posted: 17 Aug 2006, 04:36
by Pauan
Gotcha. One other thing... when I leveled up, I had 6 points to spend. I clicked once on Agility, which cost 3 points. Yet it took all 6 of my points. I am not sure yet whether it added it twice... or merely added it once with the cost of 6 points. I don't consider this that huge of a bug however... seeing as how it's only happened once. Perhaps I accidently clicked on it twice really really fast...?

EDIT: I was selling some items I had gotten when the game suddenly quit! Luckily, I had my terminal open... here is what it said:

tmw: gui/sell.cpp:198: virtual void SellDialog::action(const std::string&): Assertion `mAmountItems < mMaxItems' failed.
Aborted

I hope you guys can make sense out of that...

Posted: 17 Aug 2006, 21:41
by Bjørn
Pauan wrote:tmw: gui/sell.cpp:198: virtual void SellDialog::action(const std::string&): Assertion `mAmountItems < mMaxItems' failed.
Aborted
Thanks for reporting this. Apparently when you pressed the + button, the value of the amount of items had already reached the maximum. In this case, the + button is supposed to be disabled. We should look into why might have been apparently not the case.

Posted: 18 Aug 2006, 00:34
by Maughetar
I also have a movement glitch. I compiled a ppc ubuntu version of the game, however my character always moves towards the bottom of the screen. I tried clicking calibrate joystick, and nothing happened (is it supposed to?). Would it be possible to compile without joystick support?

Posted: 18 Aug 2006, 02:42
by Pauan
Bjørn wrote:Thanks for reporting this. Apparently when you pressed the + button, the value of the amount of items had already reached the maximum. In this case, the + button is supposed to be disabled. We should look into why might have been apparently not the case.
It happened a couple more times. Not that big of a deal though... since it saves all of my info periodically, I don't lose anything.

Also... the movement glitch keeps coming back... however, I DID figure out the problem! If I unplug my keyboard, hit the calibrate button, then, without hitting the stop button, hit the Apply button... it works! I can then plug my keyboard back in no problem. The problem comes back when I restart my computer, but other than that it works great.

Posted: 19 Aug 2006, 15:06
by Maughetar
Randomly fixed after a restart :)