"This account is already logged in" every disconnect

Ask for help regarding any technical issue or report any bug or OS independent issues.
Post Reply
Lucifer
Peon
Peon
Posts: 63
Joined: 06 Oct 2013, 15:35

"This account is already logged in" every disconnect

Post by Lucifer » 01 Aug 2014, 23:41

Every time I am disconnected from the server (e.g. due to wifi packet loss), I click OK, login, try to enter world, receive the message "this account is already logged in" and have to log in again. Every time. It's annoying and unnecessary. How do I avoid it? I'm not interested in analyzing code and compiling my own client. This is with manaplus 1.4.7.19 and at least some earlier versions.
User avatar
o11c
Knight
Knight
Posts: 2262
Joined: 20 Feb 2011, 22:09
Location: ^ ^

Re: "This account is already logged in" every disconnect

Post by o11c » 02 Aug 2014, 08:57

Most likely there's something wrong at your ISP. I've had it myself, adding an iptables rule to ignore incoming RST bits fixed it for me.

... wait, I think I'm being insufficiently paranoid.

Gestapo aside, I have vague plans to disconnect all idle connections which will fix this.
Former programmer for the TMWA server.
Lucifer
Peon
Peon
Posts: 63
Joined: 06 Oct 2013, 15:35

Re: "This account is already logged in" every disconnect

Post by Lucifer » 07 Aug 2014, 16:20

Something is wrong at Comcast? Ha... ha.. ha...
User avatar
iahc
Newly Registered User
Posts: 7
Joined: 12 Oct 2014, 00:04
Location: sArgentina >planet earth> solar system> via lactea galaxy > universe

Re: "This account is already logged in" every disconnect

Post by iahc » 16 Oct 2014, 16:18

It's not client/server related problem. always you will see you account is logged in because your character is still in the world of mana!!!, when you log in and server note that you're "out" of your account, it logout your char/acc, and now u can log in, be patient, other wise contract another ISP or an powerful wifi antenna, client/server is doing things correctly. sorry.
Crazyk8e
Peon
Peon
Posts: 60
Joined: 12 Jul 2011, 18:54

Re: "This account is already logged in" every disconnect

Post by Crazyk8e » 16 Oct 2014, 23:46

o11c wrote:Gestapo aside, I have vague plans to disconnect all idle connections which will fix this.
I assume by idle you mean AFK?

Oh and I have had issues with this too OP you are not alone. :)
User avatar
o11c
Knight
Knight
Posts: 2262
Joined: 20 Feb 2011, 22:09
Location: ^ ^

Re: "This account is already logged in" every disconnect

Post by o11c » 17 Oct 2014, 02:06

Crazyk8e wrote: I assume by idle you mean AFK?
Not really. I mean any client that is not sending any traffic. Normally manaplus send a ping packet once every second while connected to the map server.

For the login and char servers I'll have to do something different, not sure what.
Former programmer for the TMWA server.
Post Reply