Page 1 of 1

No taskbar button

Posted: 20 Apr 2016, 01:32
by Ecuador
ManaPlus 1.6.4.9 on Linux Mint 17.3 with Cinnamon. I'm not getting taskbar button for Manaplus, so suppose I'm on my web-browser and have to switch to Manaplus then I'm using alt+tab to switch.

Re: No taskbar button

Posted: 20 Apr 2016, 01:42
by 4144
Probably you enabled in manaplus settings option "no frame"?
If not, this can be your DE/WM bug.

Re: No taskbar button

Posted: 20 Apr 2016, 02:56
by Ecuador
4144, thanks for quick reply, I think I should have told before:

I first followed the M+ installation instructions given here:
http://manaplus.org/ubuntu
That's, first installed the add repo .deb file, then did:
sudo aptitude update
But at this point I got this or similar error:

Code: Select all

W: Failed to fetch http://repo.evolonline.org/manaplus/dists/rosa/main/binary-amd64/Packages: 404  Not Found [IP: 88.191.250.18 80]
W: Failed to fetch http://repo.evolonline.org/manaplus/dists/rosa/main/binary-i386/Packages: 404  Not Found [IP: 88.191.250.18 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.
E: Couldn't rebuild package cache
I proceeded with the next command:
sudo aptitude install manaplus
Manaplus installed but was older version (maybe installed through default repo of my operating system). As far as I remember this old version of M+ was having taskbar button.
Then to get newer version I opened synaptic package manager and changed this repo:
deb http://repo.evolonline.org/manaplus rosa main
(I've Linux Mint 17.3 "Rosa")
to
deb http://repo.evolonline.org/manaplus trusty main
(Changed "rosa" to "trusty" as I think Mint Rosa is based on Ubuntu Trusty)
Then I don't remember whether I did "sudo aptitude update" again, maybe I did. But then I surely did this again:
sudo aptitude install manaplus
This installed the latest version but with it I'm having the no taskbar button problem.

Re: No taskbar button

Posted: 20 Apr 2016, 12:51
by 4144
Try check settings.
Open settings, video tab and see option "no frame" it should be disabled.
If it already, look like this is bug in DE (Cinnamon).
I can only suggest search manaplus.desktop or manaplus.menu file and try remove it, may be it can help.

Re: No taskbar button

Posted: 05 Dec 2018, 10:00
by Ecuador
Notes to self:
"no frame" is already disabled.
Deleting manaplus.desktop file didn't work.
manaplus.menu didn't exist in whole of my linux system. (Just experienced that the search tool of my system isn't reliable.)