Page 1 of 1

General Troubleshooting Thread

Posted: 19 Oct 2019, 20:21
by jesusalva

These are some common troubleshooting problems for ManaPlus under different plataforms.

Android Issues
If the app crash right after opening:
-> Grant it storage permissions

Linux Issues
If you cannot install:
-> Have you tried building from the sources?
-> Have you tried an AppImage?

Protip 1: To install from the sources, read the README. If you're using an Apt-get compatible system (like Raspberry PI or Ubuntu) you can try this unofficial script by Jesusalva.

Protip 2: There are no official AppImages yet, but LawnCable have some unofficial AppImages in his private Git repository. The source code for building them is open source. USE THEM AT YOUR OWN RISK.

If you cannot copy/paste:
-> Do you have xsel installed?
-> Did you try rebuilding/reinstalling ManaPlus after installing xsel? (Shouldn't be required)

Repository outdated?
-> Have you tried contacting the repository maintainer?

Non-specific issues
Keep being pushed back while moving?
-> Go to Settings → Misc → Moving → Sync Movement Distance
-> Set it to 20 or more (may cause desync between client and server)

Player nicknames are being drawn above each other!
-> Go to Settings → Players → Automatically Move Names
-> Check the box. You may need to restart client to changes have effect.

Player XYZ is verbally abusing me!
-> Right click player
-> Click on "Ignore"

Animated tiles are not rendering properly on Software render mode!
-> Go to Settings → Performance → Best Performance → Enable map reduction (Software)
-> Disable it.

When I go in a packed area, the game freezes and lags for way too long! (In software mode)
-> Go to Settings → Performance → Less Memory → Disable Advanced Cache (Software)
-> Disable it. (Note: Do not do this on a weak computer!)

Game freezes/crashes if a Minimize and then Maximize it again!
-> This is usually a Windows issue, which happens to save CPU power when minimized.
-> Alt 1: Change to Software Render Mode. Ensure it is SDL 1.2 instead of SDL 2.

IF YOU HAVE ISSUES WHICH YOU FEEL THEY ARE COMMON, FEEL FREE TO POST THE WORKAROUNDS HERE
(Subject to strict moderation)


Re: General Troubleshooting Thread

Posted: 14 Apr 2020, 02:55
by Syzlack
Hello Guys,

It's been a while since I log in and I'm having an issue with the manaplus app on windows machine. I select the main server "server.themanaworld.org" and it just sits there in "Connecting to server" and nothing happens.

Is that server active?


Regards,
Syzlack

Re: General Troubleshooting Thread

Posted: 14 Apr 2020, 07:20
by jesusalva
Syzlack wrote: 14 Apr 2020, 02:55 Hello Guys,

It's been a while since I log in and I'm having an issue with the manaplus app on windows machine. I select the main server "server.themanaworld.org" and it just sits there in "Connecting to server" and nothing happens.

Is that server active?


Regards,
Syzlack
Yes, it most likely is either due bad connectivity or the use of proxies/tor/etc.

Re: General Troubleshooting Thread

Posted: 27 Aug 2020, 03:18
by Syzlack
jesusalva wrote: 14 Apr 2020, 07:20
Syzlack wrote: 14 Apr 2020, 02:55

Hello Guys,

It's been a while since I log in and I'm having an issue with the manaplus app on windows machine. I select the main server "server.themanaworld.org" and it just sits there in "Connecting to server" and nothing happens.

Is that server active?

Regards,
Syzlack

Yes, it most likely is either due bad connectivity or the use of proxies/tor/etc.

Hey Jesusalva,

I tried removing any possible proxy and I'm still getting stuck in "Connecting to server". I checked the setting and I'm connecting to server.themenawaworld.org on port 6901, with server type TmwAthena.

Any idea guys?


Re: General Troubleshooting Thread

Posted: 27 Aug 2020, 03:27
by jesusalva
Syzlack wrote: 27 Aug 2020, 03:18
jesusalva wrote: 14 Apr 2020, 07:20
Syzlack wrote: 14 Apr 2020, 02:55

Hello Guys,

It's been a while since I log in and I'm having an issue with the manaplus app on windows machine. I select the main server "server.themanaworld.org" and it just sits there in "Connecting to server" and nothing happens.

Is that server active?

Regards,
Syzlack

Yes, it most likely is either due bad connectivity or the use of proxies/tor/etc.

Hey Jesusalva,

I tried removing any possible proxy and I'm still getting stuck in "Connecting to server". I checked the setting and I'm connecting to server.themenawaworld.org on port 6901, with server type TmwAthena.

Any idea guys?

Good evening!

Have you tried accessing server.themanaworld.org from a web browser?
It should show the online list. This means problem is with ports.

If it does not, then the problem might be with the domain itself, and you might want to use a mirror instead (or even use the IP).

For the record, the mirror for server.themanaworld.org is server2.themanaworld.net

(PS. server.themanaworld.net might NOT allow you to login!)


Re: General Troubleshooting Thread

Posted: 16 Apr 2021, 16:24
by Clort

I just have to say things work great here :) Real solid.

Now UI-wise there's a lot of tweaks to Manaplus I could think of. Like keyboard support would make transferring to/from storage way faster. Arrow keys around inven, enter to select, type number to transfer. No extra steps. Mousing around for that is painfully slow.