Page 1 of 1

Trying to build...account server troubles [Solved] next Q?

Posted: 05 May 2008, 04:04
by MrDan
I am trying to compile the server for my use at home..

I was able to build the gameserver with no problems.

when I tried to build the accountserver I got 6 errors. I suspect I may have missed some dependencies. I will list the error log below. My search-foo is weak so please don't nark me for not googleing as I did and am drowning in the results staring with eyes glazed over and mumbling to myself. :shock: Please help! :oops:

Thanks

Dan

I used Code::blocks to build.
log :
*****************************Update******************
Installed openssl and now log is only one error:


-------------- Build: default in TMWServ Accountserver ---------------

Linking console executable: accountserver.exe
C:\Program Files\CodeBlocks\MinGW\bin\ld.exe: cannot find -lcrypto
collect2: ld returned 1 exit status
Process terminated with status 1 (0 minutes, 0 seconds)
1 errors, 0 warnings

*****************************
Searching and searching for how to either install the lcrypto or remove the reference to it..

Also, I am sorry for placing this in unix support I should have and meant to put in windows support


I am soo close I know it is something real easy but alas, today is not my day.

Maybe tomorrow ;)

Re: Trying to build server gameserver ok account server troubles

Posted: 05 May 2008, 05:09
by Sanga
The "cannot find -lcrypto" pretty much explains it - the linker was unable to find the "libcrypto" library. Which means either you have a configuration problem, or that the library simply isn't installed.

A request for clarification: This is posted under "Unix Support", but it appears you're building on Windows.

Re: Trying to build server gameserver ok account server troubles

Posted: 05 May 2008, 05:19
by MrDan
Yah ooppse sorry.. I wish I could move this.

it has been a hard day. :oops:

Re: Trying to build server gameserver ok account server troubles

Posted: 05 May 2008, 13:07
by ElvenProgrammer
You can safely remove libcrypto from dependencies in project properties

Re: Trying to build server gameserver ok account server troubles

Posted: 05 May 2008, 16:12
by MrDan
K thanks I will try that when I get home. 8)

***********Edit below*****************


Yup that did the trick thanks! :D

now I am looking for tutorial or instructions on what to do now. :?

I copied some xml files (monsters, maps...)cant find one or how to make the appropiate character file and gm-character files and when I execute the batch file the game server opens and account server opens but how do you connect? where do you put the info like ip info and stuff. I searched this forum and havent found much info other than some problems. I see that the dos windows are indicating that they are waiting. and the game server window starts counting game time.

Should this be another thread separate from this one?