Ask for help regarding any technical issue or report any bug or OS independent issues.
#129296 by baseballboy
Mon Dec 17, 2012 11:26 pm
I'm running OS X 10.8.2. It installed and downloaded the updates fine but when I went into a warp it crashed and now I can't reopen, ( I went from 009-1 to 009-2)
#129297 by Frost
Mon Dec 17, 2012 11:30 pm
ManaPlus for MacOS! Thank you, 4144!

Unfortunately, the app crashes when I load it on 10.6.8. My computer has libcurl 6.0.0 and it appears to require libcurl 7. Maybe it requires a newer version of OSX?
#129298 by 4144
Mon Dec 17, 2012 11:54 pm
Frost wrote:ManaPlus for MacOS! Thank you, 4144!

Unfortunately, the app crashes when I load it on 10.6.8. My computer has libcurl 6.0.0 and it appears to require libcurl 7. Maybe it requires a newer version of OSX?


Hm, may be.

This build by socapex. He now busy, after i will ask him.
May be he can include libcurl inside dmg.
#129308 by Nard
Tue Dec 18, 2012 10:31 am
I try it immediately :D :D :D
#129315 by Nard
Tue Dec 18, 2012 7:18 pm
Frost wrote:ManaPlus for MacOS! Thank you, 4144!

Unfortunately, the app crashes when I load it on 10.6.8. My computer has libcurl 6.0.0 and it appears to require libcurl 7. Maybe it requires a newer version of OSX?


It seems that libcurl version should be greater than 7 (7.9.6) even in 10.6 :
https://developer.apple.com/library/mac/#documentation/Darwin/Reference/ManPages/man3/libcurl.3.html
:/
#129351 by Nard
Thu Dec 20, 2012 2:15 pm
Ihave the same problem as Frost:
Code: Select allProcess:         ManaPlus [1815]
Path:            /Applications/ManaPlus.app/Contents/MacOS/ManaPlus
Identifier:      evolonline.ManaPlus
Version:         ??? (???)
Code Type:       X86-64 (Native)
Parent Process:  launchd [406]

Date/Time:       2012-12-20 13:31:54.183 +0100
OS Version:      Mac OS X 10.6.8 (10K549)
Report Version:  6

Exception Type:  EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread:  0

Dyld Error Message:
  Library not loaded: /usr/lib/libcurl.4.dylib
  Referenced from: /Applications/ManaPlus.app/Contents/MacOS/ManaPlus
  Reason: Incompatible library version: ManaPlus requires version 7.0.0 or later, but libcurl.4.dylib provides version 6.0.0

Binary Images:
    0x7fff5fc00000 -     0x7fff5fc3bdef  dyld 132.1 (???) <B536F2F1-9DF1-3B6C-1C2C-9075EA219A06> /usr/lib/dyld

though:
Man wrote: [...] .
libcurl 7.9.6 19 March 2002 libcurl(3)


http://curl.haxx.se/download.html gives links to last versions (7.28.1). second and third links are for macports and fink use. opensource.apple has an xcode project of 7.28.4 at: http://www.opensource.apple.com/source/ ... -69.2/curl ... :/
#129371 by Socapex
Fri Dec 21, 2012 12:37 am
Hey everyone, thanks for the full error log. I am including many macports libraries in the release, this was to be expected. I will look into it and will upload a new version which hopefully fixes this.

If you encounter another problem like this, please post the full log (as I need to know exactly which library it is pointing to).

From what I see, OSX 10.8 provides the latest libcurl (libcurl.4 that is 7.0.0 compatible), but not 10.6. I will try including it and post an update here for ppl to test. These types of errors are to be expected while I figure out every library (and it's dependencies) that are required for 10.6.

Thanks for helping out!

edit:

Is any body here somewhat used to the terminal? If so, until I reinstall a 10.6 OSX, could you
Code: Select allcd to /usr/lib

and then post here the output of
Code: Select allotool -L libcurl.dylib

It would be very much appreciated :)
#129372 by Nard
Fri Dec 21, 2012 12:49 am
Man page refers to v 7.9.6 maybe it is worth a report?

Another trick: I noticed that libcurl.4.dylib is just an alias that points to libcurl.dylib ;/

Code: Select alllocalhost:downloads root# cd /usr/lib
localhost:lib root# otool -L libcurl.dylib
libcurl.dylib:
   /usr/lib/libcurl.4.dylib (compatibility version 6.0.0, current version 6.1.0)
   /usr/lib/libssl.0.9.8.dylib (compatibility version 0.9.8, current version 0.9.8)
   /usr/lib/libcrypto.0.9.8.dylib (compatibility version 0.9.8, current version 0.9.8)
   /usr/lib/libz.1.dylib (compatibility version 1.0.0, current version 1.2.3)
   /System/Library/Frameworks/LDAP.framework/Versions/A/LDAP (compatibility version 1.0.0, current version 2.2.0)
   /System/Library/Frameworks/Kerberos.framework/Versions/A/Kerberos (compatibility version 5.0.0, current version 5.0.0)
   /usr/lib/libresolv.9.dylib (compatibility version 1.0.0, current version 41.1.0)
   /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 125.2.11)
localhost:lib root#
#129392 by Socapex
Sat Dec 22, 2012 1:17 am
I've sent a new version to 4144. From what I see it should work, as Snow Leopard provides all the correct dependencies with the correct compatibility versions. For further testing, it would certainly be nice to include the libcurl dependencies, so we would all be at exactly the same library versions.

@Nard: Yes, most dylibs are only aliases. What we want here is libcurl.4.
#129402 by 0x0BAL
Sat Dec 22, 2012 7:33 am
It's working perfectly on os x lion.
But it lags when I try to enter to some building like the strove or the Inn in hurscland.
#129403 by o11c
Sat Dec 22, 2012 8:28 am
0x0BAL wrote:it lags when I try to enter to some building

Try disabling music.
#129425 by Alige
Sun Dec 23, 2012 10:46 am
Socapex made new versions that should work better than the previous ones. One is for 10.6 and the other for 10.7+. Note that the version for 10.6 does not have translations thus you must speak english to understand the client correctly.
ManaPlus - Mac OS X

If you experience any bug at all, feel free to post it here along with your Mac OS X version. The more details you give, the better. Be aware that we are still working very hard on it in order to make the building process be much more easier.

Enjoy,
--Alige

Who is online

Users browsing this forum: No registered users and 3 guests