[SOLVED] Error: Couldn't load male player spriteset!

Ask for help regarding any technical issue or report any bug or OS independent issues.
Locked
TonySP
Peon
Peon
Posts: 2
Joined: 16 Nov 2006, 17:11
Location: Santa Catarina - Brazil

[SOLVED] Error: Couldn't load male player spriteset!

Post by TonySP » 16 Nov 2006, 17:35

Hi,
i have compiled the game, with all the dependencies, but when i run i get this error:
Error: Couldn't load male player spriteset!
But when i look at /usr/share/tmw/data/graphics/sprites/ i found the file player_male_base.png and player_male_base.xml...
Any ideas?
I'm using Slackware 11, XFce4, kernel 2.6.18.1, gcc 3.4.6
My configure uses --prefix=/usr --sysconfdir=/etc --with-opengl
thx
User avatar
ElvenProgrammer
TMW Adviser
TMW Adviser
Posts: 2526
Joined: 13 Apr 2004, 20:11
Location: Italy
Contact:

Post by ElvenProgrammer » 16 Nov 2006, 17:52

Be sure your physfs version is the required one
TonySP
Peon
Peon
Posts: 2
Joined: 16 Nov 2006, 17:11
Location: Santa Catarina - Brazil

Post by TonySP » 17 Nov 2006, 17:41

Thx,
Its that... i was using physfs-1.1.0 (i think that the newest its better!) but when i downgrade to physfs-1.0.1 the game runs...
User avatar
Bjørn
TMW Adviser
TMW Adviser
Posts: 1430
Joined: 09 Dec 2004, 19:50
Location: North Rhine-Westphalia, Germany
Contact:

Post by Bjørn » 18 Nov 2006, 17:53

TonySP wrote:Thx,
Its that... i was using physfs-1.1.0 (i think that the newest its better!) but when i downgrade to physfs-1.0.1 the game runs...
1.1.0 isn't necessarily better. It's the development release (unstable), and unfortunately there is a bug in it which prevents TMW to work with it.
Locked