TMW on vista?

Ask for help regarding any technical issue or report any bug or OS independent issues.
User avatar
Amethyst
Novice
Novice
Posts: 152
Joined: 14 Dec 2006, 23:56
Location: Earth

Post by Amethyst » 18 Feb 2007, 17:42

Crush wrote:
.enigmatik wrote:
Avaniel wrote:I'm sorry... Does the error depend on opengl being on/off or both?
...Now if I got that screen what do you think?
I think you should answer the question. Do you run tmw with or without opengl enabled, and does it look the same when you change it?

It might also be interesting to post a link to your tmw.log so we can check if there are any suspicious error messages.
Ok. How do I enable OpenGL? I thought it was on by default.
User avatar
yosuhara
Warrior
Warrior
Posts: 583
Joined: 16 Mar 2006, 22:19
Location: Slovakia
Contact:

Post by yosuhara » 18 Feb 2007, 17:45

.enigmatik wrote:
Crush wrote:
.enigmatik wrote: ...Now if I got that screen what do you think?
I think you should answer the question. Do you run tmw with or without opengl enabled, and does it look the same when you change it?

It might also be interesting to post a link to your tmw.log so we can check if there are any suspicious error messages.
Ok. How do I enable OpenGL? I thought it was on by default.
check your config.xml ;)
Image
Image
Image
User avatar
Amethyst
Novice
Novice
Posts: 152
Joined: 14 Dec 2006, 23:56
Location: Earth

Post by Amethyst » 18 Feb 2007, 17:52

I found a file named tmw. I think this is it.

[16:47:27.28] Initializing SDL...
[16:47:27.31] Initializing resource manager...
[16:47:27.31] Adding to PhysicsFS: .
[16:47:27.31] Adding to PhysicsFS: data
[16:47:27.31] Adding to PhysicsFS: data
[16:47:27.31] Initializing configuration...
[16:47:27.32] Setting video mode 800x600 windowed
[16:47:27.38] Using OpenGL with double buffering.
[16:47:27.38] Initializing GUI...
[16:47:27.38] Loaded data/graphics/gui/sansserif8.png
[16:47:27.39] Loaded data/graphics/gui/rpgfont_wider.png
[16:47:27.40] Loaded data/graphics/gui/hits_red.png
[16:47:27.41] Loaded data/graphics/gui/hits_blue.png
[16:47:27.41] Loaded data/graphics/gui/hits_yellow.png
[16:47:27.42] Loaded data/graphics/gui/mouse.png
[16:47:27.42] Binding texture 6 (32x32)
[16:47:27.42] Window::Window("Window")
[16:47:27.43] Loaded data/graphics/gui/vscroll_grey.png
[16:47:27.43] Binding texture 7 (16x32)
[16:47:27.43] Loaded data/graphics/gui/bg_quad_dis.png
[16:47:27.44] Binding texture 8 (32x256)
[16:47:27.45] Loaded data/graphics/gui/resize.png
[16:47:27.45] Binding texture 9 (16x16)
[16:47:27.45] Loaded data/graphics/gui/browserfont.png
[16:47:27.45] Sound::init() Initializing sound...
[16:47:27.88] Sound::info() SDL_mixer: 1.2.7 (compiled)
[16:47:27.88] Sound::info() SDL_mixer: 1.2.7 (linked)
[16:47:27.88] Sound::info() Driver: dsound
[16:47:27.88] Sound::info() Format: S16LSB
[16:47:27.88] Sound::info() Rate: 22050
[16:47:27.88] Sound::info() Channels: 2
[16:47:27.88] Sound::startMusic() Playing "data/music/Magick - Real.ogg" -1 times
[16:47:27.89] Loaded data/graphics/images/login_wallpaper.png
[16:47:27.98] Binding texture 11 (1024x1024)
[16:47:28.02] State: UPDATE
[16:47:28.02] Window::Window("Updating...")
[16:47:28.02] Loaded data/graphics/gui/deepbox.png
[16:47:28.02] Binding texture 12 (32x32)
[16:47:28.02] Loaded data/graphics/gui/vscroll_up_default.png
[16:47:28.02] Binding texture 13 (16x16)
[16:47:28.03] Loaded data/graphics/gui/vscroll_down_default.png
[16:47:28.03] Binding texture 14 (16x16)
[16:47:28.03] Loaded data/graphics/gui/hscroll_left_default.png
[16:47:28.03] Binding texture 15 (16x16)
[16:47:28.03] Loaded data/graphics/gui/hscroll_right_default.png
[16:47:28.03] Binding texture 16 (16x16)
[16:47:28.03] Loaded data/graphics/gui/vscroll_up_pressed.png
[16:47:28.03] Binding texture 17 (16x16)
[16:47:28.04] Loaded data/graphics/gui/vscroll_down_pressed.png
[16:47:28.04] Binding texture 18 (16x16)
[16:47:28.04] Loaded data/graphics/gui/hscroll_left_pressed.png
[16:47:28.04] Binding texture 19 (16x16)
[16:47:28.04] Loaded data/graphics/gui/hscroll_right_pressed.png
[16:47:28.04] Binding texture 20 (16x16)
[16:47:28.05] Loaded data/graphics/gui/button.png
[16:47:28.05] Binding texture 21 (32x32)
[16:47:28.05] Loaded data/graphics/gui/buttonhi.png
[16:47:28.05] Binding texture 22 (32x32)
[16:47:28.05] Loaded data/graphics/gui/buttonpress.png
[16:47:28.05] Binding texture 23 (32x32)
[16:47:28.05] Loaded data/graphics/gui/button_disabled.png
[16:47:28.05] Binding texture 24 (32x32)
[16:47:28.08] Downloading: http://updates.themanaworld.org/news.txt
[16:47:29.00] Downloading: http://updates.themanaworld.org/resources2.txt
[16:47:29.40] Loaded ./updates/resources2.txt
[16:47:29.44] Downloading: http://updates.themanaworld.org/items-2935.zip
[16:47:32.09] Loaded ./updates/resources2.txt
[16:47:32.09] Adding to PhysicsFS: ./updates/items-2935.zip
[16:47:32.09] Adding to PhysicsFS: ./updates/minimaps-2935.zip
[16:47:32.09] Adding to PhysicsFS: ./updates/sounds-2935.zip
[16:47:32.09] Adding to PhysicsFS: ./updates/update-2940-3040.zip
[16:47:32.09] Adding to PhysicsFS: ./updates/sprites-3126.zip
[16:47:32.09] Adding to PhysicsFS: ./updates/database-3126.zip
[16:47:32.09] Adding to PhysicsFS: ./updates/maps-3126.zip
[16:47:32.09] Adding to PhysicsFS: ./updates/update-3051-3126.zip
[16:47:32.09] ResourceManager::release(graphics/images/login_wallpaper.png)
[16:47:32.09] Loaded data/graphics/images/login_wallpaper.png
[16:47:32.18] Binding texture 11 (1024x1024)
[16:47:32.58] Window::~Window("Updating...")
[16:47:32.58] ResourceManager::release(graphics/gui/deepbox.png)
[16:47:32.58] ResourceManager::release(graphics/gui/vscroll_up_default.png)
[16:47:32.58] ResourceManager::release(graphics/gui/vscroll_up_pressed.png)
[16:47:32.58] ResourceManager::release(graphics/gui/vscroll_down_default.png)
[16:47:32.58] ResourceManager::release(graphics/gui/vscroll_down_pressed.png)
[16:47:32.58] ResourceManager::release(graphics/gui/hscroll_left_default.png)
[16:47:32.58] ResourceManager::release(graphics/gui/hscroll_left_pressed.png)
[16:47:32.58] ResourceManager::release(graphics/gui/hscroll_right_default.png)
[16:47:32.58] ResourceManager::release(graphics/gui/hscroll_right_pressed.png)
[16:47:32.58] ResourceManager::release(graphics/gui/button.png)
[16:47:32.58] ResourceManager::release(graphics/gui/buttonhi.png)
[16:47:32.58] ResourceManager::release(graphics/gui/buttonpress.png)
[16:47:32.58] ResourceManager::release(graphics/gui/button_disabled.png)
[16:47:32.58] State: EXIT
[16:47:32.58] Configuration::write(customcursor, "1")
[16:47:32.58] Configuration::write(fpslimit, "60")
[16:47:32.58] Configuration::write(guialpha, "0.8")
[16:47:32.58] Configuration::write(homeDir, ".")
[16:47:32.58] Configuration::write(host, "animesites.de")
[16:47:32.58] Configuration::write(hwaccel, "0")
[16:47:32.58] Configuration::write(musicVolume, "60")
[16:47:32.58] Configuration::write(opengl, "1")
[16:47:32.58] Configuration::write(port, "6901")
[16:47:32.58] Configuration::write(remember, "1")
[16:47:32.58] Configuration::write(screen, "0")
[16:47:32.58] Configuration::write(sfxVolume, "100")
[16:47:32.58] Configuration::write(sound, "1")
[16:47:32.58] Configuration::write(updatehost, "http://updates.themanaworld.org")
[16:47:32.58] Configuration::write(windowWinX, "237")
[16:47:32.58] Configuration::write(windowWinY, "168")
[16:47:32.58] ResourceManager::release(graphics/gui/mouse.png)
[16:47:32.58] Window::~Window("Window")
[16:47:32.58] ResourceManager::release(graphics/gui/bg_quad_dis.png)
[16:47:32.58] ResourceManager::release(graphics/gui/vscroll_grey.png)
[16:47:32.58] ResourceManager::release(graphics/gui/resize.png)
[16:47:32.58] Sound::stopMusic()
[16:47:32.83] Sound::close() Shutting down sound...
[16:47:32.83] ResourceManager::~ResourceManager() cleaning up 1 references to graphics/images/login_wallpaper.png

With OpenGL set at 0 it is still the same. :(
User avatar
Bjørn
TMW Adviser
TMW Adviser
Posts: 1430
Joined: 09 Dec 2004, 19:50
Location: North Rhine-Westphalia, Germany
Contact:

Post by Bjørn » 19 Feb 2007, 08:20

.enigmatik wrote:With OpenGL set at 0 it is still the same. :(
I doubt you managed to successfully disable OpenGL, since the stretching effects seen in your screenshot would be very weird in software mode. Remember that you need to close the game before changing the config.xml, otherwise it will overwrite it again with the old settings on quit.
User avatar
Amethyst
Novice
Novice
Posts: 152
Joined: 14 Dec 2006, 23:56
Location: Earth

Post by Amethyst » 20 Feb 2007, 02:29

What exactly do I need to do to remove openl?
User avatar
Bjørn
TMW Adviser
TMW Adviser
Posts: 1430
Joined: 09 Dec 2004, 19:50
Location: North Rhine-Westphalia, Germany
Contact:

Post by Bjørn » 20 Feb 2007, 19:45

.enigmatik wrote:What exactly do I need to do to remove openl?
Make sure the client is not running. Then set the value for the "opengl" setting in config.xml to 0 instead of 1. Then launch the client.
User avatar
The Judge
Novice
Novice
Posts: 107
Joined: 09 Nov 2006, 09:19
Location: Sonoran Desert
Contact:

Post by The Judge » 21 Feb 2007, 19:29

Hey all, I just got Vista and I can concur, I got the same exact screen when I started TMW. I'll try to disable the open Gl and get back to you if it is fixed. If that doesn't work, I'll just run it on xp on Virtual PC. But yeah, as it stands, TMW does not work on Vista.
Gabranth in game.
Get ready for chafing, here come the Chainpants!
User avatar
The Judge
Novice
Novice
Posts: 107
Joined: 09 Nov 2006, 09:19
Location: Sonoran Desert
Contact:

Post by The Judge » 22 Feb 2007, 00:43

Yeah, I just installed a virtual version of Windows xp on my Vista, and ran TMW on that. Worked fine. Hopefully you all can figure out whats wrong with the compatibility, if there's anything I can do to help that doesn't require an extreme amount of technical prowess, let me know.
Gabranth in game.
Get ready for chafing, here come the Chainpants!
User avatar
Rotonen
TMW Adviser
TMW Adviser
Posts: 3154
Joined: 08 Sep 2004, 20:48
Location: Espoo, Finland

Post by Rotonen » 22 Feb 2007, 06:43

I had to play around with the compatibility mode settings and set it for Windows 98.

I used the ATI alpha and beta level drivers and it worked out just fine with and without OpenGL, so I wonder where they went wrong with the RTM and post RTM. My educated guess would be some DRM layer change in the driver API "to promote the usage of DX10".
This message used to be meaningful.
User avatar
Amethyst
Novice
Novice
Posts: 152
Joined: 14 Dec 2006, 23:56
Location: Earth

Post by Amethyst » 22 Feb 2007, 14:45

Rotonen wrote:I had to play around with the compatibility mode settings and set it for Windows 98.

I used the ATI alpha and beta level drivers and it worked out just fine with and without OpenGL, so I wonder where they went wrong with the RTM and post RTM. My educated guess would be some DRM layer change in the driver API "to promote the usage of DX10".
Does that mean TMW has to use DirectX in the Windows version now?
User avatar
Bjørn
TMW Adviser
TMW Adviser
Posts: 1430
Joined: 09 Dec 2004, 19:50
Location: North Rhine-Westphalia, Germany
Contact:

Post by Bjørn » 25 Feb 2007, 15:51

.enigmatik wrote:
Rotonen wrote:I had to play around with the compatibility mode settings and set it for Windows 98.

I used the ATI alpha and beta level drivers and it worked out just fine with and without OpenGL, so I wonder where they went wrong with the RTM and post RTM. My educated guess would be some DRM layer change in the driver API "to promote the usage of DX10".
Does that mean TMW has to use DirectX in the Windows version now?
No, but it may mean you have to switch to a better operating system to play TMW in its full glory.
User avatar
Crush
TMW Adviser
TMW Adviser
Posts: 8046
Joined: 25 Aug 2005, 17:08
Location: Germany

Post by Crush » 25 Feb 2007, 17:40

I doubt that it is impossible to find and work around this bug on vista. Unfortunately we got noone who uses vista and got the programming skills to find and fix the problem.
  • former Manasource Programmer
  • former TMW Pixel artist
  • NOT a game master

Please do not send me any inquiries regarding player accounts on TMW.


You might have heard a certain rumor about me. This rumor is completely false. You might also have heard the other rumor about me. This rumor is 100% accurate.
User avatar
Amethyst
Novice
Novice
Posts: 152
Joined: 14 Dec 2006, 23:56
Location: Earth

Post by Amethyst » 31 Mar 2007, 05:43

How is the current development going on Vista? Anything I can do to help, like testing?
User avatar
Crush
TMW Adviser
TMW Adviser
Posts: 8046
Joined: 25 Aug 2005, 17:08
Location: Germany

Post by Crush » 31 Mar 2007, 13:26

Nothing.

We still got no programmer who got vista and would be able to analyze the problem.
  • former Manasource Programmer
  • former TMW Pixel artist
  • NOT a game master

Please do not send me any inquiries regarding player accounts on TMW.


You might have heard a certain rumor about me. This rumor is completely false. You might also have heard the other rumor about me. This rumor is 100% accurate.
User avatar
ElvenProgrammer
TMW Adviser
TMW Adviser
Posts: 2526
Joined: 13 Apr 2004, 20:11
Location: Italy
Contact:

Post by ElvenProgrammer » 01 Apr 2007, 14:09

Since it seems it's really hard for me to reboot to Vista, I'm installing it on a virtual machine. I hope to get some development done soon.
Post Reply