Error with browserbox.h/cpp when compiling 0.22.1 on Linux

Ask for help regarding any technical issue or report any bug or OS independent issues.
Post Reply
micahpdx
Peon
Peon
Posts: 11
Joined: 22 Feb 2007, 22:27

Error with browserbox.h/cpp when compiling 0.22.1 on Linux

Post by micahpdx » 22 Feb 2007, 22:29

I'm trying to compile on FC5 from source. I'm getting the following errors when running make (configure ran fine)

Code: Select all

gui/browserbox.h:93: error: ‘gcn::MouseEvent’ has not been declared
gui/browserbox.h:94: error: ‘gcn::MouseEvent’ has not been declared
gui/browserbox.cpp:242: error: variable or field ‘mousePressed’ declared void
gui/browserbox.cpp:242: error: ‘int BrowserBox::mousePressed’ is not a static member of ‘class BrowserBox’
gui/browserbox.cpp:242: error: ‘MouseEvent’ is not a member of ‘gcn’
gui/browserbox.cpp:242: error: ‘event’ was not declared in this scope
gui/browserbox.cpp:243: error: expected ‘,’ or ‘;’ before ‘{’ token
Any ideas?
User avatar
Crush
TMW Adviser
TMW Adviser
Posts: 8046
Joined: 25 Aug 2005, 17:08
Location: Germany

Post by Crush » 22 Feb 2007, 23:03

Seems like guichan is not installed.
  • former Manasource Programmer
  • former TMW Pixel artist
  • NOT a game master

Please do not send me any inquiries regarding player accounts on TMW.


You might have heard a certain rumor about me. This rumor is completely false. You might also have heard the other rumor about me. This rumor is 100% accurate.
micahpdx
Peon
Peon
Posts: 11
Joined: 22 Feb 2007, 22:27

Post by micahpdx » 22 Feb 2007, 23:32

Configure got me on that, so I installed v0.5.0. Error happens still, during make. Maybe I'll try installing guichan from source rather than RPM. I'll let you know...

Code: Select all

checking for gcnGuichanVersion in -lguichan... yes
Matt
Knight
Knight
Posts: 1747
Joined: 07 Aug 2004, 11:47
Location: Germany->Bavaria

Post by Matt » 22 Feb 2007, 23:36

Well...the latest tmw version uses guichan 0.6.1 you know...
User avatar
Crush
TMW Adviser
TMW Adviser
Posts: 8046
Joined: 25 Aug 2005, 17:08
Location: Germany

Post by Crush » 22 Feb 2007, 23:37

Guichan 0.5.0 doesn't work with the current version of tmw. You should get the 0.6.1 from the guichan homepage: http://guichan.sourceforge.net/
  • former Manasource Programmer
  • former TMW Pixel artist
  • NOT a game master

Please do not send me any inquiries regarding player accounts on TMW.


You might have heard a certain rumor about me. This rumor is completely false. You might also have heard the other rumor about me. This rumor is 100% accurate.
micahpdx
Peon
Peon
Posts: 11
Joined: 22 Feb 2007, 22:27

Post by micahpdx » 23 Feb 2007, 06:01

Ah yes, thank you. The INSTALL file says 0.5.0. I installed the newest guichan from source and that error has been corrected. However, now I have this one:

Code: Select all

gui/shoplistbox.cpp: In member function ‘virtual void ShopListBox::setSelected(int)’:
gui/shoplistbox.cpp:115: error: invalid conversion from ‘gcn::Widget*’ to ‘gcn::BasicContainer*’
User avatar
Crush
TMW Adviser
TMW Adviser
Posts: 8046
Joined: 25 Aug 2005, 17:08
Location: Germany

Post by Crush » 23 Feb 2007, 09:45

What version exactly are yo compiling?

The current version on the SVN needs 0.6.1, the latest tarball from the download page 0.6.0.
  • former Manasource Programmer
  • former TMW Pixel artist
  • NOT a game master

Please do not send me any inquiries regarding player accounts on TMW.


You might have heard a certain rumor about me. This rumor is completely false. You might also have heard the other rumor about me. This rumor is 100% accurate.
micahpdx
Peon
Peon
Posts: 11
Joined: 22 Feb 2007, 22:27

Post by micahpdx » 23 Feb 2007, 20:39

I installed guichan 0.6.1 from source and am trying to make 0.0.22.1 tmw.
micahpdx
Peon
Peon
Posts: 11
Joined: 22 Feb 2007, 22:27

Post by micahpdx » 23 Feb 2007, 20:44

Duh-- just read what you said. I'm going to find guichan 0.6.0 instead of 0.6.1. Thanks again for all your help. I'll let you know.
micahpdx
Peon
Peon
Posts: 11
Joined: 22 Feb 2007, 22:27

Post by micahpdx » 24 Feb 2007, 22:24

That did it. Thanks for all your help. It's much appreciated.
User avatar
Bjørn
TMW Adviser
TMW Adviser
Posts: 1430
Joined: 09 Dec 2004, 19:50
Location: North Rhine-Westphalia, Germany
Contact:

Post by Bjørn » 25 Feb 2007, 15:57

I still think it would have been better if you had taken TMW 0.0.22.2 instead of downgrading your Guichan. We haven't been able to update the download page yet, but it's been available since the 17th.
micahpdx
Peon
Peon
Posts: 11
Joined: 22 Feb 2007, 22:27

Post by micahpdx » 25 Feb 2007, 20:24

Oh-- I didn't realize that. I'll check it out. Thanks.
Post Reply