couldn find the map file...grr

Ask for help regarding any technical issue or report any bug or OS independent issues.
User avatar
Fou-lu
Peon
Peon
Posts: 71
Joined: Fri May 18, 2007 4:52 pm

Post by Fou-lu » Sat Aug 25, 2007 11:39 pm

Hey maeby i sholve the problem looks like there is a file lost in my game is the " new_20-1.tmx.gz" (Woodland village, indoor)

rigth click on the game and i pressed "showing content of the package", then i look for the file but there is not here...soo can any admin or mod see this nad fix it please?

maeby ix it and put it oon the download page.

well just that...thanks

P.D: sorry for my very bad englisg bu i really speak spanish, not english. :roll:
User avatar
Crush
TMW Adviser
TMW Adviser
Posts: 8046
Joined: Thu Aug 25, 2005 5:08 pm
Location: Germany

Post by Crush » Sat Aug 25, 2007 11:47 pm

It is normal that you don't find this file in the application packet. All map files are delivered through the update system. You will find the downloaded updates in your user directory (i don't know where to find this on MacOS, i am not a mac user) in the folder /.tmw/updates as zip files.

This specific file is delivered in the update-3313-3473-2.zip together with the maps 18 and 19, the outside area of the woodland village. Updates are checked for integrity automatically. So when the indoor map is missing the outdoor maps would be missing, too.

However, when you really believe that you can fix your problem by copying some files manually you can find all files on our subversion repository: http://themanaworld.svn.sourceforge.net ... nches/0.0/
  • former Manasource Programmer
  • former TMW Pixel artist
  • NOT a game master

Please do not send me any inquiries regarding player accounts on TMW.


You might have heard a certain rumor about me. This rumor is completely false. You might also have heard the other rumor about me. This rumor is 100% accurate.
User avatar
Fou-lu
Peon
Peon
Posts: 71
Joined: Fri May 18, 2007 4:52 pm

Post by Fou-lu » Sun Aug 26, 2007 12:01 am

well...i really dont know about computers...soo...nvm...xDD
but thanks...anyways that file the "update-3313-3473-2.zip" is on the updates but dosent work when i enter to a shop this happend:
Image
User avatar
Bjørn
TMW Adviser
TMW Adviser
Posts: 1430
Joined: Thu Dec 09, 2004 7:50 pm
Location: North Rhine-Westphalia, Germany
Contact:

Post by Bjørn » Tue Aug 28, 2007 9:55 am

Fou-lu wrote:well...i really dont know about computers...soo...nvm...xDD
but thanks...anyways that file the "update-3313-3473-2.zip" is on the updates but dosent work when i enter to a shop this happend:
Could you check whether it helps to delete the update-3313-3473-2.zip file from your updates directory (~/.tmw/updates) and have it re-download the file? Otherwise, please check your log (~/.tmw/tmw.log) for any errors related to the update or the loading of the map.
User avatar
Fou-lu
Peon
Peon
Posts: 71
Joined: Fri May 18, 2007 4:52 pm

Post by Fou-lu » Tue Sep 04, 2007 11:11 pm

Reo wrote:From the other post in bugs

Fou-lu:
World.app/Contents/Resources/data/graphics/gui/checkbox.png
[03:18:26.44] Window::Window("Map")
[03:18:26.44] Window::Window("Equipment")
[03:18:26.44] Window::Window("Trade: You")
[03:18:26.44] Window::Window("Help")
[03:18:26.44] Window::Window("Debug")
[03:18:26.44] Particle engine set up
[03:18:26.44] Warning: Failed to load maps/new_20-1.tmx.gz: No such file or directory
[03:18:26.44] Map file not found (maps/new_20-1.tmx.gz)
here....so any solution for this problem?
User avatar
Bjørn
TMW Adviser
TMW Adviser
Posts: 1430
Joined: Thu Dec 09, 2004 7:50 pm
Location: North Rhine-Westphalia, Germany
Contact:

Post by Bjørn » Wed Sep 05, 2007 1:11 pm

Fou-lu wrote:here....so any solution for this problem?
Alright, so now we know which map, but you forgot that I also asked for any problems related to the "update-3313-3473-2.zip" update. This is the update which contains new_20-1.tmx.gz, so apparently your client is having a problem with it. If the file does exist, deleting the file can help if the downloaded file is corrupt.
User avatar
Fou-lu
Peon
Peon
Posts: 71
Joined: Fri May 18, 2007 4:52 pm

Post by Fou-lu » Thu Sep 06, 2007 12:40 am

i have deleted the "update-3313-3473-2.zip" but the problem persist
:?...oh and i have re-dowload the game like 10 or more times but the problem persist :evil:
xyle
Peon
Peon
Posts: 14
Joined: Sun Oct 21, 2007 12:45 pm

Post by xyle » Sun Oct 21, 2007 12:57 pm

i had the same problem. The way i did:

dowload this file: https://themanaworld.svn.sourceforge.ne ... w_20-1.tmx

then in terminal:

Code: Select all

gzip new_20-1.tmx
then put this file in tmw/contents/resources/data/maps

then you can log in again ;)

but you have to move back right now !!! because the map of the inside house isn't good, so you don't see anything !!!

if an admin can tell us where is the good file (new_20-1.tmx.gz), it should be fine ;)

ps: sorry for my english ...
User avatar
Bjørn
TMW Adviser
TMW Adviser
Posts: 1430
Joined: Thu Dec 09, 2004 7:50 pm
Location: North Rhine-Westphalia, Germany
Contact:

Post by Bjørn » Sun Oct 21, 2007 11:09 pm

xyle wrote:if an admin can tell us where is the good file (new_20-1.tmx.gz), it should be fine ;)
Here:
https://themanaworld.svn.sourceforge.ne ... threv=3530
(phpBB is too silly to know where the URL ends, so copy/paste)

Of course it shouldn't be necessary to download this file manually, but so far I don't think anybody has figured out what the problem is. It seems it affects only our Mac release.
xyle
Peon
Peon
Posts: 14
Joined: Sun Oct 21, 2007 12:45 pm

Post by xyle » Mon Oct 22, 2007 11:46 am

Thanks,

but for me, this doesn't fix the problem :(

If it can help, here is a screen shot when i'm in a house:

Image
User avatar
Strump
Novice
Novice
Posts: 169
Joined: Sun Oct 14, 2007 10:05 am
Location: Germany
Contact:

Post by Strump » Mon Oct 22, 2007 12:30 pm

xyle wrote:Thanks,

but for me, this doesn't fix the problem :(

If it can help, here is a screen shot when i'm in a house:

Image

Wow is a big error ^^
:D
User avatar
Bjørn
TMW Adviser
TMW Adviser
Posts: 1430
Joined: Thu Dec 09, 2004 7:50 pm
Location: North Rhine-Westphalia, Germany
Contact:

Post by Bjørn » Tue Oct 23, 2007 1:39 pm

Looks like it may not be able to find the tileset either. Look into your ~/.tmw/tmw.log for related errors/warnings and possible download the missing tileset same way you downloaded the map.
xyle
Peon
Peon
Posts: 14
Joined: Sun Oct 21, 2007 12:45 pm

Post by xyle » Wed Oct 24, 2007 9:58 am

Yep, it seems to be the probem:

Code: Select all

cat tmw.log | grep Warning
[08:52:53.29] Sound::startMusic() Warning: error loading file.
[08:54:46.19] Sound::startMusic() Warning: error loading file.
[08:55:17.40] Warning: Failed to load graphics/tiles/woodland_indoor.png: No such file or directory
[08:55:17.40] Warning: Failed to load tileset (../graphics/tiles/woodland_indoor.png)
[08:55:17.40] Warning: Failed to load graphics/tiles/woodland_indoor_x2.png: No such file or directory
[08:55:17.40] Warning: Failed to load tileset (../graphics/tiles/woodland_indoor_x2.png)
[08:55:17.40] Warning: Failed to load graphics/tiles/woodland_indoor_x3.png: No such file or directory
[08:55:17.40] Warning: Failed to load tileset (../graphics/tiles/woodland_indoor_x3.png)
[08:55:17.42] Warning: Failed to load graphics/particles/fireplace.particle.xml: No such file or directory
[08:55:17.42] Warning: Particle engine could not find graphics/particles/fireplace.particle.xml !
[08:55:17.42] Warning: Failed to load graphics/particles/cookingfire.particle.xml: No such file or directory
[08:55:17.42] Warning: Particle engine could not find graphics/particles/cookingfire.particle.xml !
[08:55:17.43] Sound::startMusic() Warning: error loading file.
[08:56:02.00] Sound::startMusic() Warning: error loading file.
I'll try to add this files manualy...
xyle
Peon
Peon
Posts: 14
Joined: Sun Oct 21, 2007 12:45 pm

Post by xyle » Wed Oct 24, 2007 1:14 pm

Yargh !!!

I made this script to download the missing files:

Code: Select all

#!/bin/bash
cd /Applications/The\ Mana\ World.app/Contents/Resources/data/graphics/tiles/
curl -f -O https://themanaworld.svn.sourceforge.net/svnroot/themanaworld/tmw/trunk/data/graphics/tiles/woodland_indoor.png
curl -f -O https://themanaworld.svn.sourceforge.net/svnroot/themanaworld/tmw/trunk/data/graphics/tiles/woodland_indoor_x2.png
curl -f -O https://themanaworld.svn.sourceforge.net/svnroot/themanaworld/tmw/trunk/data/graphics/tiles/woodland_indoor_x3.png
cd /Applications/The\ Mana\ World.app/Contents/Resources/data/graphics/particles/
curl -f -O https://themanaworld.svn.sourceforge.net/svnroot/themanaworld/tmw/trunk/data/graphics/particles/aniblaze.png
curl -f -O https://themanaworld.svn.sourceforge.net/svnroot/themanaworld/tmw/trunk/data/graphics/particles/fireplace.particle.xml
curl -f -O https://themanaworld.svn.sourceforge.net/svnroot/themanaworld/tmw/trunk/data/graphics/particles/cookingfire.particle.xml
cd /Applications/The\ Mana\ World.app/Contents/Resources/data/maps/
curl -f -O https://themanaworld.svn.sourceforge.net/svnroot/themanaworld/tmw/trunk/data/maps/new_20-1.tmx
Don't run this file !!! You could not play anymore with your character (by the way, if an admin could loggin with my character 'xyle' and just get out the house, it would be grate !!!)

But now the probleme is:

Code: Select all

cat tmw.log | grep Warning
[12:09:02.61] Sound::startMusic() Warning: error loading file.
[12:09:16.29] Particle Engine: Warning, unknown emitter property "randomness"
[12:09:16.29] Particle Engine: Warning, unknown emitter property "randomness"
[12:09:16.29] Particle Engine: Warning, unknown emitter property "randomness"
[12:09:16.29] Sound::startMusic() Warning: error loading file.
It seems to be more complicated :(
Somebody can help ?
User avatar
Crush
TMW Adviser
TMW Adviser
Posts: 8046
Joined: Thu Aug 25, 2005 5:08 pm
Location: Germany

Post by Crush » Wed Oct 24, 2007 2:12 pm

These warnings aren't critical.

When the particle engine finds an unknown particle property in the particle definition this property is just ignored. It usually doesn't impede the particle effect and should not affect the stability of the whole game engine at all. But thanks for reporting anyway because it is a typo I made.

The same applies to the music. When music files aren't found (I am not sure if these are installed with the default mac installer) they are just not played but the game runs fine.


When there aren't any other warnings or errors in the log file please describe the nature of your current problem more precise.
  • former Manasource Programmer
  • former TMW Pixel artist
  • NOT a game master

Please do not send me any inquiries regarding player accounts on TMW.


You might have heard a certain rumor about me. This rumor is completely false. You might also have heard the other rumor about me. This rumor is 100% accurate.
Post Reply