TMW Server Problems

Ask for help regarding any technical issue or report any bug or OS independent issues.
Imago3d
Peon
Peon
Posts: 23
Joined: Tue Sep 23, 2008 9:48 pm

TMW Server Problems

Post by Imago3d » Tue Sep 23, 2008 9:52 pm

Hi,

I compiled the server from the SVN and I can get it started and everything. But the problem is that no one can connect to it. Not even me since it's on a VPS. So, my question is how do you set up the ini correctly. I've tried putting in localhost, and the IP address but nothing seems to take. When it starts up it also says "LAN SERVER". I've tried changing things around for a couple days now with no luck.


Any help would be most appreciated.
User avatar
Jaxad0127
TMW Adviser
TMW Adviser
Posts: 4209
Joined: Thu Nov 01, 2007 6:35 pm
Location: Internet

Re: TMW Server Problems

Post by Jaxad0127 » Tue Sep 23, 2008 9:53 pm

Which server?

eAthena works with the current release client.
TMWServ is for the trunk client.

I recommend you use eAthena. TMWServ and it's client aren't ready for public betas yet.
Image
Imago3d
Peon
Peon
Posts: 23
Joined: Tue Sep 23, 2008 9:48 pm

Re: TMW Server Problems

Post by Imago3d » Tue Sep 23, 2008 10:31 pm

Client is 0.25 and the server is out of TMVServ in the SVN. But the Eathena will work for it as is or would I need to download something else? I didn't use the Eathena because I couldn't get it to work. Mostly the settings are hard to understand. One says to use MYSQL and one says to use text files. I really just need to know how to set up the settings for it.

The conf files are the tricky ones. If I take out the file lan_support.conf it doesn't seem to work at all. If I leave it in then still no connections. :(
User avatar
Jaxad0127
TMW Adviser
TMW Adviser
Posts: 4209
Joined: Thu Nov 01, 2007 6:35 pm
Location: Internet

Re: TMW Server Problems

Post by Jaxad0127 » Wed Sep 24, 2008 12:39 am

Just get the eAthena code, and run make. It should build fine, just ignore all the signedness warnings. This will help as well: Setting up eAthena (Linux).

0.0.25 doesn't work with TMWServ.
Image
Imago3d
Peon
Peon
Posts: 23
Joined: Tue Sep 23, 2008 9:48 pm

Re: TMW Server Problems

Post by Imago3d » Wed Sep 24, 2008 12:46 am

Which mana client works with the eathena server? I kept getting not able to connect from the client and no response to show that the client even tried to touch the server on the server side.
User avatar
Jaxad0127
TMW Adviser
TMW Adviser
Posts: 4209
Joined: Thu Nov 01, 2007 6:35 pm
Location: Internet

Re: TMW Server Problems

Post by Jaxad0127 » Wed Sep 24, 2008 12:58 am

0.0.x clients work with eAthena. Please go through the steps here: http://wiki.themanaworld.org/index.php/ ... 28Linux.29 .
Image
Imago3d
Peon
Peon
Posts: 23
Joined: Tue Sep 23, 2008 9:48 pm

Re: TMW Server Problems

Post by Imago3d » Wed Sep 24, 2008 1:19 am

I did all the steps and set up the conf files. But I have a file that's not listed in the wiki. I don't know if it's the one setting the problems or not.

It's called lan_support.conf

And just to be sure

You have to start map-server, char-server, and the login-server. Or am I missing one. I tried doing the eathena.sh start restart file but it doesn't seem to start, stop, or restart anything. I have recompiled this server a few times, but I'm really thinking it's got something to do with the configuration files, but I just can't seem to figure it out just yet.
User avatar
Jaxad0127
TMW Adviser
TMW Adviser
Posts: 4209
Joined: Thu Nov 01, 2007 6:35 pm
Location: Internet

Re: TMW Server Problems

Post by Jaxad0127 » Wed Sep 24, 2008 1:24 am

lan_support.conf doesn't need to be messed with at all.

The correct order is login, char, map. The eathena-monitor expects to be run from ~/tmwserver and expects to see the servers there.
Image
Imago3d
Peon
Peon
Posts: 23
Joined: Tue Sep 23, 2008 9:48 pm

Re: TMW Server Problems

Post by Imago3d » Wed Sep 24, 2008 2:12 am

Okay I'm either missing something or something is missing from the wiki. Because I've followed the instructions word for word. Started up the servers and tried to connect to mine and can't but I can connect to official just fine. Are there folders that need different permissions or something. I'm either missing something or I'm just not sure. But I've run FPS games and other things from my server and thought I'd try out the mana world because it looked interesting, but I've recompiled it a few times but I'm missing something somewhere or something wasn't included in the documentation.

I'm using ubuntu if that's any help.
User avatar
Jaxad0127
TMW Adviser
TMW Adviser
Posts: 4209
Joined: Thu Nov 01, 2007 6:35 pm
Location: Internet

Re: TMW Server Problems

Post by Jaxad0127 » Wed Sep 24, 2008 2:16 am

Can you join us on IRC? Network is freenode, channel is #themanaworld. I need to log off of it briefly, but should be back on in a few minutes. Others on might be able to help as well.
Image
Imago3d
Peon
Peon
Posts: 23
Joined: Tue Sep 23, 2008 9:48 pm

Re: TMW Server Problems

Post by Imago3d » Wed Sep 24, 2008 2:31 am

Sorry I don't have any IRC program. Unless there's one set up on your server. I would like to get this sorted out. But I'm once again following the steps trying to track down exactly what is going wrong.

Here's what I've done so far...

I set up a MYSQL database for TMW and called it tmw.

Created an xml file and called it tmwserv.xml (still not sure where to put this.)

Then checked out of SVN twice once with
https://themanaworld.svn.sourceforge.ne ... hena/trunk
Putting it in the directory tmwserver
then used make on this directory to compile

Then checked out again from
https://themanaworld.svn.sourceforge.ne ... data/trunk
putting that in to the directory server-data
Then went in and gcc -o eathena-monitor eathena-monitor.c and then cp -iv ../tmwserver/*-server .

Then went in to tmwserver and edited char_athena.conf map_athena.conf and put in my servers IP address.

Then started the servers and tried to connect with the client and get "Couldn't connect to remote host".

So, I'm at a loss. I'm going to try it again just to be sure I didn't miss anything.
User avatar
Jaxad0127
TMW Adviser
TMW Adviser
Posts: 4209
Joined: Thu Nov 01, 2007 6:35 pm
Location: Internet

Re: TMW Server Problems

Post by Jaxad0127 » Wed Sep 24, 2008 2:51 am

The DB and XML file aren't needed. So, you copied the server binaries to the server-data folder? Do you copy the example files and edit them for your info?
Image
Imago3d
Peon
Peon
Posts: 23
Joined: Tue Sep 23, 2008 9:48 pm

Re: TMW Server Problems

Post by Imago3d » Wed Sep 24, 2008 3:31 am

Yes, I did. I copied all of the example files over and then changed the IP's in them to my IP. I have all the servers up and running now, but the client won't connect to them. I downloaded the client and put in my IP in to the server.
User avatar
Jaxad0127
TMW Adviser
TMW Adviser
Posts: 4209
Joined: Thu Nov 01, 2007 6:35 pm
Location: Internet

Re: TMW Server Problems

Post by Jaxad0127 » Wed Sep 24, 2008 3:44 am

Are the server binaries being run from the server-data directory?

Remember, you can't use eathena-monitor as-is, unless it's being run from ~/tmwserver.

In the console, just run login-server and post it's output.
Image
Imago3d
Peon
Peon
Posts: 23
Joined: Tue Sep 23, 2008 9:48 pm

Re: TMW Server Problems

Post by Imago3d » Wed Sep 24, 2008 3:46 am

I'm running them from the tmwserver directory. Are they supposed to be run from the server-data directory?


(=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=)
( (c)2004 eAthena Development Team presents )
( ______ __ __ )
( /\ _ \/\ \__/\ \ v 1.00.00 )
( __\ \ \_\ \ \ ,_\ \ \___ __ ___ __ )
( /'__`\ \ __ \ \ \/\ \ _ `\ /'__`\/' _ `\ /'__`\ )
( /\ __/\ \ \/\ \ \ \_\ \ \ \ \/\ __//\ \/\ \/\ \_\.\_ )
( \ \____\\ \_\ \_\ \__\\ \_\ \_\ \____\ \_\ \_\ \__/.\_\ )
( \/____/ \/_/\/_/\/__/ \/_/\/_/\/____/\/_/\/_/\/__/\/_/ )
( _ _ _ _ _ _ _ _ _ _ _ _ _ )
( / \ / \ / \ / \ / \ / \ / \ / \ / \ / \ / \ / \ / \ )
( ( e | n | g | l | i | s | h ) ( A | t | h | e | n | a ) )
( \_/ \_/ \_/ \_/ \_/ \_/ \_/ \_/ \_/ \_/ \_/ \_/ \_/ )
(=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=)

---Start reading of Login Server configuration file (conf/login_athena.conf)
---End reading of Login Server configuration file.
***WARNING: You are using the default GM password (gm_pass).
We highly recommend that you change it.
---Start reading Lan Support configuration file
LAN IP of char-server: 127.0.0.1.
Sub-network of the char-server: 127.0.0.1.
Sub-network mask of the char-server: 255.255.255.255.
LAN test of LAN IP of the char-server: LAN test (result): LAN source.
---End reading of Lan Support configuration file
read_gm_account: file 'conf/gm_account.txt' readed (0 GM accounts found).
mmo_auth_init: 1 account read in save/account.txt,
of which is no GM account, and 1 server account ('S').
The login-server is ready (Server is listening on the port 6901).

Connection of the char-server 'Mana World' accepted.
Post Reply