Framerate with 0.0.28

Got something on your mind about the project? This is the correct place for that.
Forum rules
This forum is for feature requests, content changes additions, anything not a Bug in the software.
Please report all bugs on the Support Forums
Post Reply

How is your framerate with 0.0.28 compared to 0.0.27?

Even Better
4
31%
Did not change
4
31%
Worse, but can only be noticed by looking at the framerate
4
31%
Notable worse, but I can live with it
1
8%
Unbearable worse
0
No votes
 
Total votes: 13
User avatar
Crush
TMW Adviser
TMW Adviser
Posts: 8046
Joined: Thu Aug 25, 2005 5:08 pm
Location: Germany

Framerate with 0.0.28

Post by Crush » Mon Jan 26, 2009 1:03 am

With 0.0.28 we switched to TTF rendering of fonts and introduced animated tiles on one map (012-3 - the cave under the mouboo hills). Does that affect your performance?

When you would like to comment please remember to state your operating system.
  • former Manasource Programmer
  • former TMW Pixel artist
  • NOT a game master

Please do not send me any inquiries regarding player accounts on TMW.


You might have heard a certain rumor about me. This rumor is completely false. You might also have heard the other rumor about me. This rumor is 100% accurate.
User avatar
MasterKenobi
Novice
Novice
Posts: 319
Joined: Sun Sep 21, 2008 5:39 pm

Re: Framerate with 0.0.28

Post by MasterKenobi » Mon Jan 26, 2009 1:35 am

Animated tiles look great!

Location: Cave with animated tiles 012-3
System:
Windows Vista 64
4GB
Core2Duo e6850 3.6Ghz
Geforce 8800GTS 640
Settings:
0.0.28
Full screen
OpenGL enabled
Max Particle and Ambiance

300fps+

Absolutely no performance hit.

MK
Many of the truths we cling to depend greatly on our own point of view.
User avatar
blueberry
Novice
Novice
Posts: 107
Joined: Tue Feb 27, 2007 12:26 am
Location: Graz, Austria

Re: Framerate with 0.0.28

Post by blueberry » Mon Jan 26, 2009 4:18 am

Location:
Cave with animated tiles 012-3: fps: 315+
Outdoor map 012-1: fps: 170+

System:
Debian Lenny 32bit
2GB
Dualcore 2.6Ghz
Geforce 8600GT
Settings:
0.0.28
Full screen
OpenGL enabled
Max Particle and Ambiance

Compared to 0.0.27 its almost the same :)
Last edited by blueberry on Tue Jan 27, 2009 3:13 pm, edited 2 times in total.
User avatar
Arilious
Peon
Peon
Posts: 85
Joined: Wed Jun 11, 2008 8:03 am
Location: USA
Contact:

Re: Framerate with 0.0.28

Post by Arilious » Tue Jan 27, 2009 9:53 am

Location: 012-3
System:
Windows Vista 64
4GB
Intel Core2 Quad Q6700 @ 2.66GHz
NVIDIA GeForce 8600 GT
Settings:
0.0.28
Full screen
OpenGL enabled
Max Particle and Ambiance

I got:

Constant FPS of 60 without limiter, and with limiter at 200.
I also saw no animated tiles after searching the entire cave 012-3.

Overall it seems a bit choppier for me, text is also blurrier, though that could be a "ClearType" feature, which in my opinion needs the option of Enable/Disable.
User avatar
Shaili (a.k.a. tds)
Novice
Novice
Posts: 168
Joined: Wed Feb 20, 2008 11:50 am
Contact:

Re: Framerate with 0.0.28

Post by Shaili (a.k.a. tds) » Wed Jan 28, 2009 7:30 pm

5 FPS less. Unnoticeable ;)

System:

Ubuntu Linux 32bit
1 GB RAM
Intel Centrino Duo T2050 @ 1.60GHz
ATI Radeon Mobility X1400
TWM: 0.0.28
OpenGL enabled
Max Particle and Ambiance
Ingame I am: Shaili, Lv. 9X

Image Proud Italian TMW Player

Image You can find me on Last.fm
User avatar
Ces
Novice
Novice
Posts: 231
Joined: Wed Mar 19, 2008 11:46 pm
Location: The hemisphere

Re: Framerate with 0.0.28

Post by Ces » Wed Jan 28, 2009 9:58 pm

I believe I had a somewhat higher fps than usual (a couple of frames). ;) Firefox was running in the background, usually it isn’t when I’m running tmw. But the animations looks a tad strange. I haven’t checked if there’s something strange with my data or so, yet.

With settings [1]:
* Particle count: 60-70
* Frames/second: 75-85

With settings [2]:
* Particle count: 240-260
* Frames/second: 55-60

------------

TMW 0.0.28+ (git as of earlier today; 0d4142a891cd228da24ee3aa3bbd7dc622da5b75)
Window: 800×600
OpenGL: disabled
TMW mouse graphics: disabled

[1] Ambiance: off
Particle details: low

[2] Ambiance: high
Particle details: maximal

Xubuntu 08.10 (32 bits)
256 MB
Intel(R) Celeron(R) M processor 1.50GHz

------------

[edit] Screenshots of animation glitch
* Standing still after a little movement, settings [1]
* Moving, settings [1]
* Standing still after client restart, settings [1]
* Standing still after client restart, settings [2]
User avatar
Crush
TMW Adviser
TMW Adviser
Posts: 8046
Joined: Thu Aug 25, 2005 5:08 pm
Location: Germany

Re: Framerate with 0.0.28

Post by Crush » Wed Jan 28, 2009 10:42 pm

The map got screwed up a while ago. When you want to see some non-buggy animations try the cave further to the west on the map.

Thanks for reporting. I'll pull a corrected version of the map soon.
  • former Manasource Programmer
  • former TMW Pixel artist
  • NOT a game master

Please do not send me any inquiries regarding player accounts on TMW.


You might have heard a certain rumor about me. This rumor is completely false. You might also have heard the other rumor about me. This rumor is 100% accurate.
Post Reply