particle effect ??

All development of pixel art and graphics
User avatar
Rotonen
TMW Adviser
TMW Adviser
Posts: 3154
Joined: 08 Sep 2004, 20:48
Location: Espoo, Finland

Re: particle effect ??

Post by Rotonen » 16 Jan 2010, 20:27

On Mac OS X, updates and such are in ~/.tmw/ as they are on any UNIX-like system.

Also the .app is just a directory structure you can browse which is treated special because of the .app ending in the name of it.
This message used to be meaningful.
User avatar
Jaxad0127
TMW Adviser
TMW Adviser
Posts: 4209
Joined: 01 Nov 2007, 18:35
Location: Internet

Re: particle effect ??

Post by Jaxad0127 » 16 Jan 2010, 20:47

You should be able to just run tmw (or mana if you're using the latest). So, tmw -u.
Image
User avatar
lien
Novice
Novice
Posts: 446
Joined: 30 Oct 2008, 09:59
Location: France

Re: particle effect ??

Post by lien » 17 Jan 2010, 10:14

Rotonen wrote:On Mac OS X, updates and such are in ~/.tmw/ as they are on any UNIX-like system.

Also the .app is just a directory structure you can browse which is treated special because of the .app ending in the name of it.
i know this
otherwise how could I have done my "theme"
Image
User avatar
lien
Novice
Novice
Posts: 446
Joined: 30 Oct 2008, 09:59
Location: France

Re: particle effect ??

Post by lien » 24 Jan 2010, 17:02

i think , i have the files
just i think
Image
User avatar
lien
Novice
Novice
Posts: 446
Joined: 30 Oct 2008, 09:59
Location: France

Re: particle effect ??

Post by lien » 24 Jan 2010, 21:07

when i change the xml (particle) all particles disappear
fentrexml.jpg
fentrexml.jpg (199.54 KiB) Viewed 1454 times
what's the problem ?? :shock:
Image
User avatar
Jaxad0127
TMW Adviser
TMW Adviser
Posts: 4209
Joined: 01 Nov 2007, 18:35
Location: Internet

Re: particle effect ??

Post by Jaxad0127 » 24 Jan 2010, 21:38

You've turned down all particle effects to minimum.
Image
User avatar
lien
Novice
Novice
Posts: 446
Joined: 30 Oct 2008, 09:59
Location: France

Re: particle effect ??

Post by lien » 25 Jan 2010, 17:16

jaxad0127 wrote:You've turned down all particle effects to minimum.
no i was change just the soul menhir particle but all particle disapear

edit low is the minimum but they (particles) are apear
Image
User avatar
Crush
TMW Adviser
TMW Adviser
Posts: 8046
Joined: 25 Aug 2005, 17:08
Location: Germany

Re: particle effect ??

Post by Crush » 25 Jan 2010, 17:53

lien wrote:when i change the xml (particle) all particles disappear
what's the problem ?? :shock:
Hard to say. Most likely you screwed up the file format so that the whole file can't be parsed anymore. XML parsers are very picky. When you post the changed file we can try to help you finding the error.

There could also be an error message regarding your particle effect in the logfile.
  • former Manasource Programmer
  • former TMW Pixel artist
  • NOT a game master

Please do not send me any inquiries regarding player accounts on TMW.


You might have heard a certain rumor about me. This rumor is completely false. You might also have heard the other rumor about me. This rumor is 100% accurate.
User avatar
lien
Novice
Novice
Posts: 446
Joined: 30 Oct 2008, 09:59
Location: France

Re: particle effect ??

Post by lien » 25 Jan 2010, 18:03

Crush wrote:
lien wrote:when i change the xml (particle) all particles disappear
what's the problem ?? :shock:
Hard to say. Most likely you screwed up the file format so that the whole file can't be parsed anymore. XML parsers are very picky. When you post the changed file we can try to help you finding the error.

There could also be an error message regarding your particle effect in the logfile.
the name of the xml don't change
and the effect for the test is just change colors (ff0000 (red))
Image
User avatar
Crush
TMW Adviser
TMW Adviser
Posts: 8046
Joined: 25 Aug 2005, 17:08
Location: Germany

Re: particle effect ??

Post by Crush » 25 Jan 2010, 18:27

Sorry, but there is really no way to help you unless you show us the file.
  • former Manasource Programmer
  • former TMW Pixel artist
  • NOT a game master

Please do not send me any inquiries regarding player accounts on TMW.


You might have heard a certain rumor about me. This rumor is completely false. You might also have heard the other rumor about me. This rumor is 100% accurate.
User avatar
lien
Novice
Novice
Posts: 446
Joined: 30 Oct 2008, 09:59
Location: France

Re: particle effect ??

Post by lien » 25 Jan 2010, 18:30

Code: Select all

<?xml version="1.0"?>
<!--
Light blue particles which fly up to the sky. About one tile wide, three tiles
high and supposed to give an object which is about half as large as a player
character some magical aura.
-->
<effect>
	<particle
		position-x = "0"
		position-y = "0"
		position-z = "0"
		>
		<emitter>
			<property name="position-z" value="16" />
			<property name="vertical-angle" min="0" max="90"/>
			<property name="horizontal-angle" min="0" max="360"/>
			<property name="power" min="20" max="24"/>
			<property name="lifetime" value="1"/>
			<property name="output" value="1"/>
			<emitter>
				<property name="gravity" value="-0.2"/>
				<property name="momentum" value="0.9"/>
				<property name="image" value="graphics/particles/gloworb-medium.png|W:#ffff00"/>
				<property name="lifetime" value="100"/>
				<property name="fade-in" value="10"/>
				<property name="fade-out" value="90"/>
				<property name="output" min="0" max="1"/>
				<property name="randomnes" value="200"/>
			</emitter>
			<emitter>
				<property name="gravity" value="-0.2"/>
				<property name="momentum" value="0.9"/>
				<property name="image" value="graphics/particles/orb-small.png|W:#ff0000"/>
				<property name="lifetime" value="100"/>
				<property name="fade-in" value="10"/>
				<property name="fade-out" value="90"/>
				<property name="output" min="0" max="1"/>
				<property name="randomnes" value="200"/>
			</emitter>
		</emitter>
	</particle>
</effect>
i just change the colors
Image
User avatar
Crush
TMW Adviser
TMW Adviser
Posts: 8046
Joined: 25 Aug 2005, 17:08
Location: Germany

Re: particle effect ??

Post by Crush » 25 Jan 2010, 18:38

I just copied that code into the original soulmenhir.particle.xml file and the effect works perfectly here - yellow glowing particles with a few smaller red ones.

Maybe a problem with the character encoding of your text editor? Make sure that it saves the file in ANSI/ASCII encoding or in UTF-8 without BOM.
  • former Manasource Programmer
  • former TMW Pixel artist
  • NOT a game master

Please do not send me any inquiries regarding player accounts on TMW.


You might have heard a certain rumor about me. This rumor is completely false. You might also have heard the other rumor about me. This rumor is 100% accurate.
User avatar
lien
Novice
Novice
Posts: 446
Joined: 30 Oct 2008, 09:59
Location: France

Re: particle effect ??

Post by lien » 25 Jan 2010, 18:43

Crush wrote:I just copied that code into the original soulmenhir.particle.xml file and the effect works perfectly here - yellow glowing particles with a few smaller red ones.

Maybe a problem with the character encoding of your text editor? Make sure that it saves the file in ANSI/ASCII encoding or in UTF-8 without BOM.
my text editor is text edit Image
Image
User avatar
Crush
TMW Adviser
TMW Adviser
Posts: 8046
Joined: 25 Aug 2005, 17:08
Location: Germany

Re: particle effect ??

Post by Crush » 25 Jan 2010, 18:52

Sorry, but I don't own a mac. I can not help you with configuring it correctly. Consult the help file, the official Apple support or an apple support group to find out how to configure the encoding of your text editor / how to install a text editor where the encoding settings are more intuitively.
  • former Manasource Programmer
  • former TMW Pixel artist
  • NOT a game master

Please do not send me any inquiries regarding player accounts on TMW.


You might have heard a certain rumor about me. This rumor is completely false. You might also have heard the other rumor about me. This rumor is 100% accurate.
User avatar
lien
Novice
Novice
Posts: 446
Joined: 30 Oct 2008, 09:59
Location: France

Re: particle effect ??

Post by lien » 27 Jan 2010, 14:36

now i use VIM :wink: (just fot the xml )
but the efect disaperaers again :cry:
srenshot.jpg
srenshot.jpg (99.61 KiB) Viewed 1306 times
what the problem ? ...
:?:
yeah i know you haven't my computer
edit my "xml valors" is

Code: Select all

<?xml version="1.0"?>
<!--
character some magical aura.
-->
<effect>
	<particle
		position-x = "0"
		position-y = "0"
		position-z = "0"
		>
		<emitter>
			<property name="position-z" value="16" />
			<property name="vertical-angle" min="0" max="90"/>
			<property name="horizontal-angle" min="0" max="360"/>
			<property name="power" min="20" max="24"/>
			<property name="lifetime" value="1"/>
			<property name="output" value="1"/>
			<emitter>
				<property name="gravity" value="-0.2"/>
				<property name="momentum" value="0.9"/>
				<property name="image" value="graphics/particles/gloworb-medium.png|W:#ffff00,fbbe2a,fb8d2a"/>
				<property name="lifetime" value="100"/>
				<property name="fade-in" value="10"/>
				<property name="fade-out" value="90"/>
				<property name="output" min="0" max="1"/>
				<property name="randomnes" value="200"/>
			</emitter>
			<emitter>
				<property name="gravity" value="-0.2"/>
				<property name="momentum" value="0.9"/>
				<property name="image" value="graphics/particles/orb-small.png|W:#ff0000,9f0505,c8320a,8e2306"/>
				<property name="lifetime" value="100"/>
				<property name="fade-in" value="10"/>
				<property name="fade-out" value="90"/>
				<property name="output" min="0" max="1"/>
				<property name="randomnes" value="200"/>
			</emitter>
		</emitter>
	</particle>
</effect>
Image
Post Reply