Stop automatically switching to bow

Ask for help regarding any technical issue or report any bug or OS independent issues.
Post Reply
qwertymodo
Peon
Peon
Posts: 20
Joined: 06 Jul 2009, 23:31

Stop automatically switching to bow

Post by qwertymodo » 30 Sep 2014, 21:33

It's been awhile since I've played, so I'm sure this is a simple, stupid thing I've overlooked, but any time I try to attack a monster, it switches my weapon to the bow automatically. I can go into my equipment, manually re-equip my sword, attack, and bam, bow again... it's driving me nuts. I'm using the latest ManaPlus client, and I've gone through all of the input options to see if maybe it's a button I'm hitting, but I can't find anything that seems to be related to this. Any ideas?
User avatar
meway
Knight
Knight
Posts: 1736
Joined: 04 Jan 2009, 06:02
Location: Detroit MI
Contact:

Re: Stop automatically switching to bow

Post by meway » 30 Sep 2014, 23:53

Yes seriously ^
4144
Client Developer
Client Developer
Posts: 945
Joined: 03 Aug 2009, 12:57

Re: Stop automatically switching to bow

Post by 4144 » 01 Oct 2014, 09:55

qwertymodo wrote:It's been awhile since I've played, so I'm sure this is a simple, stupid thing I've overlooked, but any time I try to attack a monster, it switches my weapon to the bow automatically. I can go into my equipment, manually re-equip my sword, attack, and bam, bow again... it's driving me nuts. I'm using the latest ManaPlus client, and I've gone through all of the input options to see if maybe it's a button I'm hitting, but I can't find anything that seems to be related to this. Any ideas?
Press G key.
Also look to yellow bar http://manaplus.org/yellowbar
User avatar
Cassy
TMW Adviser
TMW Adviser
Posts: 790
Joined: 09 Mar 2013, 10:39
Location: ♥ Fluffyland ♥
Contact:

Re: Stop automatically switching to bow

Post by Cassy » 01 Oct 2014, 09:59

Oki, I think it goes this way:
- Activate your yellow bar if it isn't already: Right click on any bar on the top left of the screen (e.g. HP bar) and "Show Status Bar"
- Turn it yellow (enable it) if it isn't already by pressing "8" on your Numpad (you also disable it like that)
- Press "G" until the appropriate letter (the 5th) in the yellow bar says "D" (default attack)

Hope this helps.... meeeh 4144 was faster *throws some C++ code at 4144*
meway wrote:Yes seriously ^
:alt-2:
Main characters:
Lv.94 - Cassy - speedarcher on dark path, bunny-wannabe, would like to ride on a Mouboo once...
Lv.95 - Biqcassy - mage on light path, addicted to her Fluffy Hat, love-hates Fallens, really misses Confused Tree...
Lv.70 - Simca. - dreams of becoming a speedarcher on light path, still has a lot to learn...

Personal development overview | priorities | wiki to-do | wiki profile incl. other characters

[20:24:59] <Cassy> debug npc in crypts!
[20:25:02] <Cassy> just a joke...
[20:25:08] <wushin> DONT DO THAT
[20:25:10] <o11c> !slap Cassy
qwertymodo
Peon
Peon
Posts: 20
Joined: 06 Jul 2009, 23:31

Re: Stop automatically switching to bow

Post by qwertymodo » 01 Oct 2014, 19:16

4144 wrote:Also look to yellow bar http://manaplus.org/yellowbar
:alt-1:

Thanks for the help, but holy frak, whoever developed that whole "yellow bar" UI needs some serious help... modes are bad, mmkay?
User avatar
veryape
Game Master
Game Master
Posts: 556
Joined: 06 Dec 2012, 13:08
Contact:

Re: Stop automatically switching to bow

Post by veryape » 01 Oct 2014, 23:47

To be honest i love the yellowbar, maybe it should/could be locked as default but keep the functionality for "powerusers".
Characters: veryape / Captain Dunce / Elvara / veryapeGM
Post Reply