Problems with automake-1.9

Ask for help regarding any technical issue or report any bug or OS independent issues.
PranaBR
Peon
Peon
Posts: 37
Joined: Fri Oct 14, 2005 1:21 am

Problems with automake-1.9

Post by PranaBR » Fri Oct 14, 2005 1:46 am

I got 2 automake's version and nothing, they dont work, i read all install notes, i did that:

sh ./configure
ok its work

make
oh feces, we get a great problem

see:

root /home/famelix/automake-1.9 $ -> make
cd . && perllibdir=/home/famelix/automake-1.9"/lib:./lib" /home/famelix/automake-1.9/aclocal --acdir=m4
/bin/sh: /home/famelix/automake-1.9/aclocal: No such file or directory
make: ** [aclocal.m4] Erro 127

i located for this file and i found, more he doesnt work

without automake i cant install guichan

see bellow:

WARNING: `automake-1.9' is needed, and you do not seem to have it handy on your
system. You might have modified somefiles without having the
proper tools for further handling them. Check the `README' file,
it often tells you about the needed prerequirements for installing
this package. You may also peek at any GNU archive site, in case
some other package would contain thismissing `automake-1.9' program.

i got automake-1.9, i followed the read and install file more.. :"""(


solve it :D
PranaBR
Peon
Peon
Posts: 37
Joined: Fri Oct 14, 2005 1:21 am

Post by PranaBR » Fri Oct 14, 2005 3:09 am

answer please. the only one thing that is missing is automake and guichan, i already installed

* SDL
* SDL_image
* SDL_mixer
(* Guichan 0.4.0 missing :(((((( )
* PhysFS
* libxml2
* zlib
* libcurl
*autoconf
*gsmlib
*allegro

help me fast i want to play mana world, i dont have what do in this pc, i need install mana world, therefore i stay typing because i dont have what do, i need things to do, i hope play today yet, someoneeeeeee solve my problem and god bless u :)
User avatar
ElvenProgrammer
TMW Adviser
TMW Adviser
Posts: 2526
Joined: Tue Apr 13, 2004 8:11 pm
Location: Italy
Contact:

Post by ElvenProgrammer » Fri Oct 14, 2005 7:58 am

This is not so clear? Did you install automake-1.9? It seems that's the only way to solve it? What distro are you using?
User avatar
Bertram
Knight
Knight
Posts: 1026
Joined: Tue Sep 07, 2004 3:55 pm
Location: France

Automake multiple versions problem

Post by Bertram » Fri Oct 14, 2005 3:00 pm

That problem can happen if you have not installed the 1.9 version of automake and / or if you have installed more than one version of automake. You'll need the 1.9 exclusively.

Surely, you'll have to automake guichan, and 'make install' guichan from sources if you can't install it.
Be sure to add a destructor to the ListModel class in the file include/listmodel.hpp in the guichan's sources before configuring and making.
Ex :
~ListModel() {};
Just under the 'public:' line, if it isn't already done, when compiling with gcc 4.0.x.

Also, while configuring guichan using ./configure, be sure you have yes in front of, at least, SDL Mode in the option report, just before doing 'make'.
To get guichan made with sdl support, you'll need the -dev files of SDL (of course.)
Ah, and you don't need allegro.

I hope I've helped you a little.
And don't hesitate to come the irc channel to get more effective and more active support.

Thanks for reading,
PranaBR
Peon
Peon
Posts: 37
Joined: Fri Oct 14, 2005 1:21 am

Post by PranaBR » Fri Oct 14, 2005 5:16 pm

MY DISTRO IS FAMELIX

i think you dont understand my problem, i cant install automake-9
appear errors

i took automake-1.9.tar.gz and after i extract for automake-1.9
then i open a terminal console and i typed:

sudo su
root: cd /home/famelix/automake-1.9
root /home/famelix/automake-1.9:./configure
root /home/famelix/automake-1.9: make

after of this command appear this error
or be i need help for install automake-1.9

root /home/famelix/automake-1.9 $ -> make
cd . && perllibdir=/home/famelix/automake-1.9"/lib:./lib" /home/famelix/automake-1.9/aclocal --acdir=m4
/bin/sh: /home/famelix/automake-1.9/aclocal: No such file or directory
make: ** [aclocal.m4] Erro 127
PranaBR
Peon
Peon
Posts: 37
Joined: Fri Oct 14, 2005 1:21 am

mission acomplished

Post by PranaBR » Fri Oct 14, 2005 6:09 pm

I installed automake-1.9 congratulations for us
\o/ yuHUUUUUUHuHUUUUUUUUUUUUUUUUU


cd . && perllibdir=/home/famelix/automake-1.9"/lib:./lib" /home/famelix/automake-1.9/aclocal --acdir=m4
/bin/sh: /home/famelix/automake-1.9/aclocal: No such file or directory
make: ** [aclocal.m4] Erro 127

i did this:

i opened the file aclocal.m4 i selected all and copy, after i opened a new text file and i pressed cotrol + v, after i overwrite the file aclocal.m4

after gived other error

cd . && perllibdir=/home/famelix/automake-1.9"/lib:./lib" /home/famelix/automake-1.9/automake --libdir=lib --gnu
/bin/sh: /home/famelix/automake-1.9/automake: No such file or directory
make: ** [Makefile.in] Erro 1

i did the same, and after i gived MAKE and he worksssssssssssssssssssssssss

now i go try install guichan, after i come back to speak results thx





:wink: :evil: :shock: :lol: 8)
PranaBR
Peon
Peon
Posts: 37
Joined: Fri Oct 14, 2005 1:21 am

Post by PranaBR » Fri Oct 14, 2005 6:24 pm

other problem during make install of automake-1.9 appear this error:

make[2]: nothing to be done to `install-exec-am'.
make[2]: nothing to be done to `install-data-am'.
PranaBR
Peon
Peon
Posts: 37
Joined: Fri Oct 14, 2005 1:21 am

Post by PranaBR » Fri Oct 14, 2005 7:09 pm

hey guys im tired, please i pray for someone make upload of the file
/usr/share/automake-1.9
and
/usr/share/automake

i cant install please someone upload for some site i pray please ok guy ?
thx
User avatar
criptos
Peon
Peon
Posts: 75
Joined: Tue Sep 20, 2005 5:00 pm
Contact:

Post by criptos » Fri Oct 14, 2005 9:20 pm

thos files come with your automake and autoconf package, include devel also...
May the Source be With You
PranaBR
Peon
Peon
Posts: 37
Joined: Fri Oct 14, 2005 1:21 am

Post by PranaBR » Fri Oct 14, 2005 9:23 pm

yes they come, but i cant install, cant installllllllllllllllllllllllllllllllllllll

give error

:cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry:


admins help me, u that know
User avatar
criptos
Peon
Peon
Posts: 75
Joined: Tue Sep 20, 2005 5:00 pm
Contact:

Post by criptos » Fri Oct 14, 2005 9:27 pm

How are yu trying to install them?

Please post command line, executed.
Distribution used.
name of file used.
May the Source be With You
PranaBR
Peon
Peon
Posts: 37
Joined: Fri Oct 14, 2005 1:21 am

Post by PranaBR » Fri Oct 14, 2005 10:08 pm

distribution is FAMELIX

i took the packet automake-1.9.6.tar.gz and i extracted after
i typed

cd /home/famelix/automake-1.9.6 so:
root /home/famelix/automake-1.9.6 $ ->
after i rotated command ./configure

here :

root /home/famelix/automake-1.9.6 $ -> ./configure
checking build system type... i686-pc-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for perl... /usr/bin/perl
checking for tex... no
checking whether autoconf is installed... yes
checking whether autoconf works... yes
checking whether autoconf is recent enough... yes
checking whether ln works... yes
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for fgrep... /bin/grep -F
configure: creating ./config.status
config.status: creating Makefile
config.status: creating doc/Makefile
config.status: creating lib/Automake/Makefile
config.status: creating lib/Automake/tests/Makefile
config.status: creating lib/Makefile
config.status: creating lib/am/Makefile
config.status: creating m4/Makefile
config.status: creating tests/Makefile
config.status: creating tests/defs
config.status: creating tests/aclocal-1.9
config.status: creating tests/automake-1.9

after i rotated command make

root /home/famelix/automake-1.9.6 $ -> make
cd . && perllibdir=/home/famelix/automake-1.9.6"/lib:./lib" /home/famelix/automake-1.9.6/aclocal --acdir=m4
/bin/sh: /home/famelix/automake-1.9.6/aclocal: No such file or directory
make: *** [aclocal.m4] Error 127


error
User avatar
biggeruniverse
Peon
Peon
Posts: 42
Joined: Sat Sep 17, 2005 5:33 am

Post by biggeruniverse » Fri Oct 14, 2005 10:26 pm

This is a (little) known issue with certain distros that was never resolved. RedHat has it too.

You need to get the preconfigured source from someone that can run configure successfully.
We are on the outer reaches of someone else's universe
PranaBR
Peon
Peon
Posts: 37
Joined: Fri Oct 14, 2005 1:21 am

Post by PranaBR » Fri Oct 14, 2005 10:31 pm

bigger can u send me ? and talk step-by-step for me do please

if someone want help me also you can send me too

blonix@hotmail.com
standing by thx
PranaBR
Peon
Peon
Posts: 37
Joined: Fri Oct 14, 2005 1:21 am

Post by PranaBR » Fri Oct 14, 2005 10:53 pm

i ask for run

apt-get install automake

see what appeared

root /home/famelix/automake-1.9.6 $ -> apt-get install automake
Lendo Lista de Pacotes... Pronto
Construindo ?rvore de Depend?ncias... Pronto
Nota, selecionando automake1.4 ao inv?s de automake
automake1.4 j? ? a vers?o mais nova.
0 pacotes atualizados, 0 novos instalados, 0 a serem removidos e 701 n?o atualizados.

when i went install automake-1.9 i deleted the file /usr/share/loca/automake-1.4

because to play need 1.9

and now i cant remove automake because it seems there is no automake
but when i ran apt-get install automake appeared
automake1.4 is the newest version
but there isnt this file nor folder

what can i do ?
Post Reply