[solved] u bu nt u

Ask for help regarding any technical issue or report any bug or OS independent issues.
Post Reply
mmmmnatheclumsyone
Peon
Peon
Posts: 29
Joined: 09 Sep 2009, 16:57

[solved] u bu nt u

Post by mmmmnatheclumsyone » 02 Feb 2010, 04:11

I just installed Ubuntu Netbook Remix 9.10 onto my desktop box.
-I installed Netbook remix version simply because, in this order, Kubuntu 9.10, Ubuntu Lite 9.10 and Ubuntu Desktop 9.10 all failed to set up networking when installed. I then tried UNR 9.10 because I already use that on my EeePC 900A, so I felt that might work better with odd wifi cards (my broadcom works fine in live all 9.10 discs), so after I installed UNR on the desktop box, I simply gave up on installing yet another Ubuntu. Managed to gt wifi running. Stayed at UNR. For now. I'm not sure it makes any difference, but maybe the kernel is different.

I just installed TMW 0.29.1 and logged in.
It is sl ow. I walk in slow motion. People RACE past me.
Smoke from the Soul Menhir takes forever to rise.

I thought that maybe I needed OpenGL, so I enabled that, exited and restarted TMW, but no better.

I installed the client from the Ubuntu Repositories, is that version a known problem, by any chance? Or is it just me?

EDIT 1: Tried adjusting frame rate from 60 to 120, seems no better. I'm running maybe 8-10 frames per second.
Last edited by mmmmnatheclumsyone on 03 Feb 2010, 15:04, edited 1 time in total.
theboomboomcars
Peon
Peon
Posts: 29
Joined: 09 Apr 2009, 18:05

Re: u bu nt u

Post by theboomboomcars » 02 Feb 2010, 04:51

What are your system specs? Do you have an openGL video driver enabled?
August Knight
Peon
Peon
Posts: 78
Joined: 03 Oct 2009, 03:06

Re: u bu nt u

Post by August Knight » 02 Feb 2010, 07:56

As a temporary fix, you can also go under SETUP and drag the slider for Ambient FX, Partial detail to low/off. You can also remove the "particle effects" to boost the fps a bit
mmmmnatheclumsyone
Peon
Peon
Posts: 29
Joined: 09 Sep 2009, 16:57

Re: u bu nt u

Post by mmmmnatheclumsyone » 02 Feb 2010, 20:04

Tried moving the particle and ambient sliders to left, no improvement.

I'm thinking the problem will be the drivers. Same hardware under a different distro (PCLinuxOS 2009.1) ran fine.

System: ECS RC410l/800M mainboard (NOT using the onboard Radeon X200 graphics), 64 bit Celeron D 3.33 GHz unicore CPU (yes, Celeron D has 64 bit), 1G ram, added PCIe Radeon X500XL graphics card (using this), Viewsonic Optiquest Q9B LCD.

OS: Last night, I installed Ubuntu Desktop 9.10 for 64bit, I formatted and installed over the Netbook install that I mentioned in my first post.

Note: I formatted the Netbook install because I had just installed ATI drivers from the repository into that install, and those drivers totally wrecked my system - made X fail in a weird way, and evidently Ubuntu feels we do not need consoles (alt-F1 through alt-F6 are not bringing up consoles). That means the drivers in the repository are going to wreck my system. For the worse, I have already tried installing the very latest 10.1 ATI drivers and those drivers did the exact same thing - wrecked X.

In both cases where I installed ATI drivers, the next boot had X frozen at a blank screen for over 10 minutes.

Not really sure how PCLOS got this configured in a way that ran so much faster.

How do I enable acceleration in Ubuntu 9.10 64?
User avatar
Freeyorp101
Administrator
Administrator
Posts: 704
Joined: 04 Nov 2008, 10:17
Location: New Zealand

Re: u bu nt u

Post by Freeyorp101 » 03 Feb 2010, 00:08

mmmmnatheclumsyone wrote:evidently Ubuntu feels we do not need consoles (alt-F1 through alt-F6 are not bringing up consoles).
Ctrl-Alt-[F-Key]. You can also startup into a console by selecting that mode in grub.
mmmmnatheclumsyone wrote:Note: I formatted the Netbook install because I had just installed ATI drivers from the repository into that install,[...] means the drivers in the repository are going to wreck my system. For the worse, I have already tried installing the very latest 10.1 ATI drivers and those drivers did the exact same thing - wrecked X.
Try using the latest drivers directly from [ATI]. These have both GUI and console modes, if your system can't run X.
mmmmnatheclumsyone wrote:How do I enable acceleration in Ubuntu 9.10 64?
With the proprietary ATI drivers, aticonfig --initial -f if your current configuration does not work. aticonfig --initial --input=/etc/X11/xorg.conf otherwise.
See aticonfig --help for a more comprehensive set of flags and options. There are quite a lot, but it should be well worth reading through.

The free drivers may also be worth a try if the proprietary drivers consistently fail. The free drivers work better on some chips than others, though...


---Freeyorp
(09:58:17) < tux9th> Freeyorp: your sig on the forums is kind of outdated
theboomboomcars
Peon
Peon
Posts: 29
Joined: 09 Apr 2009, 18:05

Re: u bu nt u

Post by theboomboomcars » 03 Feb 2010, 02:55

A good place to check for help on getting your graphic driver working would be the forums at phoronix. They have an active, knowledgeable community, with some ATi/AMD developers on it.
mmmmnatheclumsyone
Peon
Peon
Posts: 29
Joined: 09 Sep 2009, 16:57

Re: u bu nt u

Post by mmmmnatheclumsyone » 03 Feb 2010, 03:20

Freeyorp101 wrote:Ctrl-Alt-[F-Key]. You can also startup into a console by selecting that mode in grub.
Thanks for letting me know abouit the ctrl part. I really thought I had tried that, but it just worked a moment ago, so I have no ideas whether I failed to press the ctrl key or if the system was too trashed when I tried it.

Freeyorp101 wrote:Try using the latest drivers directly from [ATI]. These have both GUI and console modes, if your system can't run X.
Quoting my earlier post:
mmmmnatheclumsyone wrote:I have already tried installing the very latest 10.1 ATI drivers and those drivers did the exact same thing - wrecked X.
Moreover, I am locked out of console because I have already logged in via X when the crash takes place. And I would have had no idea what to try from the commandline even if I had been able to get a prompt.

mmmmnatheclumsyone wrote:How do I enable acceleration in Ubuntu 9.10 64?
Freeyorp101 wrote: With the proprietary ATI drivers, aticonfig --initial -f if your current configuration does not work. aticonfig --initial --input=/etc/X11/xorg.conf otherwise.
See aticonfig --help for a more comprehensive set of flags and options. There are quite a lot, but it should be well worth reading through.

The free drivers may also be worth a try if the proprietary drivers consistently fail. The free drivers work better on some chips than others, though...---Freeyorp
Tried that on one of the the 2 version 10.1 installs. Botched X.

In all instances of wrecked xserver after installing graphics drivers, rebooting made no difference - I was still trying to get a console, but the graphics were locked immediately after boot sequence began. When these things look like they are going to take dozens of hours, I can reinstall in less than 2 hours, so I take the faster way out (I don't have lots of time to waste researching then fixing the situation).


Speaking of fixing things... my issue is fixed.
History: With apic enabled AND lapic enabled, my system won't boot Ubuntu (won't boot @ live CD, wont boot @ installed). The solution to boot my system is to pass EITHER a noapic option OR a nolapic option via grub (now called grub2). I've learned I can get the system to boot by choosing one. Since I posted above, I tried installing 3rd party ATI drivers, the X server got wasted once more, and so I've installed Ubuntu 9.10 Desktop for 64 bit once again.

My solution for very choppy TMW in Ubuntu 9.10: In the instance of TMW running so very slow, I had set my boot option for nolapic, and that is when TMW ran slowly. On this install, I caught myself just as I was about to edit the grub config to add nolapic, and instead I entered noapic (since either option works for me). sudo bash, edit grub config, update-grub, reboot, install TMW, all is fine.

Sometimes these problems go WAAAAAAAAAY back.

My best guess here is that enabling lapic (when I boot with noapic) for my system is better than enabling apic (when I boot with nolapic). Which might make some sense, since lapic came after as a result of trying to fix the problems that apic had. Wikipedia is your friend.
Post Reply