Linux compile problem..

Ask for help regarding any technical issue or report any bug or OS independent issues.
Post Reply
SirKillalot
Peon
Peon
Posts: 2
Joined: 02 Nov 2005, 13:37
Contact:

Linux compile problem..

Post by SirKillalot » 02 Nov 2005, 13:43

Hi,
I'm new to TMW, and I got very excited when I saw the screenshots. I tried nearly everything to get it work on my Breezy Ubuntu machine, but have big problems with it. First I tried the .deb package but I just got errors saying I wouln't have libc++6 installed or something. Then I got the hint to compile the game, and that It'll work then. So I downloaded the code and configured it without problems. Now I am trying to 'make' it but I get these errors:

Code: Select all

gui/../sound.h:27:23: Fehler: SDL_mixer.h: Datei oder Verzeichnis nicht gefunden (file or directory not found)

gui/../sound.h:116: Fehler: ISO-C++ verbietet Deklaration von »Mix_Music« ohne Typ (ISO-C++ forbits declaring Mix_Music without a type)

gui/../sound.h:116: Fehler: expected »;« before »*« token

make[2]: *** [tmw-setup.o] Fehler 1
make[2]: Verlasse Verzeichnis »/home/caglar/Desktop/tmw-0.0.17/src«
make[1]: *** [all-recursive] Fehler 1
make[1]: Verlasse Verzeichnis »/home/caglar/Desktop/tmw-0.0.17«
make: *** [all] Fehler 2
(I wrote the english message in brackets)

So, first I thought SDL_mixer would make troubles. But I reinstalled it and did everything possible but it won't work (also the configure script doesnt say anything about a missin SDL_mixer header or something).

I would be glad if someone could help me with my problem.
Thanks
User avatar
ktm
Novice
Novice
Posts: 201
Joined: 14 Jul 2005, 10:24
Location: Vokietija

Post by ktm » 02 Nov 2005, 17:56

"gui/../sound.h:27:23: Fehler: SDL_mixer.h: Datei oder Verzeichnis nicht gefunden"
check mal, ob die sdl-quellen denn auch im richtigen verzeichnis stecken; oder pass eben die pfadangaben in den tmw-quellen an. die restlichen zwei fehler sollten damit dann auch beseitigt sein.
Matt
Knight
Knight
Posts: 1747
Joined: 07 Aug 2004, 11:47
Location: Germany->Bavaria

Post by Matt » 02 Nov 2005, 18:02

If elven see you speaking nazi language he'll kill you ;)
User avatar
ktm
Novice
Novice
Posts: 201
Joined: 14 Jul 2005, 10:24
Location: Vokietija

Post by ktm » 02 Nov 2005, 18:43

yeah, whatever... if we didn't have had to back up moussolini, we'd probably have won, and he would speak it too :wink:
anyways, the above's just another lame dependency problem, not really interesting to anyone but the poster. so, who cares.

(btw, und wenn wir (deutschen) immer weiter auf dem zeug rumreiten, werden wir das image nie los.)
SirKillalot
Peon
Peon
Posts: 2
Joined: 02 Nov 2005, 13:37
Contact:

Post by SirKillalot » 03 Nov 2005, 23:57

Ok, fixed the problem by copying all files from /usr/include/SDL to /usr/local/include/SDL

Thank you!
Gonzalo
Peon
Peon
Posts: 41
Joined: 12 Oct 2005, 14:54
Contact:

Post by Gonzalo » 04 Nov 2005, 13:23

Maybe it would've been better to use some --with-sdl-something configure option, rather than copying files... that's too... "Windowsish" :mrgreen:.
Anyways, if it worked... it worked :P.

Code: Select all

System.out.println("Java Developer");
echo 'Powered by Debian GNU/Linux'
Post Reply