Ubuntu 10.04 Mouse clicks

Ask for help regarding any technical issue or report any bug or OS independent issues.
Post Reply
User avatar
Jaxad0127
TMW Adviser
TMW Adviser
Posts: 4209
Joined: Thu Nov 01, 2007 6:35 pm
Location: Internet

Re: Ubuntu 10.04 Mouse clicks

Post by Jaxad0127 » Sun May 09, 2010 2:23 am

We've observed that with some WMs. Which one are you using?
Image
User avatar
v0id
Novice
Novice
Posts: 196
Joined: Tue Sep 15, 2009 10:31 pm
Location: Désolé, je ne loue pas.

Re: Ubuntu 10.04 Mouse clicks

Post by v0id » Mon May 10, 2010 1:07 pm

This problem appeared when i recompiled tmw with the last version of SDL, in Ubuntu 9.10.

As Ubuntu 10.04 has that last version of SDL in the repositories, this is why lots of people have this issue in 10.04.

To perform a click, you need to move the mouse a bit between your mouse down and mouse release.
User avatar
5t3v3
Novice
Novice
Posts: 451
Joined: Wed Oct 31, 2007 4:08 pm
Location: Belgium
Contact:

Re: Ubuntu 10.04 Mouse clicks

Post by 5t3v3 » Sun May 23, 2010 12:09 am

I've had teh same problem with battle of Wesnoth
After a quick google I found:
This is a known bug in libsdl (yes, ubuntu will ship a broken libsdl in 10.4 if they don't react...): http://bugzilla.libsdl.org/show_bug.cgi?id=894

Workaround: Either downgrade to libsdl 1.2.13 or switch to fullscreen mode.
BTW, is there a shortcutkey for fullscreen in tmw?
In game characters: "5t3v3" and "L "
User avatar
Jaxad0127
TMW Adviser
TMW Adviser
Posts: 4209
Joined: Thu Nov 01, 2007 6:35 pm
Location: Internet

Re: Ubuntu 10.04 Mouse clicks

Post by Jaxad0127 » Sun May 23, 2010 1:32 am

5t3v3 wrote:BTW, is there a shortcutkey for fullscreen in tmw?
No.
Image
4144
Client Developer (Lead)
Client Developer (Lead)
Posts: 904
Joined: Mon Aug 03, 2009 12:57 pm

Re: Ubuntu 10.04 Mouse clicks

Post by 4144 » Sun May 23, 2010 12:35 pm

Lord of the Flies wrote:So I upgraded to Ubuntu 10.04 LTS last night. I compiled TMW Client 0.0.29.1 on it but noticed I am no longer able to click the client buttons with my mouse. I have to use my keyboard. Any suggestions?
You can try disable compiz effects.
Also may be help minimize/restore game window.
Post Reply