libstdc

Ask for help regarding any technical issue or report any bug or OS independent issues.
Post Reply
akurashy
Peon
Peon
Posts: 8
Joined: 19 Nov 2005, 05:36

libstdc

Post by akurashy » 19 Nov 2005, 05:40

maybe im going to get a bit yelled for not searching! but its kinda later here and my head hurts =/

here is the error i'm getting

Code: Select all

david@akulinux:~$ tmw
tmw: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.6' not found (required by tmw)
tmw: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.6' not found (required by /usr/lib/libguichan_sdl.so.0)
tmw: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.6' not found (required by /usr/lib/libguichan.so.0)
david@akulinux:~$
Matt
Knight
Knight
Posts: 1747
Joined: 07 Aug 2004, 11:47
Location: Germany->Bavaria

Post by Matt » 19 Nov 2005, 09:53

Well you're using the wrong gcc version. The easiest way to fix this is that you compile guichan & tmw yourself.
User avatar
Platyna
Former Dictator
Former Dictator
Posts: 2213
Joined: 19 Nov 2005, 14:19
Location: Poland
Contact:

Post by Platyna » 19 Nov 2005, 14:38

It is rather glibc older than the one binaries were created on.

Regards.
Zuzanna K. Filutowska
[The rest of this signature was censored by TMWC's "Freedom" and "Free speech".]
akurashy
Peon
Peon
Posts: 8
Joined: 19 Nov 2005, 05:36

Post by akurashy » 19 Nov 2005, 17:25

well i'm trying to compile it but i got stuck in this one, i download libxml2 and it can't find it

Code: Select all

checking for xmlInitParser in -lxml2... no
configure: error:  *** Unable to find libxml2 library (xmlsoft.org)
david@akulinux:~/Files/tmw-0.0.17$ sudo apt-get install libxml2
Reading package lists... Done
Building dependency tree... Done
libxml2 is already the newest version.
akurashy
Peon
Peon
Posts: 8
Joined: 19 Nov 2005, 05:36

Post by akurashy » 19 Nov 2005, 18:36

oh yea just if you guys need to know, i'm on ubuntu breezy (5.10) might gives more hints
User avatar
ElvenProgrammer
TMW Adviser
TMW Adviser
Posts: 2526
Joined: 13 Apr 2004, 20:11
Location: Italy
Contact:

Post by ElvenProgrammer » 19 Nov 2005, 19:19

The question is: did you installed the dev package?
akurashy
Peon
Peon
Posts: 8
Joined: 19 Nov 2005, 05:36

Post by akurashy » 20 Nov 2005, 03:49

ElvenProgrammer wrote:The question is: did you installed the dev package?
Yes i did, but it gave me a libstdc error, then i tried compiling but i can't seem to get it right =/
User avatar
Platyna
Former Dictator
Former Dictator
Posts: 2213
Joined: 19 Nov 2005, 14:19
Location: Poland
Contact:

Post by Platyna » 20 Nov 2005, 12:54

I am telling you - you have libraries, tmw depends on that require a newer version of glibc than you have installed. You have to check your glibc version and upgrade it.


Regards.
Zuzanna K. Filutowska
[The rest of this signature was censored by TMWC's "Freedom" and "Free speech".]
Post Reply