Cannot load player_male_base.png

Ask for help regarding any technical issue or report any bug or OS independent issues.
Post Reply
Kelba
Peon
Peon
Posts: 4
Joined: Sat Dec 03, 2005 11:53 pm

Cannot load player_male_base.png

Post by Kelba » Sun Dec 04, 2005 7:11 am

Here's my log file:

Code: Select all

[05:26:16] Using video driver: x11
[05:26:16] Possible to create hardware surfaces: no
[05:26:16] Window manager available: yes
[05:26:16] Accelerated hardware to hardware blits: no
[05:26:16] Accelerated hardware to hardware colorkey blits: no
[05:26:16] Accelerated hardware to hardware alpha blits: no
[05:26:16] Accelerated software to hardware blits: no
[05:26:16] Accelerated software to hardware colorkey blits: no
[05:26:16] Accelerated software to hardware alpha blits: no
[05:26:16] Accelerated color fills: no
[05:26:16] Available video memory: 0
[05:26:16] ResourceManager::get(graphics/sprites/player_male_base.png)
[05:26:17] Error, image load failed: Unsupported image format
[05:26:17] ResourceManager::get(graphics/sprites/player_male_hair.png)
[05:26:18] Error, image load failed: Unsupported image format
[05:26:18] Error: Couldn't load player_male_base.png
SDL and SDL_Image are both up to date, and I'm using physfs 1.0.1 (I had tried 1.0.0, go t same error)
Matt
Knight
Knight
Posts: 1746
Joined: Sat Aug 07, 2004 11:47 am
Location: Germany->Bavaria

Post by Matt » Sun Dec 04, 2005 9:12 am

Do you have libpng installed?
User avatar
ElvenProgrammer
TMW Adviser
TMW Adviser
Posts: 2526
Joined: Tue Apr 13, 2004 8:11 pm
Location: Italy
Contact:

Post by ElvenProgrammer » Sun Dec 04, 2005 2:33 pm

Avoid using libphysfs 1.0.1 since we know it doesn't work with TMW.
Again follow Matt suggestion and be sure SDL_image was compiled with png support.
User avatar
Bjørn
TMW Adviser
TMW Adviser
Posts: 1430
Joined: Thu Dec 09, 2004 7:50 pm
Location: North Rhine-Westphalia, Germany
Contact:

Post by Bjørn » Sun Dec 04, 2005 6:56 pm

ElvenProgrammer wrote:Avoid using libphysfs 1.0.1 since we know it doesn't work with TMW.
Again follow Matt suggestion and be sure SDL_image was compiled with png support.
Actually it's 1.1.0 that is known not to work, I've been using 1.0.0 and 1.0.1 without problems.

The error however is "unsupported image format", suggesting that this is not related to PhysFS but indeed more likely to relate to SDL_image and libpng.
Kelba
Peon
Peon
Posts: 4
Joined: Sat Dec 03, 2005 11:53 pm

Post by Kelba » Sun Dec 04, 2005 7:25 pm

I downloaded and installed libpng, and recompiled and reinstalled sdl_image and I still get the same error concerning player_male_base.png. Any other ideas?
User avatar
ElvenProgrammer
TMW Adviser
TMW Adviser
Posts: 2526
Joined: Tue Apr 13, 2004 8:11 pm
Location: Italy
Contact:

Post by ElvenProgrammer » Sun Dec 04, 2005 7:27 pm

Bjørn wrote:
ElvenProgrammer wrote:Avoid using libphysfs 1.0.1 since we know it doesn't work with TMW.
Again follow Matt suggestion and be sure SDL_image was compiled with png support.
Actually it's 1.1.0 that is known not to work, I've been using 1.0.0 and 1.0.1 without problems.
Of course you're right, my fault, sorry.
Post Reply