Error in the "make" -process

Ask for help regarding any technical issue or report any bug or OS independent issues.
Post Reply
Ryuzaki
Newly Registered User
Posts: 2
Joined: Wed Aug 18, 2010 12:13 am

Error in the "make" -process

Post by Ryuzaki » Wed Aug 18, 2010 12:19 am

Hallo,

I'm using archlinux 64 bit. I've just tried to install tmw with the source package.
While configuring went well "make" just told me this error:

"emoteshortcut.cpp:29:1: Fehler: »EmoteShortcut::EmoteShortcut« names the constructor, not the type
make[2]: *** [tmw-emoteshortcut.o] Fehler 1
make[2]: Leaving directory `/home/.../Desktop/tmw/src'
make[1]: *** [all-recursive] Fehler 1
make[1]: Leaving directory `/home/.../Desktop/tmw'
make: *** [all] Fehler 2
"

(Fehler is a german word and means error)
User avatar
Kage
Warrior
Warrior
Posts: 927
Joined: Sat May 02, 2009 7:12 pm

Re: Error in the "make" -process

Post by Kage » Wed Aug 18, 2010 4:15 am

What client version and where did you get it from?
<Kage_Jittai> ... are you saying I am elite :D
<thorbjorn> Yes. :P
Ryuzaki
Newly Registered User
Posts: 2
Joined: Wed Aug 18, 2010 12:13 am

Re: Error in the "make" -process

Post by Ryuzaki » Wed Aug 18, 2010 4:46 am

It's the newest version avaiable on this website. Just had downloaded it ~15 minutes before I posted that error here.
User avatar
Jaxad0127
TMW Adviser
TMW Adviser
Posts: 4209
Joined: Thu Nov 01, 2007 6:35 pm
Location: Internet

Re: Error in the "make" -process

Post by Jaxad0127 » Wed Aug 18, 2010 5:03 pm

Do try the work on the next client release: http://gitorious.org/mana/mana.
Image
babel
Newly Registered User
Posts: 1
Joined: Tue Nov 16, 2010 6:39 pm
Location: méxico
Contact:

Re: Error in the "make" -process

Post by babel » Tue Nov 16, 2010 6:52 pm

I'm having the same problem with version 0.29.1 on an EeePC 1000HA using Meego 1.1. I tryed to compile an older version just to know if there's a bug in the newest one but I had the same error with 0.28 and 0.27, so i guess is not a problem with 0.29.

So, what should we do? wait for a newer version?
User avatar
Kage
Warrior
Warrior
Posts: 927
Joined: Sat May 02, 2009 7:12 pm

Re: Error in the "make" -process

Post by Kage » Tue Nov 16, 2010 6:56 pm

babel wrote:I'm having the same problem with version 0.29.1 on an EeePC 1000HA using Meego 1.1. I tryed to compile an older version just to know if there's a bug in the newest one but I had the same error with 0.28 and 0.27, so i guess is not a problem with 0.29.

So, what should we do? wait for a newer version?
I would try version 0.5: you can get it from here: http://gitorious.org/mana/mana/archive-tarball/0.5
<Kage_Jittai> ... are you saying I am elite :D
<thorbjorn> Yes. :P
Post Reply