manaserv error(s)

Content and general development discussion, including maps, quests, and server code from the development team.
Post Reply
jak1
Peon
Peon
Posts: 18
Joined: Thu May 07, 2009 12:42 am

manaserv error(s)

Post by jak1 » Mon Aug 30, 2010 10:08 am

hi guys,

i was trying to make a manaserv(tmwserv).
1. the howto from Wiki is very bad (if it should run on my system i will try to make a better one[with more description])
2. my errors are:

tmwserv-account

root@*****:~# tmwserv-account
[08:56:09] [INF] The Mana World Account+Chat Server v0.0.1
[08:56:09] [INF] Using Config File: /root/.tmwserv.xml
[08:56:09] [INF] Using Log File: /root/.tmwserv-account.log
[08:56:09] [INF] Trying to connect with SQLite database file 'tmw.db'
[08:56:09] [INF] Connection to database sucessfull.
[08:56:09] [ERR] Itemdatabase has wrong version format string!
Segmentation fault

root@*****:~#

tmwserv-game

to much,
the most are from monster.xml this are only some of them
[08:58:11] [WRN] monsters.xml: No attributes defined for monster #58 (Archant)
[08:58:11] [WRN] monsters.xml: No behavior defined for monster #58 (Archant)
[08:58:11] [WRN] monsters.xml: No experience defined for monster #58 (Archant)
[08:58:11] [WRN] monsters.xml: No attributes defined for monster #59 (Moggun)
[08:58:11] [WRN] monsters.xml: No behavior defined for monster #59 (Moggun)
[08:58:11] [WRN] monsters.xml: No experience defined for monster #59 (Moggun)
[08:58:11] [WRN] monsters.xml: No attributes defined for monster #60 (Terranite)
[08:58:11] [WRN] monsters.xml: No behavior defined for monster #60 (Terranite)
[08:58:11] [WRN] monsters.xml: No experience defined for monster #60 (Terranite)
[08:58:11] [INF] Loaded 55 monsters from monsters.xml.
[08:58:21] [INF] Unable to create a connection to an account server. <-- normal when the account server closed with seg. fault
[08:58:21] [INF] Game handler started:
[08:58:21] [INF] Listening on port 9604...
[08:58:31] [INF] World time: 100
[08:58:41] [INF] World time: 200
[08:58:51] [INF] Unable to create a connection to an account server.
[08:58:51] [INF] World time: 300
[08:59:01] [INF] World time: 400


more info
OS: Ubuntu 8.04LTS (Hardy) - 32Bit Minimal
> its a V-Server
what is wrong with items.xml and monster.xml?
i hope someone can help me... i want to test the new manaserv :cry:
yours jak1

note: if its wrong here move it pleace
@}->--- ---<-{@
User avatar
Bertram
Knight
Knight
Posts: 1026
Joined: Tue Sep 07, 2004 3:55 pm
Location: France

Re: manaserv error(s)

Post by Bertram » Mon Aug 30, 2010 12:30 pm

Hi Jak1,

Thanks for your interest into manaserv (previously named tmwserv).

1. About documentation, the most up-to-date doc can be found here, for both the client and the server:
http://doc.manasource.org/bertram_new_start

I hope you'll find what you're looking for.

2. The latest 'stable' source code of manaserv and compatible with the 0.0.29.1 client of the mana client beta2 and mana:1.0 branch
can be found here:
http://gitorious.org/mana/manaserv/commits/stable

(The tmwserv repository is obsolete.)

Shall I ask you to retry with the given release?

Best regards.
jak1
Peon
Peon
Posts: 18
Joined: Thu May 07, 2009 12:42 am

Re: manaserv error(s)

Post by jak1 » Mon Aug 30, 2010 2:58 pm

Thank you Bertram!

my english isn't so good, but i think i will get it :D
...
oh now ehm it run's,
i can connect from my client "manaplus" to server
Serveradress ***
Port: 9601
[ManaServ]

but :oops:
i can't register any account... why?
in the accountserver it tells me anything of
AccountHandler::processMessage, Invalid message type 5
do i anything wrong?
@}->--- ---<-{@
User avatar
Gotcha
Peon
Peon
Posts: 84
Joined: Thu Jul 29, 2010 4:16 pm

Re: manaserv error(s)

Post by Gotcha » Mon Aug 30, 2010 5:19 pm

hi!

what's your server now? manaserv or tmwathena?
regarding "Itemdatabase has wrong version format string!"
it seems your database tables are not up to date.
you should find a mysql folder where updates are.
for manaserv, the latest was update 9 to 10.

regarding the conncetion with manaplus, and since i am not sure if you now have a manaserv or a tmwathena server:
i guess it's related to enet1.3. the manaclient and also 4144 client were meant to connect to servers compiled with enet1.2.
however, for about little more than a week, manaserv needs enet1.3, that is, if your client isnt meant to connect to a enet1.3 supporting server,
(like older manaclients but also newer 4144clients), it wont connect.
if it's port 9601 we are talking about, i think its a manaserv server, when it 6901, its a tmwathena server.
(i'm just a bit confused about it because i have to start the newest manaserv server with manaserv-account and manaserv-game, and not tmwserv-account or tmwserv-game)
User avatar
Bertram
Knight
Knight
Posts: 1026
Joined: Tue Sep 07, 2004 3:55 pm
Location: France

Re: manaserv error(s)

Post by Bertram » Mon Aug 30, 2010 6:24 pm

To Jak1:

Well, first of all, the manaplus client hasn't been tested against manaserv servers for now, as reported by 4144 himself.

Secondly, I can't help you more without the client and servers logs. Can you provide them?

Best regards.
User avatar
Gotcha
Peon
Peon
Posts: 84
Joined: Thu Jul 29, 2010 4:16 pm

Re: manaserv error(s)

Post by Gotcha » Mon Aug 30, 2010 6:35 pm

regarding: "manaplus client hasn't been tested against manaserv servers for now"
i tested this, and it worked nice up to the point when manaserv started using enet1.3 a few days ago.
User avatar
Bertram
Knight
Knight
Posts: 1026
Joined: Tue Sep 07, 2004 3:55 pm
Location: France

Re: manaserv error(s)

Post by Bertram » Tue Aug 31, 2010 8:16 am

Hi Gotcha,
regarding: "manaplus client hasn't been tested against manaserv servers for now"
i tested this, and it worked nice up to the point when manaserv started using enet1.3 a few days ago.
:arrow: Nice to have you test that point. :)
I'm sure 4144 will update his client with latest source soon. Let's wait and see?

Best regards
Post Reply