CentOS5 Build Error.

Ask for help regarding any technical issue or report any bug or OS independent issues.
Post Reply
User avatar
visaboy
Peon
Peon
Posts: 29
Joined: Sun Jan 09, 2011 7:19 am

CentOS5 Build Error.

Post by visaboy » Sun Jan 09, 2011 7:30 am

I'm not entirely sure what the error means and I would appreciate if someone can lend me a hand here.

Code: Select all

[root@elite manaserv]# cmake .
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Looking for gethostbyaddr_r
-- Looking for gethostbyaddr_r - found
-- Looking for poll
-- Looking for poll - found
-- Looking for fcntl
-- Looking for fcntl - found
-- Looking for inet_pton
-- Looking for inet_pton - found
-- Looking for inet_ntop
-- Looking for inet_ntop - found
-- Looking for sys/types.h
-- Looking for sys/types.h - found
-- Looking for stdint.h
-- Looking for stdint.h - found
-- Looking for stddef.h
-- Looking for stddef.h - found
-- Check size of socklen_t
-- Check size of socklen_t - done
-- Performing Test HAS_MSGHDR_FLAGS
-- Performing Test HAS_MSGHDR_FLAGS - Success
-- checking for module 'libxml-2.0'
--   found libxml-2.0, version 2.6.26
-- Found LibXml2: /usr/lib/libxml2.so
-- Found ZLIB: /usr/lib/libz.so
-- Found Sqlite3 header file in /usr/include
-- Found Sqlite3 libraries: /usr/lib/libsqlite3.so
-- Found Lua51: /usr/lib/liblua.a;/usr/lib/libm.so
CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
PHYSFS_INCLUDE_DIR (ADVANCED)
   used as include directory in directory /home/manaserv/src
PHYSFS_LIBRARY (ADVANCED)
    linked by target "manaserv-account" in directory /home/manaserv/src
    linked by target "manaserv-game" in directory /home/manaserv/src

-- Configuring incomplete, errors occurred!
[root@elite manaserv]#
I'm using cmake . to build the source.

Thank you.
“If it moves, fondle it - except porcupines, ball lightning, and policemen” :)
User avatar
Crush
TMW Adviser
TMW Adviser
Posts: 8046
Joined: Thu Aug 25, 2005 5:08 pm
Location: Germany

Re: CentOS5 Build Error.

Post by Crush » Sun Jan 09, 2011 4:06 pm

It says that you don't have physfs installed.
  • former Manasource Programmer
  • former TMW Pixel artist
  • NOT a game master

Please do not send me any inquiries regarding player accounts on TMW.


You might have heard a certain rumor about me. This rumor is completely false. You might also have heard the other rumor about me. This rumor is 100% accurate.
User avatar
visaboy
Peon
Peon
Posts: 29
Joined: Sun Jan 09, 2011 7:19 am

Re: CentOS5 Build Error.

Post by visaboy » Mon Jan 10, 2011 12:28 am

I just needed to install physfs-devel, physfs was already installed. ;)

Thank you.
“If it moves, fondle it - except porcupines, ball lightning, and policemen” :)
Post Reply