no equpment

Ask for help regarding any technical issue or report any bug or OS independent issues.
Post Reply
User avatar
Mpa4Hu
Peon
Peon
Posts: 58
Joined: 18 Jul 2009, 13:26

no equpment

Post by Mpa4Hu » 20 Feb 2011, 18:03

Hello

I have windows 7, and i'm using Code:Block
i compiled server and client with MySQL.

when i enter game i have no equipments
as shown in the image.

i also compiled it with sqlite, but nothing changed.

Code: Select all

[21:54:33] [INF] Loading item reference: example/clientdata/items.xml
[21:54:33] [WRN] Item Manager: Item ID: -1 is invalid in items.xml, and will be
ignored.
[21:54:33] [WRN] Item Manager: Item ID: -2 is invalid in items.xml, and will be
ignored.
[21:54:33] [WRN] Item Manager: Item ID: -3 is invalid in items.xml, and will be
ignored.
[21:54:33] [WRN] Item Manager: Item ID: -4 is invalid in items.xml, and will be
ignored.
[21:54:33] [WRN] Item Manager: Item ID: -5 is invalid in items.xml, and will be
ignored.
[21:54:33] [WRN] Item Manager: Item ID: -6 is invalid in items.xml, and will be
ignored.
[21:54:33] [WRN] Item Manager: Item ID: -7 is invalid in items.xml, and will be
ignored.
[21:54:33] [WRN] Item Manager: Item ID: -8 is invalid in items.xml, and will be
ignored.
[21:54:33] [WRN] Item Manager: Item ID: -9 is invalid in items.xml, and will be
ignored.
[21:54:33] [WRN] Item Manager: Item ID: -10 is invalid in items.xml, and will be
 ignored.
[21:54:33] [WRN] Item Manager: Item ID: -11 is invalid in items.xml, and will be
 ignored.
[21:54:33] [WRN] Item Manager: Item ID: -12 is invalid in items.xml, and will be
 ignored.
[21:54:33] [WRN] Item Manager: Item ID: -13 is invalid in items.xml, and will be
 ignored.
[21:54:33] [WRN] Item Manager: Item ID: -14 is invalid in items.xml, and will be
 ignored.
[21:54:33] [WRN] Item Manager: Item ID: -15 is invalid in items.xml, and will be
 ignored.
[21:54:33] [WRN] Item Manager: Item ID: -16 is invalid in items.xml, and will be
 ignored.
[21:54:33] [WRN] Item Manager: Item ID: -100 is invalid in items.xml, and will b
e ignored.
[21:54:33] [WRN] Item Manager: Cooldown property not implemented yet!
[21:54:33] [INF] Loaded 7 items from example/clientdata/items.xml.
[21:54:33] [INF] Loading monster reference: example/clientdata/monsters.xml
[21:54:33] [INF] Loaded 4 monsters from monsters.xml.
[21:54:33] [INF] Loading status reference: example/clientdata/mana-status-effect
.xml
[21:54:33] [INF] Loading status script: scripts/status/plague.lua
[21:54:33] [INF] Loading status script: scripts/status/jump.lua
[21:54:33] [INF] Loading permission reference...
[21:54:33] [INF] The Mana Game Server v2nd milestone
[21:54:33] [INF] Manaserv Protocol version 1, Enet version 1.3.0
it's my gameserver, i thought maybe becouse of this warnings?

i'm using data from example as for server as for client

i recompiled it 3 times, in each i downloaded new and new repositories from git.
I also tried to use newest nightly builds but useless
Attachments
equp.png
equp.png (37.7 KiB) Viewed 1531 times
User avatar
Jaxad0127
TMW Adviser
TMW Adviser
Posts: 4209
Joined: 01 Nov 2007, 18:35
Location: Internet

Re: no equpment

Post by Jaxad0127 » 20 Feb 2011, 18:23

You need to equip something for it to show up.
Image
User avatar
Mpa4Hu
Peon
Peon
Posts: 58
Joined: 18 Jul 2009, 13:26

Re: no equpment

Post by Mpa4Hu » 20 Feb 2011, 18:34

I press the equip button but nothing happens
Attachments
equip2.png
equip2.png (88 KiB) Viewed 1525 times
User avatar
Mpa4Hu
Peon
Peon
Posts: 58
Joined: 18 Jul 2009, 13:26

Re: no equpment

Post by Mpa4Hu » 20 Feb 2011, 20:49

EDIT: i found in my client directory new file named with content

Code: Select all

Equip: 5 at 0x2
Equip: 9 at 1x1
i thought maybe it got something to do with my problem
User avatar
Bertram
Knight
Knight
Posts: 1026
Joined: 07 Sep 2004, 15:55
Location: France

Re: no equpment

Post by Bertram » 20 Feb 2011, 22:08

Hi Mpa4Hu,

As told on IRC, the equipment window and equipment handler is on rework for manaserv.

Once done, you'll see your equipment back.

Best regards.
Post Reply