liballeg.so.4.1 not found

Ask for help regarding any technical issue or report any bug or OS independent issues.
Post Reply
e

liballeg.so.4.1 not found

Post by e » Tue Aug 17, 2004 6:30 pm

hi,

i followed the offical TMW installation guide ( ;) ), but "./ManaWorld" fails:

Code: Select all

[e@localhost mana]$ ./ManaWorld 
./ManaWorld: error while loading shared libraries: liballeg.so.4.1: cannot open shared object file: No such file or directory
where do i have to put liballeg.so.4.1 to satisfy manaworld ?

note:

Code: Select all

[e@localhost mana]$ locate liballeg.so.4.1
/usr/local/lib/liballeg.so.4.1
[e@localhost mana]$ 
User avatar
nym
Novice
Novice
Posts: 116
Joined: Wed Aug 18, 2004 11:01 am
Contact:

Post by nym » Wed Aug 18, 2004 11:06 am

e:
What you need to do is set up a symlink called liballeg.so (in /usr/local/lib) which points to liballeg-4.0.3.so. Or if you are using allegro 4.1 (latest but still unstable), point the link to liballeg.so.4.1.

If you dont know how to do this, here is how:
su to root then:

cd /usr/local/lib
ln -sf liballeg-4.0.3.so liballeg.so
ldconfig

logout of root then you are free to build TMW :)
e

Post by e » Wed Aug 18, 2004 1:05 pm

does not work :(
do i have to rebuild TMW ?

Code: Select all

[e@localhost mana]$ ls /usr/local/lib/
4.1      liballeg-4.1.14.so  liballeg.so      liballeg_unsharable.a
allegro  liballeg.4.1.14.so  liballeg.so.4.1  pkgconfig
Guest

Post by Guest » Wed Aug 18, 2004 2:09 pm

add the line /usr/local/lib to your /etc/ld.so.conf
then rerun ldconfig
e

Post by e » Thu Aug 19, 2004 12:08 pm

ah fine :)

.. but there is still a problem :

Code: Select all

[e@localhost mana]$ ./ManaWorld 
Shutting down Allegro due to signal #11
Speicherzugriffsfehler
[e@localhost mana]$ 
// speicherzugriffsfehler = segmentation fault
User avatar
Chetic
Peon
Peon
Posts: 63
Joined: Mon Jul 12, 2004 10:31 am
Location: Sweden
Contact:

Post by Chetic » Sat Aug 21, 2004 3:04 pm

Try now with the latest CVS ;)
Quote of the year:
<Sull> the diff with GPL and priced software,GPL is faster to install cause you dont have to put a crack/serial

xD
e

Post by e » Mon Aug 23, 2004 10:17 am

yeah ! runs :D

.. is the login-server down ?
i cannot connect :(
User avatar
ElvenProgrammer
TMW Adviser
TMW Adviser
Posts: 2526
Joined: Tue Apr 13, 2004 8:11 pm
Location: Italy
Contact:

Post by ElvenProgrammer » Mon Aug 23, 2004 3:31 pm

Probably I made some mistakes while updating the CVS. Open up "the Mana World.ini" in the main folder and replace the current host with animesites.de or themanaworld.homeip.net. If you want to check if the first one is online just check the server status page on the web site http://themanaworld.sourceforge.net/server.html
e

Post by e » Mon Aug 23, 2004 7:42 pm

works :) fine. thx !
Post Reply