Manaclient particle transparency issues

Ask for help regarding any technical issue or report any bug or OS independent issues.
Post Reply
nmaligec
Novice
Novice
Posts: 253
Joined: 08 Apr 2010, 02:55

Manaclient particle transparency issues

Post by nmaligec » 01 May 2011, 08:27

This glitch appears in the nightly build from the 19th onward. It is very specific and not really noticeable but I thought it might be a symptom of a bigger bug. I am using a local tmwAthena server to test some content I have not posted yet. I dont know of any other content that would be able to trigger this glitch, so you will have to take my work for it.

I was testing the new <deatheffect></deatheffect> tag and came across an odd glitch. Basically the particle I created would spawn a flame pillar on the player when it hit them, died, and spawned a deatheffect particle. Since it is not attached to the player, they can move away and leave it behind (I am ok with that).

I used gimp to make a quick demo of the glitch. Trying to get screen shots in game would be to annoying and wouldn't illustrate the main point as 'sharply'.

When the player stands still to let the flame pillar sequence finish playing, the particle will be semi-transparent and show the player under it.
deatheffect1.png
Normal
deatheffect1.png (4.5 KiB) Viewed 908 times
When the player moves away, the semi-transparent pixels become solid/opaque.
deatheffect2.png
Glitch
deatheffect2.png (4.75 KiB) Viewed 908 times
This is what it should look like, if it were to work properly. It is hard to see against the darker floor, but it is semi-transparent.
deatheffect3.png
Expected
deatheffect3.png (5.5 KiB) Viewed 908 times
PS: the flame is part of a demo sequence I made, I know it sucks. I am waiting for a real artist to do a proper version.
Last edited by nmaligec on 01 May 2011, 18:34, edited 1 time in total.
User avatar
Jaxad0127
TMW Adviser
TMW Adviser
Posts: 4209
Joined: 01 Nov 2007, 18:35
Location: Internet

Re: Manaclient deatheffect particle glitch

Post by Jaxad0127 » 01 May 2011, 10:46

This behavior should be expected. The particles are transparent. Some particles are behind the player, some are in front, so you get that transparent effect: solid where there isn't a being, translucent where there is. Everything is normal.
Image
nmaligec
Novice
Novice
Posts: 253
Joined: 08 Apr 2010, 02:55

Re: Manaclient particle transparency issues

Post by nmaligec » 01 May 2011, 18:37

I can live with that. Just wanted to be sure it was doing what it was supposed to. From a content dev side of things it seems odd that if you make something with 50% alpha, that it isn't always going to display that way.
User avatar
Jaxad0127
TMW Adviser
TMW Adviser
Posts: 4209
Joined: 01 Nov 2007, 18:35
Location: Internet

Re: Manaclient particle transparency issues

Post by Jaxad0127 » 01 May 2011, 23:24

Each individual particle will. But when you start layering them, the final effect will be more opaque.
Image
nmaligec
Novice
Novice
Posts: 253
Joined: 08 Apr 2010, 02:55

Re: Manaclient particle transparency issues

Post by nmaligec » 02 May 2011, 02:57

Checking it in gimp, I do get the opaque version if I double layer same frame.

So now the question is: why is the client double(or more?) layering the particle?? The xml file I made for it does not use an emitter, just an animation node/tag. As far as I know, this should only use one layer.

Code: Select all

<effect>
	<!-- The deatheffect particle for the reaper's pillar of flame ranged attack -->
	<particle position-x="0" position-y="0" position-z="0" lifetime="47">
		<animation imageset="graphics/particles/monster-reaper-flame_64x64.png" width="64" height="64">
			<frame index="0" delay="100"/>
			<frame index="1" delay="90"/>
			<frame index="2" delay="120"/>
			<frame index="3" delay="90"/>
			<frame index="4"/>
		</animation>
	</particle>
</effect>
If this does not just use one layer please explain why. I am sure this would be useful for others to know as well.
User avatar
Crush
TMW Adviser
TMW Adviser
Posts: 8046
Joined: 25 Aug 2005, 17:08
Location: Germany

Re: Manaclient particle transparency issues

Post by Crush » 02 May 2011, 07:25

The feature which makes characters appear slightly translucent when covered by buildings also works on particle effects. So you can not cover an object completely with a particle effect.
  • former Manasource Programmer
  • former TMW Pixel artist
  • NOT a game master

Please do not send me any inquiries regarding player accounts on TMW.


You might have heard a certain rumor about me. This rumor is completely false. You might also have heard the other rumor about me. This rumor is 100% accurate.
User avatar
Bertram
Knight
Knight
Posts: 1026
Joined: 07 Sep 2004, 15:55
Location: France

Re: Manaclient particle transparency issues

Post by Bertram » 02 May 2011, 08:25

Hi,
If this does not just use one layer please explain why. I am sure this would be useful for others to know as well.
nmaligec pointed out a valid point here, right?

Best regards.
Post Reply