-nonopenGL?

Ask for help regarding any technical issue or report any bug or OS independent issues.
Post Reply
KillStr34kz
Newly Registered User
Posts: 2
Joined: 25 May 2011, 12:46

-nonopenGL?

Post by KillStr34kz » 25 May 2011, 12:48

Sorry for interupting anything happening. I dont know the mail to the support.
I started The Mana World in OpenGL. This made my graphics freak out.
And im really sorry, but I cant fix it, can I have some help? :)

I heard about this command you popped somewhere, something like -nonopenGL or so.

Thanks alot guys.
User avatar
Crush
TMW Adviser
TMW Adviser
Posts: 8046
Joined: 25 Aug 2005, 17:08
Location: Germany

Re: -nonopenGL?

Post by Crush » 25 May 2011, 17:00

There is a --no-opengl command line parameter. How to start a program with a command line parameter depends on your operating system.

Another way to change the opengl mode without starting the client is changing it in the config.xml but the location of this file depends - again - on your operating system.

But by far the best solution would of course be to fix your video card driver so that OpenGL works properly. But how to do this depends on... well, do you realize why we have different support forums for different operating systems now?
  • former Manasource Programmer
  • former TMW Pixel artist
  • NOT a game master

Please do not send me any inquiries regarding player accounts on TMW.


You might have heard a certain rumor about me. This rumor is completely false. You might also have heard the other rumor about me. This rumor is 100% accurate.
KillStr34kz
Newly Registered User
Posts: 2
Joined: 25 May 2011, 12:46

Re: -nonopenGL?

Post by KillStr34kz » 26 May 2011, 07:03

Want me to give more information here? Or should I make a new post on the Windows forums?

(Running a Windows XP-Service Pack 3)
User avatar
Freeyorp101
Administrator
Administrator
Posts: 708
Joined: 04 Nov 2008, 10:17
Location: New Zealand

Re: -nonopenGL?

Post by Freeyorp101 » 26 May 2011, 08:30

Moved to Windows Support.


---Freeyorp
(09:58:17) < tux9th> Freeyorp: your sig on the forums is kind of outdated
User avatar
Crush
TMW Adviser
TMW Adviser
Posts: 8046
Joined: 25 Aug 2005, 17:08
Location: Germany

Re: -nonopenGL?

Post by Crush » 26 May 2011, 09:01

When you use windows you should have a shortcut to TMW on your desktop. Right-click on it and select "Properties". There is an editable line "target" which has the path to mana.exe in quotes. After the quotes add --no-opengl with a space between the quote and the first dash. I don't know how the branding currently looks, but it is possible that there are already one or more other command line parameters there. You can have as many as you want, separated by spaces.

I am currently at work and don't have a machine with the Mana client installed here, but it would look that way with a different application (sorry, German version of windows):
noopengl.png
noopengl.png (10.28 KiB) Viewed 1837 times
When your OpenGL graphics are messed up on windows, there are two likely reasons:

1. DirectX isn't installed properly
2. Your video card driver isn't installed properly

To update DirectX go to http://www.microsoft.com/downloads/en/d ... laylang=en

To find the correct driver for your video card you first have to find out the vendor and model. You can find out by running the program C:\WINDOWS\system32\dxdiag. The tab "Display" should tell you. The vendor is most likely either Nvidia, ATI, AMD or Intel. The most recent drivers for your video card should be found on their respective websites.
  • former Manasource Programmer
  • former TMW Pixel artist
  • NOT a game master

Please do not send me any inquiries regarding player accounts on TMW.


You might have heard a certain rumor about me. This rumor is completely false. You might also have heard the other rumor about me. This rumor is 100% accurate.
Warlord86
Newly Registered User
Posts: 1
Joined: 27 Dec 2011, 18:59

Re: -nonopenGL?

Post by Warlord86 » 23 Jan 2012, 01:28

KillStr34kz wrote:Sorry for interupting anything happening. I dont know the mail to the support.
I started The Mana World in OpenGL. This made my graphics freak out.
And im really sorry, but I cant fix it, can I have some help? :)

I heard about this command you popped somewhere, something like -nonopenGL or so.

Thanks alot guys.
In Windows 7, 'Config.xml' and other files i find here:
'C:\Users\%username%\AppData\Roaming\mana\tmw'

(In WinXP, or Other versions, search "mana" or "tmw" folders on your disk C: (Maybe in - C:\Documents and Settings\) (to search 'tmw' folder, i use Windows built-in search engine.)

After you find 'tmw'* folder, Open 'config.xml' file with notepad**, press ctrl+f to open search window, and type "opengl".

Find line: <option name="opengl" value="1"/>
And set value to "0".
Save file and run the Game.

*(do not edit files in folder "manasource")
**Click, right mouse button & select "open with..."
Post Reply