Char-server fails to accept connections...

Ask for help regarding any technical issue or report any bug or OS independent issues.
Post Reply
User avatar
Eragon
Peon
Peon
Posts: 47
Joined: 13 Aug 2010, 11:04
Location: Somewhere in a hidden place in Planet Earth

Char-server fails to accept connections...

Post by Eragon » 12 Jun 2011, 10:31

Log in server accepts connections but the char server keeps refusing them. Whats wrong here?
Login-server:
|---Start reading of Login Server configuration file (conf/login_athena.conf)
|---Start reading of Login Server configuration file (conf/login_local.conf)
|---End reading of Login Server configuration file.
|---End reading of Login Server configuration file.
|***WARNING: You are using the default GM password (gm_pass).
| We highly recommend that you change it.
|---Start reading Lan Support configuration file
|LAN IP of char-server: 127.0.0.1.
|Sub-network of the char-server: 127.0.0.1.
|Sub-network mask of the char-server: 255.255.255.0.
|LAN test of LAN IP of the char-server: LAN test (result): LAN source.
|---End reading of Lan Support configuration file
|read_gm_account: file 'conf/gm_account.txt' readed (1 GM accounts found).
|mmo_auth_init: 8 accounts read in save/account.txt,
| of which is 1 GM account, and 5 server accounts ('S').
|The login-server is ready (Server is listening on the port 6901).
|
|used: 3, max FDs: 4096, SOFT: 4046
|Connection of the char-server 'The Mana World' accepted.
|used: 4, max FDs: 4096, SOFT: 4046
|set eof : connection #5
|used: 4, max FDs: 4096, SOFT: 4046
|set eof : connection #5
|used: 4, max FDs: 4096, SOFT: 4046
|set eof : connection #5
|used: 4, max FDs: 4096, SOFT: 4046
|Connection of the GM (level:99) account 'Eragon' accepted.
|LAN test (result): WAN source.
|set eof : connection #5
|used: 4, max FDs: 4096, SOFT: 4046
|set eof : connection #5
|used: 4, max FDs: 4096, SOFT: 4046
|set eof : connection #5
|used: 4, max FDs: 4096, SOFT: 4046
|Connection of the account 'lame' accepted.
|LAN test (result): WAN source.
|set eof : connection #5
----------------------------------------------------------------------------------
Char-server:
The Mana World server has been intialized
Login server IP address : 127.0.0.1 -> 127.0.0.1
Character server IP address : xxx.xxx.xx.xxx -> xxx.xxx.xx.xxx
---start reading of Lan Support configuration...
LAN IP of map-server: 127.0.0.1.
Sub-network of the map-server: 127.0.0.1.
Sub-network mask of the map-server: 255.255.255.0.
LAN test of LAN IP of the map-server: LAN test (result): LAN source.
---End reading of Lan Support configuration...
mmo_char_init: 3 characters read in save/athena.txt.
can't read db/exp_guild.txt
The char-server is ready (Server is listening on the port 6122).

Attempt to connect to login-server...
Connected to login-server (connection #4).
Awaiting maps from map-server.
From login-server: receiving of 1 GM accounts information.
used: 4, max FDs: 4096, SOFT: 4046
Map-Server 0 connected: 75 maps, from IP xxx.xxx.xx.xxx port 5122.
Map-server 0 loading complete.
used: 5, max FDs: 4096, SOFT: 4046
set eof : connection #6
used: 5, max FDs: 4096, SOFT: 4046
set eof : connection #6
used: 5, max FDs: 4096, SOFT: 4046
set eof : connection #6
used: 5, max FDs: 4096, SOFT: 4046
Account Logged On; Account ID: 2000000 (GM level 99).
Character selection 'Eragon' (account: 2000000, slot: 0) [192.168.1.1]
--Send IP of map-server. LAN test (result): WAN source.
set eof : connection #6
used: 5, max FDs: 4096, SOFT: 4046
Account Logged On; Account ID: 2000003.
Character selection 'xxxx' (account: 2000003, slot: 0) [192.168.1.1]
--Send IP of map-server. LAN test (result): WAN source.
set eof : connection #6
auth_fifo search error! account 2000003 not authentified.

------------------------------------------------------------------------------------
map-server:
Character server IP address : 127.0.0.1 -> 127.0.0.1
Map server IP address : xxx.xxx.xx.xxx -> xxx.xxx.xx.xxx
read conf/grf-files.txt done
Loading Maps [0/75]: data\001-1.gat
167 114
...........
Maps Loaded: 75
Maps Removed: 0
data\itemslottable.txt not found
read db/item_db.txt done (count=587)
read db/item_bluebox.txt done (count=0)
read db/item_violetbox.txt done (count=0)
read db/item_cardalbum.txt done (count=0)
read db/item_giftbox.txt done (count=0)
read db/item_scroll.txt done (count=0)
can't read db/item_avail.txt
read db/item_noequip.txt done (count=0)
data\num2cardillustnametable.txt not found
Exp for mob 'Maggot' generated: 6
...........
read db/mob_db.txt done
can't read db/mob_avail.txt
read db/mob_branch.txt done
can't read db/mob_poring.txt
read db/mob_skill_db.txt done
NPCs Loaded: 5832 [Warps:482 Shops:28 Scripts:366 Mobs:4956]
read db/exp.txt done
read db/job_db1.txt done
read db/job_db2.txt done
read db/job_db2-2.txt done
read db/skill_tree.txt done
read db/attr_fix.txt done
can't read db/size_fix.txt
read db/statpoint.txt done (size=1189)
can't read db/castle_db.txt
Incomplete skill db data online (1 entries)
read db/skill_db.txt done
read db/skill_require_db.txt done
can't read db/skill_cast_db.txt
[magic-conf] Magic initialised; obscure at 95%. 140 spells, 9 teleport anchors.
npc: OnInit Event done. (5 npc)
The map-server is ready (Server is listening on the port 5122).
Attempt to connect to char-server...
Connected to char-server (connection #5).
chrif: OnCharIfInit event done. (0 events)
chrif: OnInterIfInit event done. (0 events)
From login-server: receiving of 1 GM accounts information.
used: 4, max FDs: 4096, SOFT: 4046
set eof : connection #6
used: 4, max FDs: 4096, SOFT: 4046
set eof : connection #6
used: 4, max FDs: 4096, SOFT: 4046
set eof : connection #6
used: 4, max FDs: 4096, SOFT: 4046
set eof : connection #6
used: 4, max FDs: 4096, SOFT: 4046
set eof : connection #6
used: 4, max FDs: 4096, SOFT: 4046
set eof : connection #6
used: 4, max FDs: 4096, SOFT: 4046
set eof : connection #6
Player with account [2000003] has logged off your server (not auth account).
User avatar
o11c
Knight
Knight
Posts: 2262
Joined: 20 Feb 2011, 22:09
Location: ^ ^

Re: Char-server fails to accept connections...

Post by o11c » 12 Jun 2011, 17:11

Eragon wrote: Character server IP address : xxx.xxx.xx.xxx -> xxx.xxx.xx.xxx
Map-Server 0 connected: 75 maps, from IP xxx.xxx.xx.xxx port 5122.
--Send IP of map-server. LAN test (result): WAN source.
--Send IP of map-server. LAN test (result): WAN source.
Map server IP address : xxx.xxx.xx.xxx -> xxx.xxx.xx.xxx
These lines are wrong. The simplest setup is to set every IP to 127.0.0.1
The next-simplest setup is to make 127.0.0.1 use for inter-server communications and for lan_support.conf, and use your intranet as "WAN".
Finally, if you need to set your server to be publically accessible, each server should list its public IP, with 127.0.0.1 as internal. Note, however, that is is impossible to setup lan_support to accept connections both from localhost and from the local network, however, you *can* still connect to a "local network" connection by specifying your computer's LAN IP instead of 127.0.0.1/localhost. But if you don't need to connect from other machines on your local network then just use 127.0.0.1 as your "LAN".

TODO: fix the server to always accept connections from localhost.
Former programmer for the TMWA server.
User avatar
meway
Knight
Knight
Posts: 1736
Joined: 04 Jan 2009, 06:02
Location: Detroit MI
Contact:

Re: Char-server fails to accept connections...

Post by meway » 12 Jun 2011, 19:43

Did that account exist before you entered that line?
User avatar
Eragon
Peon
Peon
Posts: 47
Joined: 13 Aug 2010, 11:04
Location: Somewhere in a hidden place in Planet Earth

Re: Char-server fails to accept connections...

Post by Eragon » 14 Jun 2011, 20:21

o11c thanks for the help. OMG all this problem only because I didnt put the correct subnet mask xD . Just fixed it and now it works fine. Thanks for the help.
Meway: What account?
Post Reply