libpng error on startup (v 0.0.19)

Ask for help regarding any technical issue or report any bug or OS independent issues.
Post Reply
User avatar
Akuryou
Peon
Peon
Posts: 3
Joined: Fri Jun 16, 2006 11:43 pm
Contact:

libpng error on startup (v 0.0.19)

Post by Akuryou » Fri Jun 16, 2006 11:55 pm

HI
I finally installed version 0.0.19 without errors.

Im using Suse Linux 10.1 (x86-64)
Kernel 2.6.16.13-4

had no other tmw versions installed bevore.

When I start tmw i get this mesage:

Code: Select all

The Mana World v0.0.19
libpng error: Invalid image width
Fatal signal: Segmentation Fault (SDL Parachute Deployed)
libpng version is:1.2.8
i allready reinstalled it but it had no effect....
my tmw.log is empty so so i can´t post anything out of that...

any ideas??
User avatar
knivey
Novice
Novice
Posts: 187
Joined: Sun Mar 05, 2006 4:01 am
Location: Your Base
Contact:

Post by knivey » Mon Jun 19, 2006 1:06 am

edit your config and disable opengl
All your base are belong to us.
User avatar
Akuryou
Peon
Peon
Posts: 3
Joined: Fri Jun 16, 2006 11:43 pm
Contact:

Post by Akuryou » Tue Jun 20, 2006 9:59 am

thanks 4 the answer

but there is a little problem:

i got a config.xml and a logfile but both of them are empty and got 0 byte

(same for other users + root)

can u just post ur config file here?
User avatar
Akuryou
Peon
Peon
Posts: 3
Joined: Fri Jun 16, 2006 11:43 pm
Contact:

Post by Akuryou » Wed Jun 21, 2006 12:18 pm

well...

i downloaded the win version, installed it with wine and copyd the config file from there.

changed opengl to 0

=> no change same error

when i start it with wine i can register and create a character but when i try to log in it crashes (but this is a wine error i guess....)

any ideas?
User avatar
Bjørn
TMW Adviser
TMW Adviser
Posts: 1430
Joined: Thu Dec 09, 2004 7:50 pm
Location: North Rhine-Westphalia, Germany
Contact:

Post by Bjørn » Sat Jun 24, 2006 9:38 pm

All the information we have so far is this: "libpng error: Invalid image width". We do not know which image it is trying to load (which would be in the log, which apparently is empty), and we do not know where it ends up crashing (which should not happen, even if libpng cannot load an image).

I'm not sure if where the client crashes is relevant, but I'd still like to know. Therefore, please try running tmw inside gdb in order to get a backtrace of the crash, like:

gdb tmw
> run
[crash!]
> bt

And if the backtrace seems useful, paste it here. If it doesn't seem useful (not displaying any function names or line numbers) then you may first have to compile tmw with debugging symbols, I think this can be done by passing CXXFLAGS=-g to ./configure.
Post Reply