Barber script

Content and general development discussion, including maps, quests, and server code from the development team.
Post Reply
User avatar
ElvenProgrammer
TMW Adviser
TMW Adviser
Posts: 2526
Joined: 13 Apr 2004, 20:11
Location: Italy
Contact:

Barber script

Post by ElvenProgrammer » 07 Nov 2004, 18:17

Here is the barber script:

Code: Select all

new_3-1.gat,42,79,0	script	Barber	100,{
	mes "[Barber]";
	mes "I'm the greatest barber in the whole mana world!";
	mes "What color do you prefer?";
	next;
	menu
	"black",black,
	"purple",purple,
	"green",green,
	"blue",blue,
	"red",red,
	"blonde",blonde,
	"light blue",lightblue,
	"gray",gray,
	"brown",brown,
	"white",white,
	"no hair",nohair;

black:
	next;
	setlook 6,1;
	close;
purple:
	next;
	setlook 6,2;
	close;
green:
	next;
	setlook 6,3;
	close;
blue:
	next;
	setlook 6,4;
	close;
red:
	next;
	setlook 6,5;
	close;
blonde:
	next;
	setlook 6,6;
	close;
lightblue:
	next;
	setlook 6,7;
	close;
gray:
	next;
	setlook 6,8;
	close;
brown:
	next;
	setlook 6,9;
	close;
white:
	next;
	setlook 6,10;
	close;
nohair:
	next;
	setlook 6,11;
	close;
}
What's wrong with it? Because in the list the server adds also the last item which is "you prefer?". Please someone help me, or try it with a normal athena server-RO client to test if it works correctly.
Jacjy

Post by Jacjy » 09 Nov 2004, 06:45

I have tested the script and it works as the script wants :) . hope this will help. :) :)

Out topic: why is that when i connect to the server, it seems i'm connecting to the wrong map. I'm using the latest build.

Note sorry for my bad english.
User avatar
ElvenProgrammer
TMW Adviser
TMW Adviser
Posts: 2526
Joined: 13 Apr 2004, 20:11
Location: Italy
Contact:

Post by ElvenProgrammer » 12 Nov 2004, 17:02

Thx for the help, then the problem is with my client anyway I think I found a solution.

About the wrong map problem, try to get the latest snapshot. Maybe you're using an old account? Try to delete your player and create a new one.
Post Reply