Problem in SVN 2935

Content and general development discussion, including maps, quests, and server code from the development team.
Post Reply
User avatar
Pajarico
Warrior
Warrior
Posts: 592
Joined: 28 Feb 2005, 20:29
Contact:

Problem in SVN 2935

Post by Pajarico » 24 Dec 2006, 18:54

Code: Select all

make[2]: Leaving directory `/home/lxuser/compilation/tmw/docs'
Making all in src
make[2]: Entering directory `/home/lxuser/compilation/tmw/src'
if g++ -DHAVE_CONFIG_H -I. -I. -I..  -DTMW_DATADIR=\""/home/lxuser/compilation//share/tmw/"\"   -Wall -Werror -DUSE_OPENGL -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT `pkg-config --cflags libxml-2.0`  -g -O2 -MT tmw-shoplistbox.o -MD -MP -MF ".deps/tmw-shoplistbox.Tpo" -c -o tmw-shoplistbox.o `test -f 'gui/shoplistbox.cpp' || echo './'`gui/shoplistbox.cpp; \
        then mv -f ".deps/tmw-shoplistbox.Tpo" ".deps/tmw-shoplistbox.Po"; else rm -f ".deps/tmw-shoplistbox.Tpo"; exit 1; fi
if g++ -DHAVE_CONFIG_H -I. -I. -I..  -DTMW_DATADIR=\""/home/lxuser/compilation//share/tmw/"\"   -Wall -Werror -DUSE_OPENGL -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT `pkg-config --cflags libxml-2.0`  -g -O2 -MT tmw-viewport.o -MD -MP -MF ".deps/tmw-viewport.Tpo" -c -o tmw-viewport.o `test -f 'gui/viewport.cpp' || echo './'`gui/viewport.cpp; \
        then mv -f ".deps/tmw-viewport.Tpo" ".deps/tmw-viewport.Po"; else rm -f ".deps/tmw-viewport.Tpo"; exit 1; fi
make[2]: *** No rule to make target `action.cpp', needed by `tmw-action.o'.  Stop.
make[2]: Leaving directory `/home/lxuser/compilation/tmw/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/lxuser/compilation/tmw'
make: *** [all] Error 2
lxuser@localhost ~/compilation/tmw $
Lv.: Maggot
Please, read the FAQ before posting.
User avatar
Rotonen
TMW Adviser
TMW Adviser
Posts: 3154
Joined: 08 Sep 2004, 20:48
Location: Espoo, Finland

Post by Rotonen » 24 Dec 2006, 19:19

Tried CMake?
This message used to be meaningful.
User avatar
Bjørn
TMW Adviser
TMW Adviser
Posts: 1430
Joined: 09 Dec 2004, 19:50
Location: North Rhine-Westphalia, Germany
Contact:

Post by Bjørn » 24 Dec 2006, 20:52

configure should work too, but action.cpp was moved from src to src/resources. If you don't know how to solve this issue, try a clean checkout of the src directory.
User avatar
Pajarico
Warrior
Warrior
Posts: 592
Joined: 28 Feb 2005, 20:29
Contact:

Post by Pajarico » 25 Dec 2006, 15:48

Rotonen wrote:Tried CMake?
I tried and works. make compiles everything fineand, I can run the executable from src/tmw. But make install does exit with succex but doesn't install anything.

Bjørn: Where should be src/resources/action.cpp referenciated?

PD: Apparently rm -fr src and rechecking that folder from svn works. But I want to know if there is a shorter solution to this since is not the first time I get to this problem. Sooner or later there is some update that screws svn...
Lv.: Maggot
Please, read the FAQ before posting.
User avatar
Bjørn
TMW Adviser
TMW Adviser
Posts: 1430
Joined: 09 Dec 2004, 19:50
Location: North Rhine-Westphalia, Germany
Contact:

Post by Bjørn » 26 Dec 2006, 18:33

Pajarico wrote:Bjørn: Where should be src/resources/action.cpp referenciated?

PD: Apparently rm -fr src and rechecking that folder from svn works. But I want to know if there is a shorter solution to this since is not the first time I get to this problem. Sooner or later there is some update that screws svn...
src/resources/action.cpp should be referenced from src/Makefile.am. I'm sorry but I do not know enough about how configure works to tell you why these things happen, I fight with it form time to time as well.
Post Reply