beryl + tmw

Ask for help regarding any technical issue or report any bug or OS independent issues.
Post Reply
User avatar
Fill_os_OFF
Peon
Peon
Posts: 9
Joined: 25 Dec 2006, 10:47
Location: Moscow
Contact:

beryl + tmw

Post by Fill_os_OFF » 23 Jan 2007, 14:49

I can see following bug: when beryl is active tmw window has a strange color ( pink :shock: ). Later, in game, only left top corner has the same strange color. It's always blinking. I try another application - there is no such bug. Maybe it's tmw's bug, maybe beryl's bug - do not know for sure, just know about it.

Image

Image
User avatar
Crush
TMW Adviser
TMW Adviser
Posts: 8046
Joined: 25 Aug 2005, 17:08
Location: Germany

Post by Crush » 23 Jan 2007, 15:03

I have never heard of this error before. But i haven't heard of beryl before either.

In the wallpaper on the upper screen the green color channel is obviously missing. But for some reason the gui elements are drawn correctly. Very strange.

It might be because the SDL library detects the color format incorrectly on the (you have to admit rather exotic) window manager you are using. But this is just a guess.
Last edited by Crush on 23 Jan 2007, 15:22, edited 2 times in total.
  • former Manasource Programmer
  • former TMW Pixel artist
  • NOT a game master

Please do not send me any inquiries regarding player accounts on TMW.


You might have heard a certain rumor about me. This rumor is completely false. You might also have heard the other rumor about me. This rumor is 100% accurate.
User avatar
Avaniel
Peon
Peon
Posts: 40
Joined: 20 Aug 2006, 10:55
Location: The Netherlands

Post by Avaniel » 23 Jan 2007, 15:12

I dont really think I can help you, but I would still like to know: Are you using software or opengl rendering for TMW? (If you don't know, look in your configuration file in the tmw folder...)
First they ignore you. Then they laugh at you. Then you swing your +150 axe. Then you win.
User avatar
Fill_os_OFF
Peon
Peon
Posts: 9
Joined: 25 Dec 2006, 10:47
Location: Moscow
Contact:

Post by Fill_os_OFF » 23 Jan 2007, 15:36

Avaniel wrote:I dont really think I can help you, but I would still like to know: Are you using software or opengl rendering for TMW? (If you don't know, look in your configuration file in the tmw folder...)
Yes, I used opengl rendering. I try software rendering - bug disappeared.
So? Is it tmw bug?
User avatar
Crush
TMW Adviser
TMW Adviser
Posts: 8046
Joined: 25 Aug 2005, 17:08
Location: Germany

Post by Crush » 23 Jan 2007, 15:39

Considering that the error appears on no other window manager and Beryl is still in a quite early beta stadium I would blame Beryl.
Last edited by Crush on 23 Jan 2007, 15:41, edited 1 time in total.
  • former Manasource Programmer
  • former TMW Pixel artist
  • NOT a game master

Please do not send me any inquiries regarding player accounts on TMW.


You might have heard a certain rumor about me. This rumor is completely false. You might also have heard the other rumor about me. This rumor is 100% accurate.
User avatar
Avaniel
Peon
Peon
Posts: 40
Joined: 20 Aug 2006, 10:55
Location: The Netherlands

Post by Avaniel » 23 Jan 2007, 15:41

TMW OpenGL mode relies on certain settings, these seem to be overridden by Beryl. I don't know if there is a workaround, but it might be worth a try to check out any Beryl forums...
First they ignore you. Then they laugh at you. Then you swing your +150 axe. Then you win.
User avatar
Avaniel
Peon
Peon
Posts: 40
Joined: 20 Aug 2006, 10:55
Location: The Netherlands

Post by Avaniel » 23 Jan 2007, 15:47

Please try the method described here: http://ubuntuforums.org/showpost.php?p= ... tcount=683
Q: Anytime I play Frozen Bubble at all, it isn't opaque, and it seems to be a little desaturated. It's also got some funky brightness levels.

A: Nothing to do with the ghost problem, nor with the last package, this problem with every SDL applications occurs since the very first xgl/compiz.
To avoid this, you can launch it with :
Code:
export XLIB_SKIP_ARGB_VISUALS=1 tmw
Last edited by Avaniel on 23 Jan 2007, 15:56, edited 1 time in total.
First they ignore you. Then they laugh at you. Then you swing your +150 axe. Then you win.
User avatar
Fill_os_OFF
Peon
Peon
Posts: 9
Joined: 25 Dec 2006, 10:47
Location: Moscow
Contact:

Post by Fill_os_OFF » 23 Jan 2007, 15:53

Crush wrote:Considering that the error appears on no other window manager and Beryl is still in a quite early beta stadium I would blame Beryl.
But also considering that the error appears on no other application :)
It might be because the SDL library detects the color format incorrectly on the (you have to admit rather exotic) window manager you are using. But this is just a guess.
I try another apllication based on SDL - there is no such bug.
Please try the method described here: http://ubuntuforums.org/showpost.php?p= ... tcount=683
it isn't solve the problem. And I can say that frozen-bubble works correctly with beryl
User avatar
Platyna
Former Dictator
Former Dictator
Posts: 2213
Joined: 19 Nov 2005, 14:19
Location: Poland
Contact:

Post by Platyna » 23 Jan 2007, 18:02

Upgrade to current release and then check for errors. And beryl is buggy, I see no point of using it.

Regards.
Zuzanna K. Filutowska
[The rest of this signature was censored by TMWC's "Freedom" and "Free speech".]
User avatar
Modanung
Knight
Knight
Posts: 1719
Joined: 20 May 2005, 16:51
Location: Groningen, The Netherlands
Contact:

Post by Modanung » 23 Jan 2007, 18:36

I can't remember having this problem in TMW while running Beryl. I'll check again some other time, but last time I tried it ran fine.
If you're looking for 3D FOSS games be sure to check out LucKey Productions on itch.io
User avatar
Fill_os_OFF
Peon
Peon
Posts: 9
Joined: 25 Dec 2006, 10:47
Location: Moscow
Contact:

Post by Fill_os_OFF » 23 Jan 2007, 19:16

Platyna wrote:Upgrade to current release and then check for errors. And beryl is buggy, I see no point of using it.

Regards.
I tried it on friend's computer. He has Gentoo with newest version of tmw. The same problem. But we have different versions of beryl( 0.1.4 and 0.1.99).

PS with newest nvidia drivers beryl works quite good. I use beryl and I don't see any annoing or critical bugs in it.

To Modanung: Are sure that you have opengl rendering on?
User avatar
Bjørn
TMW Adviser
TMW Adviser
Posts: 1430
Joined: 09 Dec 2004, 19:50
Location: North Rhine-Westphalia, Germany
Contact:

Post by Bjørn » 24 Jan 2007, 00:44

When I try TMW in OpenGL with Beryl, the screen is usually flickering every time I click the window for example. But at least there I'm sure it's buggy ATI drivers and Beryl. TMW displays in the right colors though.

There may be something specific about our wallpaper that makes it turn up pink, but I really think it's a problem with Beryl or your video drivers.
Post Reply