Using make command, Error at middle or end... ?

Ask for help regarding any technical issue or report any bug or OS independent issues.
Post Reply
Craig.Engbrecht
Peon
Peon
Posts: 8
Joined: 02 Oct 2007, 08:39
Location: California, USA

Using make command, Error at middle or end... ?

Post by Craig.Engbrecht » 05 Oct 2007, 05:26

Ok, so this is start to end of the command, Basically what happens after I put in Make and press enter... I am going to remove duplicate lines.

[root@localhost tmw-0.0.23]# make
make all-recursive
make[1]: Entering directory `/home/craig/Desktop/tmw-0.0.23'
Making all in data
make[2]: Entering directory `/home/craig/Desktop/tmw-0.0.23/data'
Making all in graphics

~~~ These are basically all the same ~~~

make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/craig/Desktop/tmw-0.0.23/docs'
Making all in src
make[2]: Entering directory `/home/craig/Desktop/tmw-0.0.23/src'
g++ -DHAVE_CONFIG_H -I. -I.. -DTMW_DATADIR=\""/usr/local/share/tmw/"\" -Wall -DUSE_OPENGL -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT `pkg-config --cflags libxml-2.0` -g -O2 -MT tmw-resizegrip.o -MD -MP -MF .deps/tmw-resizegrip.Tpo -c -o tmw-resizegrip.o `test -f 'gui/widgets/resizegrip.cpp' || echo './'`gui/widgets/resizegrip.cpp
In file included from gui/widgets/../../resources/image.h:36,
from gui/widgets/resizegrip.cpp:30:
/usr/include/SDL/SDL_opengl.h:44:60: error: GL/gl.h: No such file or directory
/usr/include/SDL/SDL_opengl.h:45:58: error: GL/glu.h: No such file or directory
gui/widgets/../../resources/image.h:124: error: ‘GLuint’ has not been declared
gui/widgets/../../resources/image.h:139: error: ‘GLuint’ does not name a type
gui/widgets/../../resources/image.h:160: error: ‘GLuint’ has not been declared
make[2]: *** [tmw-resizegrip.o] Error 1
make[2]: Leaving directory `/home/craig/Desktop/tmw-0.0.23/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/craig/Desktop/tmw-0.0.23'
make: *** [all] Error 2


Looks to me Like I am missing a Library, but I cant pin it down, Or I dont have the files or I dont have access, but this looks like mumbo jumbo too...
The important stuff to me is that its talking about GL/glu (Undeclared and or no such file with the GL/gl.h)
If someone can help that would be great, if I get an answer I will post all my trouble solutions here cause I think that i have covered half the globe on The ./Configure command... And soon the make... and then mostlikely the Make install...

But anyway any help would be appreciated. I checked the boards earlier on but non had any solutions that I could find...?
Image
Craig.Engbrecht
Peon
Peon
Posts: 8
Joined: 02 Oct 2007, 08:39
Location: California, USA

Post by Craig.Engbrecht » 05 Oct 2007, 21:28

ok, Got the GL librarys and that was great, now when I run Make install, it finished, but I cant seem to run version 0.0.23, I am stuck at 0.0.22.2
Image
Craig.Engbrecht
Peon
Peon
Posts: 8
Joined: 02 Oct 2007, 08:39
Location: California, USA

Post by Craig.Engbrecht » 06 Oct 2007, 06:33

So, stupid me forgot to uninstall 0.0.22.2 so that is why... as for the game, it is compiled, and runs great, though I need to know where to put the music, it is not playing, and didn't seem to be in the source..... Oh and is it possible to move the Compiled folder after compiling?

Thanks all.

Have a great day
Image
User avatar
ElvenProgrammer
TMW Adviser
TMW Adviser
Posts: 2526
Joined: 13 Apr 2004, 20:11
Location: Italy
Contact:

Post by ElvenProgrammer » 06 Oct 2007, 08:48

You need to download an additional package to have music:

http://sourceforge.net/project/showfile ... _id=199743

Moving the folder should be possible.
Post Reply