Some pngs are not shown correctly on thumbnails

Web discussions, including project website, forums, wiki, and others.
Post Reply
User avatar
Pajarico
Warrior
Warrior
Posts: 592
Joined: Mon Feb 28, 2005 8:29 pm
Contact:

Some pngs are not shown correctly on thumbnails

Post by Pajarico » Tue Dec 25, 2007 6:01 pm

Hi,
Some of my last uploads are not rendering quite well. Check Nomad_hut02.png for example:
http://wiki.themanaworld.org/index.php/ ... co#Gallery
Others like hut01 or hut05 are displayed correctly and all of them were uploaded around the same time.

Regards.
Lv.: Maggot
Please, read the FAQ before posting.
User avatar
Platyna
Knight
Knight
Posts: 2213
Joined: Sat Nov 19, 2005 2:19 pm
Location: Poland
Contact:

Post by Platyna » Tue Dec 25, 2007 8:53 pm

What is incorrect in it?

Regards.
Zuzanna K. Filutowska
[The rest of this signature was censored by TMWC's "Freedom" and "Free speech".]
Quiche_on_a_leash
Novice
Novice
Posts: 221
Joined: Fri Oct 20, 2006 5:44 pm

Post by Quiche_on_a_leash » Tue Dec 25, 2007 9:20 pm

It's missing it's red channel from what I can see.
User avatar
Pajarico
Warrior
Warrior
Posts: 592
Joined: Mon Feb 28, 2005 8:29 pm
Contact:

Post by Pajarico » Tue Dec 25, 2007 10:29 pm

Quiche_on_a_leash wrote:It's missing it's red channel from what I can see.
Probably. The strange part is that the white parts are still white, whereas suppressing the red channel should make white parts cyan (green+blue)
Lv.: Maggot
Please, read the FAQ before posting.
User avatar
Platyna
Knight
Knight
Posts: 2213
Joined: Sat Nov 19, 2005 2:19 pm
Location: Poland
Contact:

Post by Platyna » Tue Dec 25, 2007 11:03 pm

IMHO, whatever, a thumbnail is something that is supposed to give a hint what is "under" it, not small state of the art pic.

Regards.
Zuzanna K. Filutowska
[The rest of this signature was censored by TMWC's "Freedom" and "Free speech".]
User avatar
Pajarico
Warrior
Warrior
Posts: 592
Joined: Mon Feb 28, 2005 8:29 pm
Contact:

Post by Pajarico » Wed Dec 26, 2007 1:11 pm

And I'm not discussing that. The point is that the thumbnails are broken. If you don't consider that the work invested in fixing is not equaled by the usefulness of having it fixed, then fine.
Lv.: Maggot
Please, read the FAQ before posting.
User avatar
Jaxad0127
TMW Adviser
TMW Adviser
Posts: 4209
Joined: Thu Nov 01, 2007 6:35 pm
Location: Internet

Post by Jaxad0127 » Wed Dec 26, 2007 5:43 pm

It looks like a bad compression algorithm. The red channel wasn't dropped, if it were the tent would be black, not cyan. The red in the tent was replaced by the cyan in the sky.
User avatar
Pajarico
Warrior
Warrior
Posts: 592
Joined: Mon Feb 28, 2005 8:29 pm
Contact:

Post by Pajarico » Thu Dec 27, 2007 11:55 am

I'm not sure, some were compressed by xsane and some by krita, but not every image compressed in krita is faulty, and not every image compressed with xsane is ok, so it's a mixed bag.
Lv.: Maggot
Please, read the FAQ before posting.
Post Reply