Game Pitch Black and Crashes

Ask for help regarding any technical issue or report any bug or OS independent issues.
Post Reply
staticboy44
Peon
Peon
Posts: 3
Joined: 27 Dec 2007, 03:26
Location: Look behind you.

Game Pitch Black and Crashes

Post by staticboy44 » 27 Dec 2007, 03:30

Like the topic title said, the game crashes and when it starts up it freezes and has a pitch black screen. I cannot close the program when this happens, so i have to kill its process.
Can someone tell me whats wrong? I've played the game for several days now and everything was fine until i changed my computer theme to a dark grayish one.

Im using Kubuntu Gusty Gibbon (7.10). Does KDM Theme Manager have anything to do with this problem?
Tarro
Peon
Peon
Posts: 5
Joined: 25 Dec 2007, 23:09

Post by Tarro » 27 Dec 2007, 03:42

Have u upgraded the client?
I got some problems and this worked fine to me.
staticboy44
Peon
Peon
Posts: 3
Joined: 27 Dec 2007, 03:26
Location: Look behind you.

Post by staticboy44 » 27 Dec 2007, 07:32

its the .23 version. I cant compile the .24 version.
User avatar
Falcata
Novice
Novice
Posts: 137
Joined: 10 Nov 2006, 02:55
Location: Michiana
Contact:

Post by Falcata » 27 Dec 2007, 15:06

You need Guichan 0.7 to compile version 0.0.24.
I'm a proud member of the Online Campaign for Real English, a movement for those who believe in capital letters, correct spelling, and good sentence structure.
User avatar
MerlinX420
Warrior
Warrior
Posts: 575
Joined: 23 Dec 2007, 05:42

same problem...

Post by MerlinX420 » 28 Dec 2007, 00:24

I have the same problem with .23 after a bad .24 ./configure attempt.

An attempt at removing and reinstalling of .23 causes the above mention crash.

I'm on Mint Daryna (Ubuntu7.10 Gutsy) I was have been using KDE so I don't believe thats it.
Vidar
Peon
Peon
Posts: 2
Joined: 25 Dec 2007, 05:42

Post by Vidar » 28 Dec 2007, 06:39

I'm having crashes as well. It's pretty random when it happens. Usually when I'm walking. It started after I got a new hair style, which was pretty stupid of me since I can't see them anyway.
I'm using Ubuntu 7.10 Gutsy Gibbon and version 0.0.23 of TMW.
User avatar
blueberry
Novice
Novice
Posts: 107
Joined: 27 Feb 2007, 00:26
Location: Graz, Austria

Post by blueberry » 28 Dec 2007, 23:33

First try to delete .tmw in your home directory and start the game, let the updates pass and it should work.
Is your graphics card proper configured? - drivers ...
Are all dependancies installed only once, or did you forget to uninstall an existing version of a program listed in INSTALL - textfile?

what about compiling 0.0.24, the new release which is more stable? On debian its quite easy todo...dont forget to replace your guichan with version 0.7.0...

...btw, a better error statement would be nice...like posting your tmw.log for example ...search the forums for other suggestions...
I have the same problem with .23 after a bad .24 ./configure attempt.
From 0.0.24 INSTALL - text file:

Requirements:
* SDL http://www.libsdl.org/
* SDL_mixer http://www.libsdl.org/projects/SDL_mixer/
* SDL_image http://www.libsdl.org/projects/SDL_image/
* SDL_net http://www.libsdl.org/projects/SDL_net/
* Guichan 0.7.x http://guichan.sourceforge.net/
* libxml2 http://www.xmlsoft.org/
* physfs 1.0.x http://icculus.org/physfs/
* zlib 1.2.x http://www.gzip.org/zlib/
* libcurl http://curl.haxx.se/libcurl/

With your synaptic replace all Files except guichan with your current -dev version packs,
uninstall guichan < 0.7.x , get the source of 0.7.0 , compile and install and voila 0.0.24 works :)
User avatar
Tors
Peon
Peon
Posts: 8
Joined: 26 Dec 2007, 19:39

Post by Tors » 28 Dec 2007, 23:58

get the source of 0.7.0 , compile and install and voila 0.0.24 works
Another possibility is to download the guichan-deb-packages from the Hardy repositories
Vidar
Peon
Peon
Posts: 2
Joined: 25 Dec 2007, 05:42

Post by Vidar » 03 Jan 2008, 05:11

Well, my 0.0.23 does not work anymore at all. I've even completely got rid of it and reinstalled it and it still doesn't work.
Here's my log file after reinstalling and starting:
[04:15:29.12] Initializing SDL...
[04:15:29.16] Initializing resource manager...
[04:15:29.16] Adding to PhysicsFS: /home/woody//.tmw
[04:15:29.16] Adding to PhysicsFS: data
[04:15:29.16] Adding to PhysicsFS: /usr/share/games/tmw/data
[04:15:29.20] Initializing configuration...
[04:15:29.22] Setting video mode 800x600 windowed
[04:15:29.55] Using video driver: x11
[04:15:29.55] Possible to create hardware surfaces: no
[04:15:29.55] Window manager available: yes
[04:15:29.55] Accelerated hardware to hardware blits: no
[04:15:29.55] Accelerated hardware to hardware colorkey blits: no
[04:15:29.55] Accelerated hardware to hardware alpha blits: no
[04:15:29.55] Accelerated software to hardware blits: no
[04:15:29.55] Accelerated software to hardware colorkey blits: no
[04:15:29.55] Accelerated software to hardware alpha blits: no
[04:15:29.55] Accelerated color fills: no
[04:15:29.55] Available video memory: 0
[04:15:29.56] Initializing GUI...
User avatar
ElvenProgrammer
TMW Adviser
TMW Adviser
Posts: 2526
Joined: 13 Apr 2004, 20:11
Location: Italy
Contact:

Post by ElvenProgrammer » 03 Jan 2008, 09:27

Can you try using 0.0.24?
Post Reply