scource code compiling under ubuntu

Ask for help regarding any technical issue or report any bug or OS independent issues.
Post Reply
impcnrd
Peon
Peon
Posts: 1
Joined: 04 Jan 2008, 00:34
Contact:

scource code compiling under ubuntu

Post by impcnrd » 04 Jan 2008, 00:46

hi i need help.
i'm new to source code compiling and my copy of tmw would crash while playing in version 0.0.23 and i can't update so i got the source code for .24 and i'm trying to compile it and i get this message
"make[1]: *** No rule to make target `.deps/tmw-xml.Po'. Stop.
make[1]: Leaving directory `/tmw'
make: *** [build-stamp] Error 2"
what do i have to do to fix this and finish compiling the code???
:x :x :x :( :( :( :( :( :( :( :(
User avatar
Crush
TMW Adviser
TMW Adviser
Posts: 8046
Joined: 25 Aug 2005, 17:08
Location: Germany

Post by Crush » 04 Jan 2008, 00:54

Moved to UNIX support
  • former Manasource Programmer
  • former TMW Pixel artist
  • NOT a game master

Please do not send me any inquiries regarding player accounts on TMW.


You might have heard a certain rumor about me. This rumor is completely false. You might also have heard the other rumor about me. This rumor is 100% accurate.
User avatar
ElvenProgrammer
TMW Adviser
TMW Adviser
Posts: 2526
Joined: 13 Apr 2004, 20:11
Location: Italy
Contact:

Post by ElvenProgrammer » 04 Jan 2008, 10:12

Try posting the whole compiler log
User avatar
blueberry
Novice
Novice
Posts: 107
Joined: 27 Feb 2007, 00:26
Location: Graz, Austria

Installing 0.0.24 on Ubuntu Gutsy 7.10

Post by blueberry » 04 Jan 2008, 19:55

1.) Uninstall previous installed versions of tmw and guichan with Synaptic
2.) Get Guichan 0.7.1-1 from the hardy-repositories:

http://packages.ubuntu.com/hardy/libs/libguichan2
http://packages.ubuntu.com/hardy/libdev ... ichan2-dev

and download the .deb packages for your architecture, then install with sudo dpkg -i *.deb or with Gdebi-Package-Manager in X.

3.) Now install the other dependencies:

sudo apt-get install libsdl-net1.2-dev && sudo apt-get install libsdl-mixer1.2-dev && sudo apt-get install libphysfs-dev && sudo apt-get install libcurl4-gnutls-dev && sudo apt-get install libxml2-dev

4.) Get the source of tmw-0.0.24 from

http://prdownloads.sourceforge.net/them ... z?download

unpack and compile:

sudo ./configure
sudo make
sudo make install

5.) That's it - start with tmw in console, or have a look at applications/games in X
User avatar
Bjørn
TMW Adviser
TMW Adviser
Posts: 1430
Joined: 09 Dec 2004, 19:50
Location: North Rhine-Westphalia, Germany
Contact:

Re: Installing 0.0.24 on Ubuntu Gutsy 7.10

Post by Bjørn » 07 Jan 2008, 15:30

blueberry wrote:3.) Now install the other dependencies:

sudo apt-get install libsdl-net1.2-dev && sudo apt-get install libsdl-mixer1.2-dev && sudo apt-get install libphysfs-dev && sudo apt-get install libcurl4-gnutls-dev && sudo apt-get install libxml2-dev

4.) Get the source of tmw-0.0.24 from

http://prdownloads.sourceforge.net/them ... z?download

unpack and compile:

sudo ./configure
sudo make
sudo make install
Nice instructions, however, consider:

3. Running one command to install those dependencies:

sudo apt-get install libsdl-net1.2-dev libsdl-mixer1.2-dev libphysfs-dev libcurl4-gnutls-dev libxml2-dev

4. Don't run configure and make as root!

./configure
make
sudo make install
Drmgiver
Peon
Peon
Posts: 33
Joined: 16 Mar 2008, 19:50

Re: scource code compiling under ubuntu

Post by Drmgiver » 16 Mar 2008, 19:52

Ooooor sudo checkinstall -D

Though would you need the data or music files from the repository?
User avatar
Bjørn
TMW Adviser
TMW Adviser
Posts: 1430
Joined: 09 Dec 2004, 19:50
Location: North Rhine-Westphalia, Germany
Contact:

Re: scource code compiling under ubuntu

Post by Bjørn » 01 Apr 2008, 08:11

Drmgiver wrote:Ooooor sudo checkinstall -D

Though would you need the data or music files from the repository?
The necessary data files are included in the release, and the rest is downloaded automatically by the client. The music is optional, it just won't play if you don't install it.
Post Reply