EDIT:Guichan not detected, compile 0.0.24 under Gutsy Gibbon

Ask for help regarding any technical issue or report any bug or OS independent issues.
Post Reply
Coleccionista
Peon
Peon
Posts: 25
Joined: 02 Feb 2008, 21:11

EDIT:Guichan not detected, compile 0.0.24 under Gutsy Gibbon

Post by Coleccionista » 04 Feb 2008, 04:29

Hello. I have Ubuntu 7.10 Gutsy Gibbon.

However I installed the tmw 0.0.24 with the Hardy packages found in the download page. With all the dependencies. Obviously.
I installed the latest version because the 0.0.23 had a bug and the game just crashed randomly.

Everything works grate.

-1/
But now I want to compile it from the source. So I installed build-essential from synaptic (I had to add the Hardy repositories for this, because build-essential for Gutsy Gibbon couldn't handle the latest version of libc6, needed for 0.0.24, etc..)

So, obviously all the dependencies are installed (as I can play very well with the package version)

I have guichan 0.7.1-1

So, when I do ./configure --without-opengl I get an error telling me guichan was not found.

Here is the output:
laptop:~/Desktop/tmw-0.0.24$ ./configure --without-opengl
checking for g++... g++
checking for C++ compiler default output file name... a.out
checking whether the C++ compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for a BSD-compatible install... /usr/bin/install -c
checking whether make sets $(MAKE)... yes
checking how to run the C++ preprocessor... g++ -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for stdbool.h that conforms to C99... yes
checking for _Bool... no
checking for an ANSI C-conforming const... yes
checking whether time.h and sys/time.h may both be included... yes
checking for working volatile... yes
checking for error_at_line... yes
checking for stdlib.h... (cached) yes
checking for GNU libc compatible malloc... yes
checking for stdlib.h... (cached) yes
checking for GNU libc compatible realloc... yes
checking sys/select.h usability... yes
checking sys/select.h presence... yes
checking for sys/select.h... yes
checking sys/socket.h usability... yes
checking sys/socket.h presence... yes
checking for sys/socket.h... yes
checking types of arguments for select... int,fd_set *,struct timeval *
checking for vprintf... yes
checking for _doprnt... no
checking for atexit... yes
checking for floor... yes
checking for getcwd... yes
checking for gethostbyname... yes
checking for memset... yes
checking for mkdir... yes
checking for select... yes
checking for socket... yes
checking for pthread_create in -lpthread... yes
checking for gcnGuichanVersion in -lguichan... no
configure: error: *** Unable to find Guichan library (guichan.sf.net)
What can I do about this?

-2/
I dont want to actually install it again. The current installation works fine. I just want to compile it from the source and be able to use it when I want. But I don't want to replace the actual installation. how can I do this?

Thank you for your time :)

PS: are this lines important?
checking for _Bool... no
checking for _doprnt... no
User avatar
blueberry
Novice
Novice
Posts: 107
Joined: 27 Feb 2007, 00:26
Location: Graz, Austria

Post by blueberry » 04 Feb 2008, 13:30

http://forums.themanaworld.org/viewtopic.php?t=3394

Guess you havent installed the -dev packages of all dependencies...
Coleccionista
Peon
Peon
Posts: 25
Joined: 02 Feb 2008, 21:11

Post by Coleccionista » 04 Feb 2008, 13:44

Exactly, I just figured it out. Thank you.

So, now, I installed everything I needed. I did ./configure and make. Everything went fine.

I'm trying it before typing "sudo make install"
So I went to the src directory and executed tmw: ./tmw

This is the output I get:
laptop:~/Desktop/tmw-0.0.24/src$ ./tmw
tmw: resources/imageloader.cpp:70: virtual gcn::Color ProxyImage::getPixel(int, int): Assertion `mSDLImage' failed.
Aborted (core dumped)
So there is an error on the file resources/imageloader.cpp on line 70. But how am I supposed to fix this?

Again, thank you.
User avatar
ElvenProgrammer
TMW Adviser
TMW Adviser
Posts: 2526
Joined: 13 Apr 2004, 20:11
Location: Italy
Contact:

Post by ElvenProgrammer » 04 Feb 2008, 13:56

What if you run it like src/tmw?
Coleccionista
Peon
Peon
Posts: 25
Joined: 02 Feb 2008, 21:11

Post by Coleccionista » 04 Feb 2008, 14:06

ElvenProgrammer wrote:What if you run it like src/tmw?
Wow, that worked. thanks!

how is this working? what's the difference?
Last edited by Coleccionista on 04 Feb 2008, 16:51, edited 1 time in total.
Coleccionista
Peon
Peon
Posts: 25
Joined: 02 Feb 2008, 21:11

Post by Coleccionista » 04 Feb 2008, 14:25

Is there another way of doing this?

What if I want to create a Desktop shortcut?

I can't use the command home/tmw-0.0.24/src/tmw
It wont work.

So is there any universal option (that can be used for everything, not only tmw) like:

home/tmw-0.0.24/src/tmw --from-path "home/tmw-0.0.24"

I'm asking this because I already had this problem with different applications. :)
User avatar
blueberry
Novice
Novice
Posts: 107
Joined: 27 Feb 2007, 00:26
Location: Graz, Austria

Post by blueberry » 04 Feb 2008, 15:11

What if I want to create a Desktop shortcut?
right click on Desktop, build starter:

Name: tmw
Command: /home/tmw-0.0.24/src/tmw

and voila :)
Coleccionista
Peon
Peon
Posts: 25
Joined: 02 Feb 2008, 21:11

Post by Coleccionista » 04 Feb 2008, 16:53

blueberry wrote:
What if I want to create a Desktop shortcut?
right click on Desktop, build starter:

Name: tmw
Command: /home/tmw-0.0.24/src/tmw

and voila :)
Read the three posts above yours please. :)
That shortcut doesn't work.
User avatar
blueberry
Novice
Novice
Posts: 107
Joined: 27 Feb 2007, 00:26
Location: Graz, Austria

Post by blueberry » 04 Feb 2008, 22:15

in your posts the leading slash "/" was missing in the path statement.
Coleccionista
Peon
Peon
Posts: 25
Joined: 02 Feb 2008, 21:11

Post by Coleccionista » 04 Feb 2008, 22:22

blueberry wrote:in your posts the leading slash "/" was missing in the path statement.
You are right. But that isn't the problem.

The problem is:

I have to be in the /home/tmw-0.0.24/ directory and type "src/tmw" for it to run properly.

If I am in any other directory and type "/home/tmw-0.0.24/src/tmw" it will just crash.
Last edited by Coleccionista on 05 Feb 2008, 04:32, edited 1 time in total.
User avatar
Jaxad0127
TMW Adviser
TMW Adviser
Posts: 4209
Joined: 01 Nov 2007, 18:35
Location: Internet

Post by Jaxad0127 » 04 Feb 2008, 23:51

Put this in a text file in a directory:
cd /home/tmw-0.0.24/
src/tmw
Make the file executable (file properties) and change the desktop link to point to that file.
Coleccionista
Peon
Peon
Posts: 25
Joined: 02 Feb 2008, 21:11

Post by Coleccionista » 05 Feb 2008, 04:51

That works perfectly, makes me feel dumb.

Thank you! :)
flipe
Peon
Peon
Posts: 32
Joined: 18 Oct 2005, 06:16

Re:

Post by flipe » 19 Mar 2008, 21:55

ElvenProgrammer wrote:What if you run it like src/tmw?
I have the same problem, I try run from bash, using command tmw and from the complete PATH, /usr/bin/tmw

but return this error.

I try first with guichan-0.7.1 and 0.7.0, but I get the same problem.

I using now guichan-0.7.0, physfs-1.1.0 and tmw-0.0.24
flipe
Peon
Peon
Posts: 32
Joined: 18 Oct 2005, 06:16

Re: Re:

Post by flipe » 19 Mar 2008, 22:35

flipe wrote:
ElvenProgrammer wrote:What if you run it like src/tmw?
I have the same problem, I try run from bash, using command tmw and from the complete PATH, /usr/bin/tmw

but return this error.

I try first with guichan-0.7.1 and 0.7.0, but I get the same problem.

I using now guichan-0.7.0, physfs-1.1.0 and tmw-0.0.24
the problem is the version of physfs... I back to 1.0.1 and work.

thanks.
Post Reply