The New Snake Cave in Eastern desert

Ask for help regarding any technical issue or report any bug or OS independent issues.
Post Reply
User avatar
Landon
Novice
Novice
Posts: 136
Joined: 16 Jan 2008, 22:09

The New Snake Cave in Eastern desert

Post by Landon » 14 Mar 2008, 13:41

I don't know if it is me but it seems like the snakes have projectile fangs loaded with extra poison that can hit over 20 tiles away. A snake normally does 1-5 damage on me, when I go in there I can not even be near a snake and 15, 20, 30 hit points come off rapidly until I die.
Landon
"Life is like one big screwed up Merry-Go-Round, I get thrown off but I get right back on"
User avatar
Black Don
Warrior
Warrior
Posts: 660
Joined: 06 Feb 2008, 22:30

Re: The New Snake Cave in Eastern desert

Post by Black Don » 14 Mar 2008, 15:01

I found that not to be a bug but lag between client and server. :)
"Too much of a good thing is an awesome thing, but too much of an awesome thing is, um, really really dumb. And bad." Strong Bad
User avatar
originaljustin
Peon
Peon
Posts: 69
Joined: 30 Jan 2007, 00:39
Location: California

Re: The New Snake Cave in Eastern desert

Post by originaljustin » 15 Mar 2008, 00:48

This happens a lot to me. If there is one snake it only does 1 damage to me but if there are about 4 or more snakes they start doing 10 damage or more to me each hit and sometimes 30.
Ami
Peon
Peon
Posts: 2
Joined: 29 Mar 2008, 06:36

Re: The New Snake Cave in Eastern desert

Post by Ami » 29 Mar 2008, 06:57

I've seen half of this bug -- the snakes attacking at a distance.

I think I know (part) of the cause too. If you provoke enough monsters, you can be 'out of range' of them, and they'll keep attacking. And hitting too. (As I showed with the bats and pinkies.)

I think it has something to do with the number targeting you, its not entirely 'lag'.
Attachments
TMW_Screenshot_33.png
TMW_Screenshot_33.png (139.2 KiB) Viewed 899 times
TMW_Screenshot_32.png
TMW_Screenshot_32.png (116.44 KiB) Viewed 899 times
TMW_Screenshot_1.png
This time from Jinna's perspective.
TMW_Screenshot_1.png (122.94 KiB) Viewed 895 times
Wendel
Peon
Peon
Posts: 7
Joined: 20 Mar 2008, 01:15

Re: The New Snake Cave in Eastern desert

Post by Wendel » 12 Apr 2008, 05:17

Ami wrote:I've seen half of this bug -- the snakes attacking at a distance.

I think I know (part) of the cause too. If you provoke enough monsters, you can be 'out of range' of them, and they'll keep attacking. And hitting too. (As I showed with the bats and pinkies.)

I think it has something to do with the number targeting you, its not entirely 'lag'.
I've noticed this same effect in the mine with the red slimes. If enough of them target you you can run around a corner and they still cause massive damage. Now that the fast attack bug has been fixed, this should be too. otherwise the balance of power is slanted too much to the monsters.
User avatar
Sanga
Peon
Peon
Posts: 70
Joined: 16 Mar 2008, 22:57

Re: The New Snake Cave in Eastern desert

Post by Sanga » 12 Apr 2008, 06:39

originaljustin wrote:This happens a lot to me. If there is one snake it only does 1 damage to me but if there are about 4 or more snakes they start doing 10 damage or more to me each hit and sometimes 30.
This is intentional. In the server configuration, there's an option that applies a penalty to your vitality (which is a critical part of your defense stat) when you are fighting more than 3 monsters at a time. It basically applies a -5 penalty to your vitality (and hence your defense) for each monster after the 3rd. So for the 4th monster, your vitality is reduced by 5, for the 5th it's reduced by 10, etc.
User avatar
Sanga
Peon
Peon
Posts: 70
Joined: 16 Mar 2008, 22:57

Re: The New Snake Cave in Eastern desert

Post by Sanga » 12 Apr 2008, 07:57

Black Don wrote:I found that not to be a bug but lag between client and server. :)
"lag" generally means a network issue - the information from client to server (or server to client) is being delayed. This is a *small* component of this issue, but not the primary problem.

There *is* a bug. What's happening is that the client is moving the character, but the server is not accepting the move request. Instead, as far as the server is concerned, you are still standing there being pounded on by the monsters.

Here's an experiment for you - get into this situation, move to a distant part of the map, and then log off. When you log back on, you'll find your character is in the spot where the battle was occurring, not in the place that you moved to.

So the server isn't accepting the "I want to run away" instruction from the client.

What I *suspect* is happening is that the server is preventing you from disengaging from combat (maybe as a result of a "dice roll"), but the client is not recognizing the "you failed to disengage" message. So I'd call this a "sync" issue (a programming bug), rather than a "lag" issue (a network problem).

(I've been digging through the eAthena server and client sources trying to pin this down, but no luck so far.)
User avatar
Black Don
Warrior
Warrior
Posts: 660
Joined: 06 Feb 2008, 22:30

Re: The New Snake Cave in Eastern desert

Post by Black Don » 12 Apr 2008, 13:48

Could I still call it the lag bug? :P
"Too much of a good thing is an awesome thing, but too much of an awesome thing is, um, really really dumb. And bad." Strong Bad
Post Reply