guichan.framework version 0.8.0

Ask for help regarding any technical issue or report any bug or OS independent issues.
Post Reply
allenmoatallen
Peon
Peon
Posts: 32
Joined: Thu Apr 10, 2008 6:39 pm

guichan.framework version 0.8.0

Post by allenmoatallen » Thu Apr 24, 2008 8:43 pm

Can anyone post either their XCode project for building these frameworks for each release or post a prebuilt .framework with OpenGL support built in?

Thanks!
User avatar
trapdoor
Novice
Novice
Posts: 216
Joined: Sun Feb 18, 2007 1:36 pm

Re: guichan.framework version 0.8.0

Post by trapdoor » Fri Apr 25, 2008 11:12 pm

allenmoatallen
Peon
Peon
Posts: 32
Joined: Thu Apr 10, 2008 6:39 pm

Re: guichan.framework version 0.8.0

Post by allenmoatallen » Sat Apr 26, 2008 8:23 am

Much thanks! I have an issue though, it seems as if the src isn't seeing guichan properly:

Code: Select all

    cd /Users/trevor/Projects/LoMClient/XCode
    /Developer/usr/bin/gcc-4.0 -x c++ -arch i386 -pipe -Wno-trigraphs -fpascal-strings -fasm-blocks -O0 -Wreturn-type -Wunused-variable -fmessage-length=0 -mfix-and-continue -fvisibility-inlines-hidden -gdwarf-2 -I/Users/trevor/Projects/LoMClient/XCode/../../build/LoM_Client.build/Debug/LoM_Client.build/LoM_Client.hmap -F/Users/trevor/Projects/LoMClient/XCode/../../build/Debug -F/Users/trevor/Library/Frameworks -F/Library/Frameworks -I/Users/trevor/Projects/LoMClient/XCode/../../build/Debug/include -I/Library/Frameworks/SDL_ttf.framework/Headers -I/usr/include -I/Library/Frameworks/enet.framework/Headers -I/Users/trevor/Library/Frameworks/SDL_mixer.framework/Headers -I/Users/trevor/Library/Frameworks/SDL.framework/Headers -I/Library/Frameworks/SDL.framework/Headers -I/Users/trevor/Library/Frameworks/SDL.framework/Headers -I/Library/Frameworks/SDL.framework/Headers -I/Library/Frameworks/SDL_mixer.framework/Headers -I/Users/trevor/Library/Frameworks/SDL_image.framework/Headers -I/Library/Frameworks/SDL_image.framework/Headers -I/Library/Frameworks/enet.framework/Headers -I/Library/Frameworks/guichan.framework/Headers -I/Library/Frameworks/libpng.framework/Headers -I/Library/Frameworks/physfs.framework/Headers -I/Users/trevor/Projects/LoMClient/XCode/../../build/LoM_Client.build/Debug/LoM_Client.build/DerivedSources -c /Users/trevor/Projects/LoMClient/XCode/../src/gui/button.cpp -o /Users/trevor/Projects/LoMClient/XCode/../../build/LoM_Client.build/Debug/LoM_Client.build/Objects-normal/i386/button.o
/Users/trevor/Projects/LoMClient/XCode/../src/gui/button.cpp: In member function 'void Button::init()':
/Users/trevor/Projects/LoMClient/XCode/../src/gui/button.cpp:86: error: 'setFrameSize' was not declared in this scope
	/Users/trevor/Projects/LoMClient/XCode/../src/gui/button.cpp:86: error: 'setFrameSize' was not declared in this scope
    cd /Users/trevor/Projects/LoMClient/XCode
    /Developer/usr/bin/gcc-4.0 -x c++ -arch i386 -pipe -Wno-trigraphs -fpascal-strings -fasm-blocks -O0 -Wreturn-type -Wunused-variable -fmessage-length=0 -mfix-and-continue -fvisibility-inlines-hidden -gdwarf-2 -I/Users/trevor/Projects/LoMClient/XCode/../../build/LoM_Client.build/Debug/LoM_Client.build/LoM_Client.hmap -F/Users/trevor/Projects/LoMClient/XCode/../../build/Debug -F/Users/trevor/Library/Frameworks -F/Library/Frameworks -I/Users/trevor/Projects/LoMClient/XCode/../../build/Debug/include -I/Library/Frameworks/SDL_ttf.framework/Headers -I/usr/include -I/Library/Frameworks/enet.framework/Headers -I/Users/trevor/Library/Frameworks/SDL_mixer.framework/Headers -I/Users/trevor/Library/Frameworks/SDL.framework/Headers -I/Library/Frameworks/SDL.framework/Headers -I/Users/trevor/Library/Frameworks/SDL.framework/Headers -I/Library/Frameworks/SDL.framework/Headers -I/Library/Frameworks/SDL_mixer.framework/Headers -I/Users/trevor/Library/Frameworks/SDL_image.framework/Headers -I/Library/Frameworks/SDL_image.framework/Headers -I/Library/Frameworks/enet.framework/Headers -I/Library/Frameworks/guichan.framework/Headers -I/Library/Frameworks/libpng.framework/Headers -I/Library/Frameworks/physfs.framework/Headers -I/Users/trevor/Projects/LoMClient/XCode/../../build/LoM_Client.build/Debug/LoM_Client.build/DerivedSources -c /Users/trevor/Projects/LoMClient/XCode/../src/gui/buy.cpp -o /Users/trevor/Projects/LoMClient/XCode/../../build/LoM_Client.build/Debug/LoM_Client.build/Objects-normal/i386/buy.o
/Users/trevor/Projects/LoMClient/XCode/../src/gui/buy.cpp: In constructor 'BuyDialog::BuyDialog()':
/Users/trevor/Projects/LoMClient/XCode/../src/gui/buy.cpp:75: error: 'class ShopListBox' has no member named 'addSelectionListener'
	/Users/trevor/Projects/LoMClient/XCode/../src/gui/buy.cpp:75: error: 'class ShopListBox' has no member named 'addSelectionListener'
guichan.framework is included/linked like all the others, so I don't understand what it is missing.
User avatar
trapdoor
Novice
Novice
Posts: 216
Joined: Sun Feb 18, 2007 1:36 pm

Re: guichan.framework version 0.8.0

Post by trapdoor » Sat Apr 26, 2008 12:28 pm

Those are problems with the headers. Make sure you are including the correct version.

--
trapdoor
allenmoatallen
Peon
Peon
Posts: 32
Joined: Thu Apr 10, 2008 6:39 pm

Re: guichan.framework version 0.8.0

Post by allenmoatallen » Sat Apr 26, 2008 5:51 pm

Thanks, I tried linking against the .dylib of guichan which worked wonderfully and finally managed to compile my own that worked as well, I don't know why the other versions weren't working. The game starts now but fails with:

Code: Select all

4/26/08 9:45:05 AM [0x0-0xed0ed].com.TMW.TMW[23607] Assertion failed: (mSDLImage), function getPixel, file /Users/trevor/Projects/TMW/XCode/../src/resources/imageloader.cpp, line 70. 
Why is getPixel failing its assertion?
allenmoatallen
Peon
Peon
Posts: 32
Joined: Thu Apr 10, 2008 6:39 pm

Re: guichan.framework version 0.8.0

Post by allenmoatallen » Sat Apr 26, 2008 7:22 pm

Nvm leeor_net solved my problems, thanks!
allenmoatallen
Peon
Peon
Posts: 32
Joined: Thu Apr 10, 2008 6:39 pm

Re: guichan.framework version 0.8.0

Post by allenmoatallen » Sun Apr 27, 2008 10:11 am

Ok, this question pertains to OpenGL in TMW, once you have guichan with opengl support, how are you including opengl in TMW project? you have the <OpenGL/OpenGL.h> includes in the src is that all you need? or is there another parameter to pass? Also with guichan, you do the same thing when compiling from source?
User avatar
trapdoor
Novice
Novice
Posts: 216
Joined: Sun Feb 18, 2007 1:36 pm

Re: guichan.framework version 0.8.0

Post by trapdoor » Sun Apr 27, 2008 11:16 am

You need to define USE_OPENGL.

--
trapdoor
allenmoatallen
Peon
Peon
Posts: 32
Joined: Thu Apr 10, 2008 6:39 pm

Re: guichan.framework version 0.8.0

Post by allenmoatallen » Sun Apr 27, 2008 4:36 pm

Ok, thats what I thought, would that be done by adding a user setting such as:

USE_OPENGL TRUE ?

Or is there a different way to do it?
User avatar
trapdoor
Novice
Novice
Posts: 216
Joined: Sun Feb 18, 2007 1:36 pm

Re: guichan.framework version 0.8.0

Post by trapdoor » Sun Apr 27, 2008 6:33 pm

It doesnt need to be defined as anything, just add -DUSE_OPENGL to the compile line.

--
trapdoor
allenmoatallen
Peon
Peon
Posts: 32
Joined: Thu Apr 10, 2008 6:39 pm

Re: guichan.framework version 0.8.0

Post by allenmoatallen » Mon Apr 28, 2008 10:11 pm

got it! thank you very much!
Post Reply