[RESOLVED] Can't run tmw after upgrading to ubuntu 8.10

Ask for help regarding any technical issue or report any bug or OS independent issues.
Post Reply
User avatar
5t3v3
Novice
Novice
Posts: 451
Joined: 31 Oct 2007, 16:08
Location: Belgium
Contact:

[RESOLVED] Can't run tmw after upgrading to ubuntu 8.10

Post by 5t3v3 » 04 Nov 2008, 17:37

When I run it trough a terminal I get:

Code: Select all

~ $: tmw
tmw: /usr/local/lib/libcurl.so.4: no version information available (required by tmw)
ALSA lib pcm_pulse.c:629:(pulse_prepare) PulseAudio: Unable to create stream: Invalid argument

E: stream.c: Assertion 's' failed at pulse/stream.c:971, function pa_stream_drain(). Aborting.
Aborted
~ $: 
Any suggestions?
Last edited by 5t3v3 on 04 Nov 2008, 21:41, edited 1 time in total.
In game characters: "5t3v3" and "L "
User avatar
Jaxad0127
TMW Adviser
TMW Adviser
Posts: 4209
Joined: 01 Nov 2007, 18:35
Location: Internet

Re: Can't run tmw after upgrading to ubuntu 8.10

Post by Jaxad0127 » 04 Nov 2008, 17:57

Update curl?
Image
User avatar
Ces
Novice
Novice
Posts: 231
Joined: 19 Mar 2008, 23:46
Location: The hemisphere

Re: Can't run tmw after upgrading to ubuntu 8.10

Post by Ces » 04 Nov 2008, 18:40

Not sure if it helps in this specific case, but I updated the Dependencies wiki page for Ubuntu. On a fresh install of Intrepid it works without any trouble for me.
erebe
Peon
Peon
Posts: 49
Joined: 02 Aug 2008, 21:36
Location: France

Re: Can't run tmw after upgrading to ubuntu 8.10

Post by erebe » 04 Nov 2008, 19:51

Hello,

I've meet this problem, I'm trying to find how it was fixed, ( rm a .pulse directory if I remenber well )

erebe
erebe
Peon
Peon
Posts: 49
Joined: 02 Aug 2008, 21:36
Location: France

Re: Can't run tmw after upgrading to ubuntu 8.10

Post by erebe » 04 Nov 2008, 19:54

So

https://bugs.launchpad.net/ubuntu/+sour ... bug/274577

and specially
following some tip here :
http://ubuntuforums.org/showthread.php?t=929641&page=3

I clean ./pulse directory

reboot , and it work
erebe
User avatar
5t3v3
Novice
Novice
Posts: 451
Joined: 31 Oct 2007, 16:08
Location: Belgium
Contact:

Re: Can't run tmw after upgrading to ubuntu 8.10

Post by 5t3v3 » 04 Nov 2008, 21:41

Thanks all for you help, the problem was no the dependencies but audiopulse like erebe said.
However cleaning up /.pulse and resetting didn't do the trick for me. after some googling I found this advice:
sudo killall pulseaudio
sudo alsa force-reload

and them go to System>Preferences>Sound and change everything to ALSA
That did the trick.
In game characters: "5t3v3" and "L "
Post Reply