[FIXED] Segfault

Ask for help regarding any technical issue or report any bug or OS independent issues.
Post Reply
User avatar
Freeyorp101
Administrator
Administrator
Posts: 710
Joined: 04 Nov 2008, 10:17
Location: New Zealand

[FIXED] Segfault

Post by Freeyorp101 » 14 Nov 2008, 05:10

System: Ubuntu 8.10 AMD64

I have been encountering a number of client crashes recently on TMW 0.0.26. I ran a client from a console to see any error output; after ~15mins of playing the game quit:

[User]@[Computer]:~$ tmw
Segmentation fault
[User]@[Computer]:~$

(where [user] and [computer] were my names respectively)

This does not seem to connected to any event (in game) in particular and seems to occur whether or not other programs are running.

Any ideas?

_____________
--Freeyorp
(09:58:17) < tux9th> Freeyorp: your sig on the forums is kind of outdated
User avatar
Jaxad0127
TMW Adviser
TMW Adviser
Posts: 4209
Joined: 01 Nov 2007, 18:35
Location: Internet

Re: Segfault

Post by Jaxad0127 » 14 Nov 2008, 05:15

Please post (or preferably attach or pastebin) this file: ~/.tmw/tmw.log .
Image
User avatar
Freeyorp101
Administrator
Administrator
Posts: 710
Joined: 04 Nov 2008, 10:17
Location: New Zealand

Re: Segfault

Post by Freeyorp101 » 14 Nov 2008, 05:30

Attached...

_____________
--Freeyorp
Attachments
tmw.log
tmw.log
(70.89 KiB) Downloaded 75 times
(09:58:17) < tux9th> Freeyorp: your sig on the forums is kind of outdated
User avatar
Jaxad0127
TMW Adviser
TMW Adviser
Posts: 4209
Joined: 01 Nov 2007, 18:35
Location: Internet

Re: Segfault

Post by Jaxad0127 » 14 Nov 2008, 05:48

Does it only happen when you change maps (right after you appear on the new one)?
Image
User avatar
Freeyorp101
Administrator
Administrator
Posts: 710
Joined: 04 Nov 2008, 10:17
Location: New Zealand

Re: Segfault

Post by Freeyorp101 » 14 Nov 2008, 05:57

Does it only happen when you change maps (right after you appear on the new one)?
Hmm.. I think so, all the ones I remember were a few seconds after changing maps

_____________
--Freeyorp
(09:58:17) < tux9th> Freeyorp: your sig on the forums is kind of outdated
User avatar
Jaxad0127
TMW Adviser
TMW Adviser
Posts: 4209
Joined: 01 Nov 2007, 18:35
Location: Internet

Re: Segfault

Post by Jaxad0127 » 14 Nov 2008, 06:08

It's a known bug in 0.0.26. It's already been fixed, and so will be in the next version. If you want, you can compile the current development version.
Image
User avatar
Freeyorp101
Administrator
Administrator
Posts: 710
Joined: 04 Nov 2008, 10:17
Location: New Zealand

Re: Segfault

Post by Freeyorp101 » 14 Nov 2008, 22:27

Will do. :) Thanks!

_____________
--Freeyorp
(09:58:17) < tux9th> Freeyorp: your sig on the forums is kind of outdated
Post Reply