Compiling Server and Getting Admin Site Running

Content and general development discussion, including maps, quests, and server code from the development team.
Post Reply
YellowShadow
Peon
Peon
Posts: 6
Joined: 16 Nov 2008, 08:34

Compiling Server and Getting Admin Site Running

Post by YellowShadow » 16 Nov 2008, 08:37

Hey guys,

I've been trying to figure out how to compile the server and install and run the admin site. I just finished getting the git repository all over again so I have a fresh clean code checkout to work with.

Is there an easy way to get all the dependencies for the server so I won't have to go hunting for them and compiling them?

Also, how do I setup the sql database? I'm using MySQL with phpMyAdmin.

Can anyone point me to any documentation/tutorials regarding setting these two things up? Also any help here would be appreciated.

Thanks,
YellowShadow
YellowShadow
Peon
Peon
Posts: 6
Joined: 16 Nov 2008, 08:34

Re: Compiling Server and Getting Admin Site Running

Post by YellowShadow » 16 Nov 2008, 17:07

Thank you so much!
YellowShadow
Peon
Peon
Posts: 6
Joined: 16 Nov 2008, 08:34

Re: Compiling Server and Getting Admin Site Running

Post by YellowShadow » 16 Nov 2008, 17:43

I ran into another problem. When I execute the createTables.sql thing I get this error:

Code: Select all

SQL query:

INSERT INTO tmw_world_states
VALUES (
'accountserver_startup', NULL , NULL , 1226042339
);

MySQL said: Documentation
#1048 - Column 'value' cannot be null 
And it doesn't finish creating all the tables.

What should I do?
Exceptionfault
Peon
Peon
Posts: 21
Joined: 20 Jul 2008, 16:46
Location: Germany
Contact:

Re: Compiling Server and Getting Admin Site Running

Post by Exceptionfault » 17 Nov 2008, 09:34

You found a bug in the mySQL scripts.

Please replace the create table command for the table `tmw_world_states`with the following:
Value column should be nullable.

Code: Select all

CREATE TABLE IF NOT EXISTS `tmw_world_states` (
   `state_name`    varchar(100)              NOT NULL,
   `map_id`        int(10) unsigned default      NULL,
   `value`         varchar(255)      default     NULL,
   `moddate` int(10) unsigned                NOT NULL,
   --
   KEY `state_name` (`state_name`)
) ENGINE=InnoDB
DEFAULT CHARSET=utf8;
Never say: "Always"! Always say: "Never say never"! - Tom Kyte @ Ask Tom Live in Berlin 2008

Image
YellowShadow
Peon
Peon
Posts: 6
Joined: 16 Nov 2008, 08:34

Re: Compiling Server and Getting Admin Site Running

Post by YellowShadow » 18 Nov 2008, 00:55

Thanks Exceptionfault :)
YellowShadow
Peon
Peon
Posts: 6
Joined: 16 Nov 2008, 08:34

Re: Compiling Server and Getting Admin Site Running

Post by YellowShadow » 19 Nov 2008, 02:39

I get some new errors when compiling the accountserver.

http://pastebin.com/m2ffa93b9

Can anyone help?
Post Reply