Compile Error?

Ask for help regarding any technical issue or report any bug or OS independent issues.
Post Reply
BobSongs
Peon
Peon
Posts: 7
Joined: Wed Jan 07, 2009 4:51 pm

Compile Error?

Post by BobSongs » Wed Jan 07, 2009 5:00 pm

Greetings. First post.

Wanna say: game is fun.

I'm using Ubuntu Linux, Hardy Heron, 8.04. I'm trying to compile, from source code, an updated copy.

1. After running ./configure (in the correct directory), the last line output is:

Code: Select all

configure complete, now type "make".
2. The last output of make is:

Code: Select all

In file included from gui/buddywindow.h:27,
                 from gui/buddywindow.cpp:22:
gui/window.h:26:38: error: guichan/widgetlistener.hpp: No such file or directory
In file included from gui/buddywindow.h:27,
                 from gui/buddywindow.cpp:22:
gui/window.h:44: error: expected class-name before ‘{’ token
make[2]: *** [tmw-buddywindow.o] Error 1
make[2]: Leaving directory `/home/robert/Downloads/tmw-0.0.27/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/robert/Downloads/tmw-0.0.27'
make: *** [all] Error 2
The line: gui/window.h:44: error: expected class-name before ‘{’ token seems to throw a fatal error.

Any ideas? All the dependencies seem to be met.
User avatar
Jaxad0127
TMW Adviser
TMW Adviser
Posts: 4209
Joined: Thu Nov 01, 2007 6:35 pm
Location: Internet

Re: Compile Error?

Post by Jaxad0127 » Wed Jan 07, 2009 5:11 pm

You need a newer version of one of the libraries than Hardy has. This will help: http://wiki.themanaworld.org/index.php/ ... ompilation.
Image
BobSongs
Peon
Peon
Posts: 7
Joined: Wed Jan 07, 2009 4:51 pm

Re: Compile Error?

Post by BobSongs » Wed Jan 07, 2009 5:39 pm

jaxad0127 wrote:You need a newer version of one of the libraries than Hardy has. This will help: http://wiki.themanaworld.org/index.php/ ... ompilation.
I think you're right. I was just trying to install the newer version of tmw from the Ubuntu repositories, and they kept whining about wanting more recent libraries.

So, in a sense, I got roughly the same answer from my own efforts. :roll:

But, many thanks. I guess I have to decide whether I hang on to Hardy, or invest in Intrepid. :)
User avatar
Platyna
Knight
Knight
Posts: 2213
Joined: Sat Nov 19, 2005 2:19 pm
Location: Poland
Contact:

Re: Compile Error?

Post by Platyna » Wed Jan 07, 2009 6:30 pm

First post and already you have managed to step on moderator's toes by posting in wrong section. ;-}

Regards.
Zuzanna K. Filutowska
[The rest of this signature was censored by TMWC's "Freedom" and "Free speech".]
User avatar
kr0n05931
Warrior
Warrior
Posts: 652
Joined: Sat Jul 26, 2008 2:59 am
Location: United Socialist States of America
Contact:

Re: Compile Error?

Post by kr0n05931 » Wed Jan 07, 2009 11:27 pm

BobSongs wrote:
jaxad0127 wrote:You need a newer version of one of the libraries than Hardy has. This will help: http://wiki.themanaworld.org/index.php/ ... ompilation.
I think you're right. I was just trying to install the newer version of tmw from the Ubuntu repositories, and they kept whining about wanting more recent libraries.

So, in a sense, I got roughly the same answer from my own efforts. :roll:

But, many thanks. I guess I have to decide whether I hang on to Hardy, or invest in Intrepid. :)
There is no need to give up hardy! I have prepared a script for the compilation that will do everything for you. Just make sure you have an internet connection when you run the scripts. And read the post required thoroughly.

http://forums.themanaworld.org/viewtopic.php?f=7&t=5498

:D
Lazy bum.
BobSongs
Peon
Peon
Posts: 7
Joined: Wed Jan 07, 2009 4:51 pm

Re: Compile Error?

Post by BobSongs » Fri Jan 16, 2009 5:58 pm

Platyna wrote:First post and already you have managed to step on moderator's toes by posting in wrong section. ;-}

Regards.
Ahh. Forgive me for connecting "Linux/Unix support, All posts regarding problems in a Unix environment" with a Linux compile error.

You'll notice it says: "First Post".

The best way to answer is: "While you are posting in an area that seems to support the kind of question you're asking, it still isn't quite accurate. However, being your first post, try checking out this answer written by 'kr0n05931' in which he deals with the subject you brought up. By the way, your post should have been posted in 'blah'."

Yes?
Last edited by BobSongs on Fri Jan 16, 2009 6:07 pm, edited 1 time in total.
BobSongs
Peon
Peon
Posts: 7
Joined: Wed Jan 07, 2009 4:51 pm

Re: Compile Error?

Post by BobSongs » Fri Jan 16, 2009 6:00 pm

kr0n05931 wrote:
BobSongs wrote:
jaxad0127 wrote:You need a newer version of one of the libraries than Hardy has. This will help: http://wiki.themanaworld.org/index.php/ ... ompilation.
I think you're right. I was just trying to install the newer version of tmw from the Ubuntu repositories, and they kept whining about wanting more recent libraries.

So, in a sense, I got roughly the same answer from my own efforts. :roll:

But, many thanks. I guess I have to decide whether I hang on to Hardy, or invest in Intrepid. :)
There is no need to give up hardy! I have prepared a script for the compilation that will do everything for you. Just make sure you have an internet connection when you run the scripts. And read the post required thoroughly.

http://forums.themanaworld.org/viewtopic.php?f=7&t=5498

:D
Ahh. Now that's how to answer a post.

Much appreciated.
Post Reply