New TMW Mac binary

Ask for help regarding any technical issue or report any bug or OS independent issues.
Blorx2
Peon
Peon
Posts: 60
Joined: 13 Mar 2005, 14:10
Location: Florence, SC
Contact:

New TMW Mac binary

Post by Blorx2 » 15 May 2005, 01:16

Tell me if anything's missing...It's not really new but I included some .dylibs for you to put in /usr/local/lib . If it does not launch, check the console. If it says it's missing something, post here. I will try to get a new binary soon.

http://freewebs.com/blorx22/The%20Mana%20World.zip
"A wizard is never late, nor is he early, he arrives precisely when he needs to" - Gandalf
User avatar
ElvenProgrammer
TMW Adviser
TMW Adviser
Posts: 2526
Joined: 13 Apr 2004, 20:11
Location: Italy
Contact:

Post by ElvenProgrammer » 15 May 2005, 10:50

Great work :D
User avatar
Talaroc
Novice
Novice
Posts: 429
Joined: 10 Feb 2005, 05:23
Location: The Frozen North
Contact:

Post by Talaroc » 15 May 2005, 11:36

Sorry, still won't work on my machine. Cracking open terminal, I got the same error message as before ("dyld: /Users/arashi86/Desktop/ManaWorld.app/Contents/Resources/tmw can't open library: /usr/local//lib/libguichan_sdl.0.dylib (No such file or directory, errno = 2)"). Two things I notice that may be causing this glitchiness:
* I didn't, until making one specifically for this, have a "lib" folder in /usr/local. There's a "lib" folder in /usr, as well as a "local" folder, but they're on the same level. Currently, "/usr/local" is totally empty, whereas "/usr/lib" is where a bunch of other .dylibs are stored.
* I notice in the path described in the error message, there's a double slash between local and lib. I'm not a programmer, so this could be perfectly fine, but I've never seen anything other than the single slash when denoting file pathways, so I thought I'd point it out.

Hope that helps.
Blorx2
Peon
Peon
Posts: 60
Joined: 13 Mar 2005, 14:10
Location: Florence, SC
Contact:

Post by Blorx2 » 15 May 2005, 15:56

The double slash doesn't matter...just go to /usr/local/lib and store them there...I would get a new version done but I'm not sure that I have some files in the right place and it won't pick up libxml
"A wizard is never late, nor is he early, he arrives precisely when he needs to" - Gandalf
User avatar
Talaroc
Novice
Novice
Posts: 429
Joined: 10 Feb 2005, 05:23
Location: The Frozen North
Contact:

Post by Talaroc » 15 May 2005, 18:46

When I made the "lib" folder to get the path correct and put in the files, it still came up with the same error.
Blorx2
Peon
Peon
Posts: 60
Joined: 13 Mar 2005, 14:10
Location: Florence, SC
Contact:

Post by Blorx2 » 15 May 2005, 19:10

Hmm...I'll get my dad to try it on his com later...See if it works
"A wizard is never late, nor is he early, he arrives precisely when he needs to" - Gandalf
User avatar
Talaroc
Novice
Novice
Posts: 429
Joined: 10 Feb 2005, 05:23
Location: The Frozen North
Contact:

Post by Talaroc » 15 May 2005, 19:22

Update: I fixed that particular problem (the issue was that there was a space at the end of the filename for libguichan_sdl.0.dylib, which was also incidentally true of libphysfs-1.0.0.dylib), but am now running into a different one--the terminal error says it is missing libguichan.0.dylib (needs to be in the same folder as the other three).
User avatar
ElvenProgrammer
TMW Adviser
TMW Adviser
Posts: 2526
Joined: 13 Apr 2004, 20:11
Location: Italy
Contact:

Post by ElvenProgrammer » 15 May 2005, 19:36

I think we're on the right way, but still guichan giving issues... :(
Blorx2
Peon
Peon
Posts: 60
Joined: 13 Mar 2005, 14:10
Location: Florence, SC
Contact:

Post by Blorx2 » 15 May 2005, 21:54

I have it uploaded with the missing file. Report if any more are missing. Remember, Catfish made this, I've been having issues with the library. I've also been having issues with the _M to make an account thing...it says unregistered. Oh well, here's the link
http://freewebs.com/blorx22/The%20Mana%20World.sit
"A wizard is never late, nor is he early, he arrives precisely when he needs to" - Gandalf
Catfish_Man
Peon
Peon
Posts: 52
Joined: 07 Mar 2005, 04:15
Location: Portland, OR, USA
Contact:

Post by Catfish_Man » 16 May 2005, 04:38

Yeah, my guess is that it's because the binary is rather old. I'll do my best to unbreak my build setup (I kinda messed up my libraries trying to fix linking issues) and make a new one.
User avatar
Talaroc
Novice
Novice
Posts: 429
Joined: 10 Feb 2005, 05:23
Location: The Frozen North
Contact:

Post by Talaroc » 16 May 2005, 05:19

Please do. Now it's asking for /sw/lib/libSDL-1.2.0.dylib (there is no file named sw anywhere on my computer).
Blorx2
Peon
Peon
Posts: 60
Joined: 13 Mar 2005, 14:10
Location: Florence, SC
Contact:

Post by Blorx2 » 31 May 2005, 17:55

Install SDL and SDL_image is all I can say
"A wizard is never late, nor is he early, he arrives precisely when he needs to" - Gandalf
User avatar
ElvenProgrammer
TMW Adviser
TMW Adviser
Posts: 2526
Joined: 13 Apr 2004, 20:11
Location: Italy
Contact:

Post by ElvenProgrammer » 03 Jun 2005, 16:38

Blorx, it seems time is ready to build a mac package for the next release?
Catfish_Man
Peon
Peon
Posts: 52
Joined: 07 Mar 2005, 04:15
Location: Portland, OR, USA
Contact:

Post by Catfish_Man » 03 Jun 2005, 18:38

As far as I know, there isn't currently anyone who can build the latest source; Blorx was working from my 0.11-era binary, and my build setup is screwed up and I haven't worked out how to fix it.
User avatar
ElvenProgrammer
TMW Adviser
TMW Adviser
Posts: 2526
Joined: 13 Apr 2004, 20:11
Location: Italy
Contact:

Post by ElvenProgrammer » 03 Jun 2005, 18:48

I guess we should start all over again, and try to compile all the dependencies
Post Reply