Not sure, can't see log in on start of game. (SOLVED)

Ask for help regarding any technical issue or report any bug or OS independent issues.
Post Reply
Dies
Peon
Peon
Posts: 1
Joined: 31 Jan 2009, 23:19

Not sure, can't see log in on start of game. (SOLVED)

Post by Dies » 31 Jan 2009, 23:25

Hello, tried game last night and its pretty cool.
While in game and exploring I noticed I could change the resolution to 1024 768 so I did. It did not click so I hit it a few more times. Finally I noticed the apply button and then the screen went full.
That was cool, however after trying to log back in, I noticed that the game starts full screen however the log in box is nowhere to be found. I see one error in the TMW log.
I can post the TMW Log here it is.
I put Oops smileys behind the error I see.
Thanks for looking and help. I usually would just move on and remove the game but this one seems to good to let go without a little trouble.
Dies.

[22:09:57.05] Starting The Mana World Version 0.0.26
[22:09:57.05] Initializing SDL...
[22:09:57.16] Initializing resource manager...
[22:09:57.16] Adding to PhysicsFS: /home/mikem//.tmw
[22:09:57.16] Adding to PhysicsFS: data
[22:09:57.16] Error: File not found
[22:09:57.16] Adding to PhysicsFS: /usr/share/games/tmw/data
[22:09:57.16] Initializing configuration...
[22:09:57.16] Setting video mode 800x600 fullscreen
[22:09:57.35] Using OpenGL with double buffering.
[22:09:57.35] OpenGL texture size: 512 pixels
[22:09:57.35] Initializing GUI...
[22:09:57.35] Loaded /usr/share/games/tmw/data/graphics/gui/sansserif8.png
[22:09:57.35] Loaded /usr/share/games/tmw/data/graphics/gui/rpgfont_wider.png
[22:09:57.35] Loaded /usr/share/games/tmw/data/graphics/gui/hits_red.png
[22:09:57.36] Loaded /usr/share/games/tmw/data/graphics/gui/hits_blue.png
[22:09:57.36] Loaded /usr/share/games/tmw/data/graphics/gui/hits_yellow.png
[22:09:57.36] Loaded /usr/share/games/tmw/data/graphics/gui/mouse.png
[22:09:57.36] Window::Window("Window")
[22:09:57.36] Loaded /usr/share/games/tmw/data/graphics/gui/vscroll_grey.png
[22:09:57.36] Loaded /usr/share/games/tmw/data/graphics/gui/bg_quad_dis.png
[22:09:57.36] Loaded /usr/share/games/tmw/data/graphics/gui/close_button.png
[22:09:57.36] Loaded /usr/share/games/tmw/data/graphics/gui/browserfont.png
[22:09:57.36] Loaded /usr/share/games/tmw/data/graphics/gui/target-cursor-blue-s.png
[22:09:57.37] Loaded /usr/share/games/tmw/data/graphics/gui/target-cursor-red-s.png
[22:09:57.37] Loaded /usr/share/games/tmw/data/graphics/gui/target-cursor-blue-m.png
[22:09:57.37] Loaded /usr/share/games/tmw/data/graphics/gui/target-cursor-red-m.png
[22:09:57.37] Loaded /usr/share/games/tmw/data/graphics/gui/target-cursor-blue-l.png
[22:09:57.38] Loaded /usr/share/games/tmw/data/graphics/gui/target-cursor-red-l.png
[22:09:57.38] Sound::init() Initializing sound...
[22:09:57.39] Sound::info() SDL_mixer: 1.2.8 (compiled)
[22:09:57.40] Sound::info() SDL_mixer: 1.2.8 (linked)
[22:09:57.40] Sound::info() Driver: alsa
[22:09:57.40] Sound::info() Format: S16LSB
[22:09:57.40] Sound::info() Rate: 22050
[22:09:57.40] Sound::info() Channels: 2
[22:09:57.40] Sound::startMusic() Playing "/usr/share/games/tmw/data/music/Magick - Real.ogg" -1 times
[22:09:57.40] Loaded /usr/share/games/tmw/data/graphics/images/login_wallpaper.png
[22:09:57.49] Warning: image too large, cropping to 800x600 texture! :oops: :oops: :oops:
[22:09:57.50] State: LOGIN
[22:09:57.50] Window::Window("Login")
[22:09:57.50] Loaded /usr/share/games/tmw/data/graphics/gui/deepbox.png
[22:09:57.50] Loaded /usr/share/games/tmw/data/graphics/gui/checkbox.png
[22:09:57.50] Loaded /usr/share/games/tmw/data/graphics/gui/button.png
[22:09:57.50] Loaded /usr/share/games/tmw/data/graphics/gui/buttonhi.png
[22:09:57.50] Loaded /usr/share/games/tmw/data/graphics/gui/buttonpress.png
[22:09:57.50] Loaded /usr/share/games/tmw/data/graphics/gui/button_disabled.png
[22:10:04.21] Window::~Window("Login")
[22:10:04.21] State: EXIT
[22:10:04.21] Configuration::write() writing configuration...
[22:10:04.21] Window::~Window("Window")
[22:10:04.21] Sound::stopMusic()
[22:10:04.21] Sound::close() Shutting down sound...
[22:10:04.27] Unloading item database...
[22:10:04.27] ResourceManager::~ResourceManager() cleaning up 1 reference to graphics/images/login_wallpaper.png

Solution was in linux forum, thanks.
Open ~/.tmw/config.xml and set the option 'screen' to '0'. If this does not work, you can delete the config.xml and TMW will get back to the default settings.
Last edited by Dies on 31 Jan 2009, 23:34, edited 1 time in total.
User avatar
EJlol
Developer
Developer
Posts: 1084
Joined: 06 Sep 2005, 09:42

Re: Not sure, can't see log in on start of game.

Post by EJlol » 31 Jan 2009, 23:33

that shouldn't be problem. You could always try to delete the config.xml. This can be found in some kind of hidden tmw directory. (Im not a linux expert, so i dont know the exact location :P , directory should be called ".tmw")

EDIT: try ~/.tmw/config.xml :wink:
Post Reply