Acer Aspire One:LinpusLite install/uninstall scripts for TMW

Ask for help regarding any technical issue or report any bug or OS independent issues.
Post Reply
Zorofroozo
Peon
Peon
Posts: 5
Joined: 21 Jan 2009, 14:59

Acer Aspire One:LinpusLite install/uninstall scripts for TMW

Post by Zorofroozo » 02 Feb 2009, 12:48

edited for version 28;)

first try the game, Acer has created a simple installer. just unzip and install. problem with this file is that it is an old version. It is unsupported and has some isues, your character is also without clothes and hair. As thus, for the complete experience, follow my guidelines;)

[REPORTED PROBLEMS]

None atm :)

Fixed issues
Script shows errors during configure step while trying to compile tmw 21-01-09 FIXED@30-01-09


first get the newest repositories if you haven't yet done so

"About a month ago there was an intrusion into Fedora servers, and while the signing key for all packages was not compromised Fedora still decided to resign all packages with a new key as a security measure. A few days ago repositories with the new key have gone live. That leads to quite a few unresolved dependency problems if you're still using the default repositories on Acer Aspire One Linux, which are not updated anymore. To switch to the new repositories just use the command below which will enable updates-newkey and automatically get all new packages from there." [thx macles ^^]

do

Code: Select all

sudo yum install fedora-release
now for some extra repositories you'll need the rpmfusion repo and the kwizzart testing repo (rpmfusion replaces livna)

Code: Select all

sudo -c 'rpm -Uvh http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm'

Code: Select all

sudo rpm -Uvh http://rpms.kwizart.net/kwizart-release-8.rpm

Code: Select all

sudo yum install --enablerepo=kwizart-testing

then do

Code: Select all

sudo yum install imake automake make gcc gcc-c++ curl-devel SDL-devel SDL_gfx-devel SDL_image-devel SDL_mixer-devel SDL_ttf-devel SDL_net-devel physfs-devel libxml2-devel
this should install the devel packages and because the needed packages for the devel are missing, it'll add them to, press "y" and let it download and install them

press alt+f2 and then type

Code: Select all

mousepad
or use any other text editor and then make a file called tmw28install.sh in the directory /home/user/Desktop/ with the following code

if you get errors here, wich you shouldn't, leave me a reply or pm

Code: Select all

# This is the tmw ALPHA1 install script, for version 0.0.28 of tmw, and
# 0.8.1 of guichan.
# This script is especially made for Ubuntu/Kubuntu/Xubuntu Hardy Heron & Intrepid Ibex
# and then edited by Zorofroozo to work under Linpus linux lite for the Acer Aspire One
# The original script is licensed under the GPL v.2
# The contributors and creators to/of this script disclaim
# all warranties and liability, and are not responsible for damages/losses
# of any kind.
# bash, wget, and tar are required for this script.
# this script is an adapted version from the tmw forum: http://forums.themanaworld.org/viewtopic.php?f=7&t=5498
# many thanks for original script to kr0n05931 and Platyna

mkdir ~/.programs
mkdir ~/.programs/tmw
mkdir ~/.programs/src
cd ~/.programs/src
wget http://guichan.googlecode.com/files/guichan-0.8.1.tar.gz
tar -vzxf guichan-0.8.1.tar.gz
cd guichan-0.8.1
./configure --prefix=$HOME/.programs/tmw
make
make install
cd ~/.programs/src
wget http://downloads.sourceforge.net/themanaworld/tmw-0.0.28.tar.gz
tar -vzxf tmw-0.0.28.tar.gz
cd tmw-0.0.28
export LDFLAGS="$LDFLAGS -L$HOME/.programs/tmw/lib"
export CPPFLAGS="$CPPFLAGS -I$HOME/.programs/tmw/include"
./configure --prefix=$HOME/.programs/tmw
make
make install
cd ~
then in the directory /home/user/Desktop use the following command in terminal
(use "cd $HOME/desktop" to get there, cd is used to navigate, if you want to go one directory down, type "cd ..")

Code: Select all

chmod u+x tmw28install.sh
this will make the file executable, then run the script by using the following command

Code: Select all

./tmw28install.sh
in /home/user/Desktop

Now it will download and install all needed libraries the game The Mana World.

next, you need to create another script called tmw.sh in /home/user/Desktop with this code

Code: Select all

# This is the tmw STABLE run script, for version 0.0.28 of tmw
# This script is licensed under the GPL v.2
# The contributors and creators to/of this script disclaim
# all warranties and liability, and are not responsible for damages/losses # of any kind.
# bash is required for this script.
# this is a copy paste from http://forums.themanaworld.org/viewtopic.php?f=7&t=5498
# many thanks for original script to kr0n05931 and Platyna

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$HOME/.programs/tmw/lib &&
$HOME/.programs/tmw/bin/tmw
then in the directory /home/user/Desktop use the following command in terminal

Code: Select all

chmod u+x tmw.sh
now, to run the game you only need one more step, use this code in terminal

Code: Select all

sudo ln -s /home/user/Desktop/tmw.sh /usr/bin/tmw
this wil create a symbolic link from your tmw.sh script to /user/bin/ so you can simply type "tmw" in the terminal and the game should work perfectly.

As thus, type

Code: Select all

tmw
in terminal and you can play The Mana World

if you want to uninstall the game, use this script, it will leave all the libraries. (only The Mana World and guichan8.1 is removed) You don't want those libraries? okay, look at the bottom of the page.

So once again, you create a script called tmw28uninstall.sh with the following code in th /home/user/Desktop directory

Code: Select all

# This is the tmw STABLE uninstall script, for version 0.0.28 of tmw and 0.8.1 of guichan
# This script is especially made for Ubuntu/Kubuntu/Xubuntu Hardy Heron & Intrepid Ibex
# and then edited by Zorofroozo to work under Linpus linux lite for the Acer Aspire One
# This script is licensed under the GPL v.2
# The contributors and creators to/of this script disclaim
# all warranties and liability, and are not responsible for damages/losses
# of any kind.
# bash and make are required for this script.
# many thanks for original script to kr0n05931 and Platyna

cd ~/.programs/src/tmw-0.0.28
make uninstall
cd ~/.programs/src/guichan-0.8.1
make uninstall
rm /usr/bin/tmw
cd ~/Desktop
rm tmw.sh
rm tmw28install.sh
rm -r -f /home/user/.programs/
then in the directory /home/user/Desktop use the following command in terminal

Code: Select all

chmod u+x tmw28uninstall.sh
then run it using the following code in the /home/user/Desktop/ directory

Code: Select all

./tmw28uninstall.sh
and finally, do

Code: Select all

rm tmw28uninstall.sh
and type "y" to accept

So YOU want to remove the libraries to do ya? then use this command

Code: Select all

sudo yum remove curl-devel SDL-devel SDL_gfx-devel SDL_image-devel SDL_mixer-devel SDL_ttf-devel SDL_net-devel physfs-devel libxml2-devel
You can also remove Imake, automake, make and gcc, but i whould advice against it, unless you're never going to compile a thing again;)

Code: Select all

sudo yum remove imake automake make gcc gcc-c++ curl-devel SDL-devel SDL_gfx-devel SDL_image-devel SDL_mixer-devel SDL_ttf-devel SDL_net-devel physfs-devel libxml2-devel

if it does not work there are some possibility's,
1) you don't have all needed libraries. To know what is mising ou should run "./configure" yourself, so make a smaller script which does everything but ends at the first "./configure" and then do that step yourself, please give me the output of the terminal window.
2) the game does not run, did you create the symlink? Did it compile correctly? Are you using the shell script to run the game or the executable? Did you see any errors in terminal. As allways, a copy-paste from terminal is needed for help
3) others, if so, plz let me know so i can make corrections in the script
Last edited by Zorofroozo on 02 Feb 2009, 13:10, edited 2 times in total.
Zorofroozo
Peon
Peon
Posts: 5
Joined: 21 Jan 2009, 14:59

Re: Acer Aspire One:LinpusLite install/uninstall scripts for TMW

Post by Zorofroozo » 02 Feb 2009, 13:05

let me know if you like it ;)

if you want quick help, got to the acer aspire one user forum
User avatar
prsm
Game Master
Game Master
Posts: 1295
Joined: 24 Mar 2009, 18:18

Re: Acer Aspire One:LinpusLite install/uninstall scripts for TMW

Post by prsm » 21 Apr 2009, 01:37

very excited to see this post, i have been playing mana world on the acer aspire one and hate version 24 (since i use version 28 on windows). so today i went to install it, logged in has root and issued the first command and it passed, the second command....

sudo -c 'rpm -Uvh http://download1.rpmfusion.org/free/fed ... noarch.rpm http://download1.rpmfusion.org/nonfree/ ... noarch.rpm'

failed with the following response....

[root@localhost ~]# sudo -c 'rpm -Uvh http://download1.rpmfusion.org/free/fed ... noarch.rpm http://download1.rpmfusion.org/nonfree/ ... noarch.rpm'
sudo: illegal option `-c'
usage: sudo -h | -K | -k | -L | -l | -V | -v
usage: sudo [-bEHPS] [-p prompt] [-u username|#uid] [VAR=value]
{-i | -s | <command>}
usage: sudo -e [-S] [-p prompt] [-u username|#uid] file ...
[root@localhost ~]#


what do you recommend........
Let's judge each man by his actions, not his color.
User avatar
Jaxad0127
TMW Adviser
TMW Adviser
Posts: 4209
Joined: 01 Nov 2007, 18:35
Location: Internet

Re: Acer Aspire One:LinpusLite install/uninstall scripts for TMW

Post by Jaxad0127 » 21 Apr 2009, 02:02

su takes -c and a command
sudo just takes the command
Image
henryj0n4s
Peon
Peon
Posts: 1
Joined: 05 May 2009, 17:31

Re: Acer Aspire One:LinpusLite install/uninstall scripts for TMW

Post by henryj0n4s » 05 May 2009, 17:32

Error: Equipment Database: Could not find equipment.xml!
User avatar
Jaxad0127
TMW Adviser
TMW Adviser
Posts: 4209
Joined: 01 Nov 2007, 18:35
Location: Internet

Re: Acer Aspire One:LinpusLite install/uninstall scripts for TMW

Post by Jaxad0127 » 05 May 2009, 18:40

That file was removed a long time ago. No current version of the client needs it. Even if we provided it again, you'll want to update, as the game will be hard to play.
Image
Happyrain
Peon
Peon
Posts: 1
Joined: 16 May 2009, 09:38

Re: Acer Aspire One:LinpusLite install/uninstall scripts for TMW

Post by Happyrain » 16 May 2009, 09:45

Hi, the command to below gave an error:
sudo yum install --enablerepo=kwizart-testing


[root@localhost ~]# sudo yum install --enablerepo=kwizart-testing
Error: Need to pass a list of pkgs to install
Usage: yum [options] < grouplist, localinstall, groupinfo, localupdate, resolvedep, erase, deplist, groupremove, makecache, upgrade, provides, shell, install, whatprovides, groupinstall, update, repolist, groupupdate, info, search, check-update, list, remove, clean, grouperase >

Options:
-h, --help show this help message and exit
-t, --tolerant be tolerant of errors
-C run entirely from cache, don't update cache
-c [config file] config file location
-R [minutes] maximum command wait time
-d [debug level] debugging output level
-e [error level] error output level
-q, --quiet quiet operation
-v, --verbose verbose operation
-y answer yes for all questions
--version show Yum version and exit
--installroot=[path] set install root
--enablerepo=[repo] enable one or more repositories (wildcards allowed)
--disablerepo=[repo] disable one or more repositories (wildcards allowed)
-x [package], --exclude=[package]
exclude package(s) by name or glob
--obsoletes enable obsoletes processing during updates
--noplugins disable Yum plugins
--nogpgcheck disable gpg signature checking
--disableplugin=[plugin]
disable plugins by name

All the previous commands could be made to work. (sudo - c error was resolved by removing the sudo and running as root)
miksu
Peon
Peon
Posts: 1
Joined: 09 Jul 2009, 17:04

Re: Acer Aspire One:LinpusLite install/uninstall scripts for TMW

Post by miksu » 13 Jul 2009, 11:01

Not woking. :(

Code: Select all

[user@localhost Desktop]$ sudo yum install imake automake make gcc gcc-c++ curl-devel SDL-devel SDL_gfx-devel SDL_image-devel SDL_mixer-devel SDL_ttf-devel SDL_net-devel physfs-devel libxml2-devel
Loading "priorities" plugin
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package SDL_gfx-devel.i386 0:2.0.16-4.fc8 set to be updated
---> Package gcc.i386 0:4.1.2-33 set to be updated
--> Processing Dependency: glibc-devel >= 2.2.90-12 for package: gcc
---> Package SDL-devel.i386 0:1.2.13-2.fc8 set to be updated
--> Processing Dependency: SDL = 1.2.13-2.fc8 for package: SDL-devel
--> Processing Dependency: libXrandr-devel for package: SDL-devel
--> Processing Dependency: libGL-devel for package: SDL-devel
--> Processing Dependency: alsa-lib-devel for package: SDL-devel
--> Processing Dependency: libX11-devel for package: SDL-devel
--> Processing Dependency: libXext-devel for package: SDL-devel
--> Processing Dependency: libGLU-devel for package: SDL-devel
--> Processing Dependency: libXrender-devel for package: SDL-devel
---> Package SDL_net-devel.i386 0:1.2.7-3.fc8 set to be updated
---> Package SDL_image-devel.i386 0:1.2.6-5.fc8 set to be updated
---> Package SDL_mixer-devel.i386 0:1.2.8-6.fc8 set to be updated
---> Package gcc-c++.i386 0:4.1.2-33 set to be updated
--> Processing Dependency: libstdc++-devel = 4.1.2-33 for package: gcc-c++
---> Package make.i386 1:3.81-11.fc8 set to be updated
---> Package imake.i386 0:1.0.2-5.fc8 set to be updated
---> Package libxml2-devel.i386 0:2.7.2-2.fc8 set to be updated
--> Processing Dependency: libxml2 = 2.7.2-2.fc8 for package: libxml2-devel
--> Processing Dependency: zlib-devel for package: libxml2-devel
---> Package curl-devel.i386 0:7.18.2-7.fc8 set to be updated
--> Processing Dependency: libidn-devel for package: curl-devel
--> Processing Dependency: curl = 7.18.2-7.fc8 for package: curl-devel
---> Package automake.noarch 0:1.10-6 set to be updated
--> Processing Dependency: autoconf >= 2.58 for package: automake
---> Package SDL_ttf-devel.i386 0:2.0.9-3.fc8 set to be updated
---> Package physfs-devel.i386 0:1.0.1-7.fc8 set to be updated
--> Running transaction check
---> Package mesa-libGLU-devel.i386 0:7.0.2-3.fc8 set to be updated
--> Processing Dependency: mesa-libGLU = 7.0.2-3.fc8 for package: mesa-libGLU-devel
---> Package libXext-devel.i386 0:1.0.1-4.fc8 set to be updated
--> Processing Dependency: xorg-x11-proto-devel >= 7.0-1 for package: libXext-devel
---> Package mesa-libGL-devel.i386 0:7.0.2-3.fc8 set to be updated
--> Processing Dependency: mesa-libGL = 7.0.2-3.fc8 for package: mesa-libGL-devel
---> Package SDL.i386 0:1.2.13-2.fc8 set to be updated
---> Package zlib-devel.i386 0:1.2.3-14.fc8 set to be updated
---> Package libstdc++-devel.i386 0:4.1.2-33 set to be updated
---> Package libXrender-devel.i386 0:0.9.4-1.fc8 set to be updated
---> Package glibc-devel.i386 0:2.7-2 set to be updated
--> Processing Dependency: glibc-headers for package: glibc-devel
--> Processing Dependency: glibc = 2.7-2 for package: glibc-devel
--> Processing Dependency: glibc-headers = 2.7-2 for package: glibc-devel
---> Package libidn-devel.i386 0:0.6.14-4 set to be updated
--> Processing Dependency: libxml2 = 2.6.30-1 for package: libxml2-python
---> Package libxml2.i386 0:2.7.2-2.fc8 set to be updated
---> Package libXrandr-devel.i386 0:1.2.2-1.fc8 set to be updated
---> Package curl.i386 0:7.18.2-7.fc8 set to be updated
--> Processing Dependency: libssh2.so.1 for package: curl
---> Package libX11-devel.i386 0:1.1.3-4.fc8 set to be updated
--> Processing Dependency: libxcb-devel for package: libX11-devel
--> Processing Dependency: libXau-devel for package: libX11-devel
--> Processing Dependency: libXdmcp-devel for package: libX11-devel
---> Package alsa-lib-devel.i386 0:1.0.16-3.fc8 set to be updated
--> Processing Dependency: alsa-lib = 1.0.16-3.fc8 for package: alsa-lib-devel
---> Package autoconf.noarch 0:2.61-9.fc8 set to be updated
--> Running transaction check
---> Package libXau-devel.i386 0:1.0.3-3.fc8 set to be updated
---> Package libXdmcp-devel.i386 0:1.0.2-4.fc8 set to be updated
---> Package xorg-x11-proto-devel.noarch 0:7.3-3.fc8 set to be updated
---> Package alsa-lib.i386 0:1.0.16-3.fc8 set to be updated
---> Package mesa-libGLU.i386 0:7.0.2-3.fc8 set to be updated
---> Package mesa-libGL.i386 0:7.0.2-3.fc8 set to be updated
---> Package glibc.i686 0:2.7-2 set to be updated
--> Processing Dependency: glibc-common = 2.7-2 for package: glibc
---> Package libxcb-devel.i386 0:1.1-1.1.fc8 set to be updated
--> Processing Dependency: libxcb = 1.1-1.1.fc8 for package: libxcb-devel
---> Package libssh2.i386 0:0.18-5.fc8 set to be updated
---> Package libxml2-python.i386 0:2.7.2-2.fc8 set to be updated
---> Package glibc-headers.i386 0:2.7-2 set to be updated
--> Processing Dependency: kernel-headers for package: glibc-headers
--> Processing Dependency: kernel-headers >= 2.2.1 for package: glibc-headers
--> Running transaction check
---> Package glibc.i686 0:2.7-2 set to be updated
--> Processing Dependency: glibc-common = 2.7-2 for package: glibc
---> Package libxcb.i386 0:1.1-1.1.fc8 set to be updated
---> Package kernel-headers.i386 0:2.6.26.8-57.fc8 set to be updated
--> Finished Dependency Resolution
Error: Missing Dependency: glibc-common = 2.7-2 is needed by package glibc
[user@localhost Desktop]$ 
Post Reply