1 compiling error

Ask for help regarding any technical issue or report any bug or OS independent issues.
Post Reply
User avatar
Nooblets
Peon
Peon
Posts: 31
Joined: 08 Jul 2009, 23:26

1 compiling error

Post by Nooblets » 08 Jul 2009, 23:28

Hi I'm trying to compile using codeblocks and I've added all the directories with the lib and include and dll and all I get is this 1 error that I can't figure out what to do to fix it:

Code: Select all

C:\Documents and Settings\Nooblets\Desktop\tmw\src\gui\button.cpp||In member function `void Button::init()':|
C:\Documents and Settings\Nooblets\Desktop\tmw\src\gui\button.cpp|85|error: `setFrameSize' was not declared in this scope|
C:\Documents and Settings\Nooblets\Desktop\tmw\src\gui\button.cpp|85|warning: unused variable 'setFrameSize'|
||=== Build finished: 1 errors, 1 warnings ===|
Marco
Peon
Peon
Posts: 2
Joined: 09 Jul 2009, 00:21

Re: 1 compiling error

Post by Marco » 09 Jul 2009, 00:23

Which version of codeblocks and mingw are you using?
The latest stable version of codeblocks is of the 28 Feb 2008, so it's obsolete.
You should download one of the nightly builds, but they, as nightly builds, aren't really stable.
User avatar
Nooblets
Peon
Peon
Posts: 31
Joined: 08 Jul 2009, 23:26

Re: 1 compiling error

Post by Nooblets » 09 Jul 2009, 01:26

codeblocks 8.02
User avatar
octalot
Novice
Novice
Posts: 214
Joined: 23 Sep 2008, 20:15

Re: 1 compiling error

Post by octalot » 09 Jul 2009, 01:49

Which version of Guichan?
setFrameSize() was added in version 0.8.0
Retired from TMW; incomplete projects looking for a dev:
Cave foliage (plants up the walls): http://forums.themanaworld.org/viewtopic.php?f=8&t=5659
Cave wetwalls (water down the walls): http://forums.themanaworld.org/viewtopic.php?f=8&t=5816
User avatar
Jaxad0127
TMW Adviser
TMW Adviser
Posts: 4209
Joined: 01 Nov 2007, 18:35
Location: Internet

Re: 1 compiling error

Post by Jaxad0127 » 09 Jul 2009, 02:16

octalot wrote:Which version of Guichan?
setFrameSize() was added in version 0.8.0
Older versions should have more problems.
Image
User avatar
Nooblets
Peon
Peon
Posts: 31
Joined: 08 Jul 2009, 23:26

Re: 1 compiling error

Post by Nooblets » 09 Jul 2009, 04:32

Yeah I was testing and commented out that one line then after compiling again there are tons of other things that probably still would need to fix after I figured this one out. So I probably need new version of guichan? I just used what was in the devpack and also what was in the lib pack download. Those don't have current up to date?
User avatar
Jaxad0127
TMW Adviser
TMW Adviser
Posts: 4209
Joined: 01 Nov 2007, 18:35
Location: Internet

Re: 1 compiling error

Post by Jaxad0127 » 09 Jul 2009, 05:36

Nooblets wrote:Yeah I was testing and commented out that one line then after compiling again there are tons of other things that probably still would need to fix after I figured this one out. So I probably need new version of guichan? I just used what was in the devpack and also what was in the lib pack download. Those don't have current up to date?
Did you use the most recent dev pack? http://www.crushnet.org/tmw/tmw_libs.zip
Image
User avatar
Bjørn
TMW Adviser
TMW Adviser
Posts: 1430
Joined: 09 Dec 2004, 19:50
Location: North Rhine-Westphalia, Germany
Contact:

Re: 1 compiling error

Post by Bjørn » 09 Jul 2009, 08:46

If not, it would be interesting to know where you got the devpack from, so that we can remove references to outdated versions.
User avatar
Nooblets
Peon
Peon
Posts: 31
Joined: 08 Jul 2009, 23:26

Re: 1 compiling error

Post by Nooblets » 09 Jul 2009, 09:09

Ok I downloaded the lib pack you posted and updated the directories and now it seems to work but i get this 1 error now. If anyone knows what it is from:

Code: Select all

ld.exe||cannot find -lenet|
||=== Build finished: 1 errors, 0 warnings ===|
Marco
Peon
Peon
Posts: 2
Joined: 09 Jul 2009, 00:21

Re: 1 compiling error

Post by Marco » 09 Jul 2009, 09:56

There isn't the library enet.

However your codeblock version is really old. You should download a nightly build. There is a nightly build of 21 July 2009, instead your version is of 28 february 2008...
I think also your MinGW is old, there is gcc-4.4 now, you should use this
User avatar
Nooblets
Peon
Peon
Posts: 31
Joined: 08 Jul 2009, 23:26

Re: 1 compiling error

Post by Nooblets » 11 Jul 2009, 06:26

Still get the same error. Can you explain why I am getting this better? You confuse me. Am I missing a library or is it the compiler out of date?
User avatar
ElvenProgrammer
TMW Adviser
TMW Adviser
Posts: 2526
Joined: 13 Apr 2004, 20:11
Location: Italy
Contact:

Re: 1 compiling error

Post by ElvenProgrammer » 13 Jul 2009, 08:59

Check your compiler libs folder if theres a libenet.a file inside, or configure Code::Blocks lib path to reach the place where the file is.
User avatar
Nooblets
Peon
Peon
Posts: 31
Joined: 08 Jul 2009, 23:26

Re: 1 compiling error

Post by Nooblets » 13 Jul 2009, 10:06

libenet.a is in the folder where i extracted the tmw_libs and the codeblocks lib folder. I tried adding both to search directories but still get the same error.
Post Reply