Setting up eAthena on Windows

Ask for help regarding any technical issue or report any bug or OS independent issues.
Post Reply
User avatar
Wombat
TMW Adviser
TMW Adviser
Posts: 1532
Joined: 08 Aug 2008, 17:31

Setting up eAthena on Windows

Post by Wombat » 12 Jul 2009, 18:29

Attempting to figure out the problems I’m having with running an eAthena server for TMW game. I’m using the July 10th 2009 history of http://wiki.themanaworld.org/index.php/ ... on_Windows, which is the most current version.

I’ve received some help on IRC from Jax* and others (and thank you for helping). However, I just recently downloaded “notepad++” which may help with some of the problems I was having with the default “notepad” I was using with Windows Vista.

I’m deleting my tmw files again and starting from step 4, though I will say steps 1, 2 and 3 seem to of been completed true to the suggestions in the wiki. I have Cygwin and all the “devel” files installed in an appropriate folder and everything seems to work here.

4.) Start Cygwin
5.) Made tmw folder
6.) Downloaded eathena folder into tmw folder from gitorious.org
7.) Downloaded eathena-data folder into tmw folder from gitorious.org
8.) Entered: cd eathena
9.) Entered: make
10.) (Note: On IRC I’ve received an alternative version of this step. It was to use the eathena-data folder instead of the eathena folder. I’ve tried both and the same problems seem to repeat, so I will stay true to the wiki for this attempt.) I have copied everything from my eathena-data folder into my eathena folder, excluding the .git folder and the files .gitignore and .mailmap
11.) I have copied cygwin1.dll and cygz.dll into the eathena folder
12.1) (Note: There is no save/accounts.txt.example but there is a save/account.txt.example. I assume this is a small error) I have renamed save/account.txt.example to save/account.txt
12.2) (Note: The wiki suggests conf/login_local.conf.example be renamed login_local.conf, which would move the file from the conf folder to the eathena folder. I assume this is a small error.) I renamed conf/login_local.conf.example to conf/login_local.conf
12.3) I renamed conf/char_local.conf.example to conf/char_local.conf and I also entered the IP Address 127.0.0.1 into both the Login Server IP and the Character Server IP
12.4) I renamed conf/map_local.conf.example to conf/map_local.conf
13.) It is char_server.exe that shuts down automatically. I simply went back into the folders and double clicked them open again and all are running.
A.) This could be step 14 to confirm if things are working by logging into the client, but because it isn’t noted as such in the wiki, I’m calling this step A. The client goes through all steps (like all my previous attempts that have gotten this far with this style and the alternative suggestion) but the client stops short at “Connecting to character server”. Checking tmw.log I get the following: http://pastebin.com/m30fe363f and I was informed on IRC by Jax* that this log shows a failure when I’ve shown him my previous attempts.
B.) Assuming this could be a problem with “Character 0” I am shutting down my server. Then I am renaming “Character 0” to a name and hidden password. I assure you that the password I enter are consistent with all files: save/account.txt conf/char_local.conf and conf/map_local.conf
I have shut down my notepad++ after saving and am attempting to reload the servers, starting with login-server.exe then char-server.exe then map-server.exe. All seem to be working the same as before, thus all seem to be working. Now I am loading my client. I again get as far as I did before I changed the name of “Character 0”. I get to “Connecting to character server” in my client and Checking tmw.log I get the following: http://pastebin.com/m504c7efe Below is the log of my servers, account and configuration files:
Login-server: http://pastebin.com/m6dc8ae23
Char-server: http://pastebin.com/m67aeda4e
Map-server: http://pastebin.com/m76687fe
Account.txt: http://pastebin.com/m15ee6e53
Char_local.conf: http://pastebin.com/m389718a6
Map_local.conf: http://pastebin.com/m46e6f30
Current character is "Abolish".
User avatar
Wombat
TMW Adviser
TMW Adviser
Posts: 1532
Joined: 08 Aug 2008, 17:31

Re: Setting up eAthena on Windows

Post by Wombat » 12 Jul 2009, 18:39

I registered a character with my server and it has worked. Thanx again Jax* :D
Current character is "Abolish".
User avatar
Wombat
TMW Adviser
TMW Adviser
Posts: 1532
Joined: 08 Aug 2008, 17:31

Re: Setting up eAthena on Windows

Post by Wombat » 12 Jul 2009, 18:56

http://wiki.themanaworld.org/index.php/ ... on_Windows

The current edit should be clean and provide enough information for someone that has almost no knowledge of how to set up their server to set one up using Windows.
Current character is "Abolish".
Post Reply